gnu: python-pandas: Fix build on 32-bit.
[jackhill/guix/guix.git] / gnu / packages / indent.scm
1 ;;; GNU Guix --- Functional package management for GNU
2 ;;; Copyright © 2013 Andreas Enge <andreas@enge.fr>
3 ;;; Copyright © 2014 Mark H Weaver <mhw@netris.org>
4 ;;;
5 ;;; This file is part of GNU Guix.
6 ;;;
7 ;;; GNU Guix is free software; you can redistribute it and/or modify it
8 ;;; under the terms of the GNU General Public License as published by
9 ;;; the Free Software Foundation; either version 3 of the License, or (at
10 ;;; your option) any later version.
11 ;;;
12 ;;; GNU Guix is distributed in the hope that it will be useful, but
13 ;;; WITHOUT ANY WARRANTY; without even the implied warranty of
14 ;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
15 ;;; GNU General Public License for more details.
16 ;;;
17 ;;; You should have received a copy of the GNU General Public License
18 ;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
19
20 (define-module (gnu packages indent)
21 #:use-module (gnu packages)
22 #:use-module ((guix licenses) #:prefix license:)
23 #:use-module (guix packages)
24 #:use-module (guix download)
25 #:use-module (guix build-system gnu))
26
27 (define-public indent
28 (package
29 (name "indent")
30 (version "2.2.10")
31 (source (origin
32 (method url-fetch)
33 (uri (string-append "mirror://gnu/indent/indent-" version
34 ".tar.gz"))
35 (sha256 (base32
36 "0f9655vqdvfwbxvs1gpa7py8k1z71aqh8hp73f65vazwbfz436wa"))))
37 (build-system gnu-build-system)
38 (arguments
39 `(#:phases (alist-cons-after
40 'unpack 'fix-docdir
41 (lambda _
42 ;; Although indent uses a modern autoconf in which docdir
43 ;; defaults to PREFIX/share/doc, the doc/Makefile.am
44 ;; overrides this to be in PREFIX/doc. Fix this.
45 (substitute* "doc/Makefile.in"
46 (("^docdir = .*$") "docdir = @docdir@\n")))
47 %standard-phases)))
48 (synopsis "Code reformatter")
49 (description
50 "Indent is a program that makes source code easier to read by
51 reformatting it in a consistent style. It can change the style to one of
52 several different styles such as GNU, BSD or K&R. It has some flexibility to
53 deal with incomplete or malformed syntax. GNU indent offers several
54 extensions over the standard utility.")
55 (license license:gpl3+)
56 (home-page "http://www.gnu.org/software/indent/")))