gnu: python-pandas: Fix build on 32-bit.
[jackhill/guix/guix.git] / gnu / packages / icu4c.scm
1 ;;; GNU Guix --- Functional package management for GNU
2 ;;; Copyright © 2013 Andreas Enge <andreas@enge.fr>
3 ;;; Copyright © 2015, 2016 Mark H Weaver <mhw@netris.org>
4 ;;;
5 ;;; This file is part of GNU Guix.
6 ;;;
7 ;;; GNU Guix is free software; you can redistribute it and/or modify it
8 ;;; under the terms of the GNU General Public License as published by
9 ;;; the Free Software Foundation; either version 3 of the License, or (at
10 ;;; your option) any later version.
11 ;;;
12 ;;; GNU Guix is distributed in the hope that it will be useful, but
13 ;;; WITHOUT ANY WARRANTY; without even the implied warranty of
14 ;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
15 ;;; GNU General Public License for more details.
16 ;;;
17 ;;; You should have received a copy of the GNU General Public License
18 ;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
19
20 (define-module (gnu packages icu4c)
21 #:use-module (gnu packages)
22 #:use-module (gnu packages perl)
23 #:use-module (guix licenses)
24 #:use-module (guix packages)
25 #:use-module (guix download)
26 #:use-module (guix build-system gnu))
27
28 (define-public icu4c
29 (package
30 (name "icu4c")
31 (version "55.1")
32 (source (origin
33 (method url-fetch)
34 (uri (string-append
35 "mirror://sourceforge/icu/ICU4C/"
36 version
37 "/icu4c-"
38 (string-map (lambda (x) (if (char=? x #\.) #\_ x)) version)
39 "-src.tgz"))
40 (sha256
41 (base32 "0ys5f5spizg45qlaa31j2lhgry0jka2gfha527n4ndfxxz5j4sz1"))
42 (patches (search-patches "icu4c-CVE-2014-6585.patch"
43 "icu4c-CVE-2015-1270.patch"
44 "icu4c-CVE-2015-4760.patch"))))
45 (build-system gnu-build-system)
46 (inputs
47 `(("perl" ,perl)))
48 (arguments
49 `(#:configure-flags
50 '("--enable-rpath"
51 ,@(if (let ((s (or (%current-target-system)
52 (%current-system))))
53 (or (string-prefix? "arm" s)
54 (string-prefix? "mips" s)))
55 '("--with-data-packaging=archive")
56 '()))
57 #:phases
58 (alist-cons-after
59 'unpack 'chdir-to-source
60 (lambda _ (chdir "source"))
61 (alist-cons-before
62 'configure 'patch-configure
63 (lambda _
64 ;; patch out two occurrences of /bin/sh from configure script
65 ;; that might have disappeared in a release later than 54.1
66 (substitute* "configure"
67 (("`/bin/sh")
68 (string-append "`" (which "bash")))))
69 %standard-phases))))
70 (synopsis "International Components for Unicode")
71 (description
72 "ICU is a set of C/C++ and Java libraries providing Unicode and
73 globalisation support for software applications. This package contains the
74 C/C++ part.")
75 (license x11)
76 (home-page "http://site.icu-project.org/")))