gnu: python-pandas: Fix build on 32-bit.
[jackhill/guix/guix.git] / gnu / packages / groff.scm
1 ;;; GNU Guix --- Functional package management for GNU
2 ;;; Copyright © 2013 Andreas Enge <andreas@enge.fr>
3 ;;; Copyright © 2014 Mark H Weaver <mhw@netris.org>
4 ;;; Copyright © 2016 Ricardo Wurmus <rekado@elephly.net>
5 ;;;
6 ;;; This file is part of GNU Guix.
7 ;;;
8 ;;; GNU Guix is free software; you can redistribute it and/or modify it
9 ;;; under the terms of the GNU General Public License as published by
10 ;;; the Free Software Foundation; either version 3 of the License, or (at
11 ;;; your option) any later version.
12 ;;;
13 ;;; GNU Guix is distributed in the hope that it will be useful, but
14 ;;; WITHOUT ANY WARRANTY; without even the implied warranty of
15 ;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
16 ;;; GNU General Public License for more details.
17 ;;;
18 ;;; You should have received a copy of the GNU General Public License
19 ;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
20
21 (define-module (gnu packages groff)
22 #:use-module (guix licenses)
23 #:use-module (guix packages)
24 #:use-module (guix download)
25 #:use-module (guix git-download)
26 #:use-module (guix build-system gnu)
27 #:use-module (gnu packages)
28 #:use-module (gnu packages bison)
29 #:use-module (gnu packages ghostscript)
30 #:use-module (gnu packages netpbm)
31 #:use-module (gnu packages perl)
32 #:use-module (gnu packages texinfo))
33
34 (define-public groff
35 (package
36 (name "groff")
37 (version "1.22.3")
38 (source (origin
39 (method url-fetch)
40 (uri (string-append "mirror://gnu/groff/groff-" version
41 ".tar.gz"))
42 (sha256 (base32
43 "1998v2kcs288d3y7kfxpvl369nqi06zbbvjzafyvyl3pr7bajj1s"))))
44 (build-system gnu-build-system)
45 (outputs '("out"
46 "doc")) ;12MiB of PS, PDF, HTML, and examples
47 (inputs `(("ghostscript" ,ghostscript)
48 ("netpbm" ,netpbm)))
49 (native-inputs `(("bison" ,bison)
50 ("perl" ,perl)
51 ("psutils" ,psutils)
52 ("texinfo" ,texinfo)))
53 (arguments '(#:parallel-build? #f)) ; parallel build fails
54 (synopsis "Typesetting from plain text mixed with formatting commands")
55 (description
56 "Groff is a typesetting package that reads plain text and produces
57 formatted output based on formatting commands contained within the text. It
58 is usually the formatter of \"man\" documentation pages.")
59 (license gpl3+)
60 (home-page "http://www.gnu.org/software/groff/")))
61
62 ;; There are no releases, so we take the latest commit.
63 (define-public roffit
64 (let ((commit "e5228388e3faf2b7f1ae5bd048ad46ed565304c6")
65 (revision "1"))
66 (package
67 (name "roffit")
68 (version (string-append "0.11-" revision "." (string-take commit 9)))
69 (source (origin
70 (method git-fetch)
71 (uri (git-reference
72 (url "https://github.com/bagder/roffit.git")
73 (commit commit)))
74 (file-name (string-append "roffit-" commit "-checkout"))
75 (sha256
76 (base32
77 "1y7ndbqciy7h0khlpi1bv4v1614vhybnmm4jysj6fwxkw9cwv1nc"))))
78 (build-system gnu-build-system)
79 (arguments
80 `(#:test-target "test"
81 #:make-flags
82 (list (string-append "INSTALLDIR="
83 (assoc-ref %outputs "out") "/bin"))
84 #:phases
85 (modify-phases %standard-phases
86 (delete 'configure)
87 (add-before 'install 'pre-install
88 (lambda* (#:key outputs #:allow-other-keys)
89 (mkdir-p (string-append (assoc-ref outputs "out")
90 "/bin"))
91 #t)))))
92 (inputs
93 `(("perl" ,perl)))
94 (home-page "https://daniel.haxx.se/projects/roffit/")
95 (synopsis "Convert nroff files to HTML")
96 (description
97 "Roffit is a program that reads an nroff file and outputs an HTML file.
98 It is typically used to display man pages on a web site.")
99 (license expat))))