gnu: python-pandas: Fix build on 32-bit.
[jackhill/guix/guix.git] / gnu / packages / gnu-pw-mgr.scm
1 ;;; GNU Guix --- Functional package management for GNU
2 ;;; Copyright © 2013 Eric Bavier <bavier@member.fsf.org>
3 ;;; Copyright © 2015 Mark H Weaver <mhw@netris.org>
4 ;;; Copyright © 2016 Efraim Flashner <efraim@flashner.co.il>
5 ;;;
6 ;;; This file is part of GNU Guix.
7 ;;;
8 ;;; GNU Guix is free software; you can redistribute it and/or modify it
9 ;;; under the terms of the GNU General Public License as published by
10 ;;; the Free Software Foundation; either version 3 of the License, or (at
11 ;;; your option) any later version.
12 ;;;
13 ;;; GNU Guix is distributed in the hope that it will be useful, but
14 ;;; WITHOUT ANY WARRANTY; without even the implied warranty of
15 ;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
16 ;;; GNU General Public License for more details.
17 ;;;
18 ;;; You should have received a copy of the GNU General Public License
19 ;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
20
21 (define-module (gnu packages gnu-pw-mgr)
22 #:use-module (guix packages)
23 #:use-module (guix licenses)
24 #:use-module (guix download)
25 #:use-module (guix build-system gnu)
26 #:use-module (gnu packages)
27 #:use-module (gnu packages base)
28 #:use-module (gnu packages autogen))
29
30 (define-public gnu-pw-mgr
31 (package
32 (name "gnu-pw-mgr")
33 (version "2.0")
34 (source
35 (origin
36 (method url-fetch)
37 (uri (string-append "mirror://gnu/gnu-pw-mgr/gnu-pw-mgr-"
38 version ".tar.xz"))
39 (sha256
40 (base32
41 "19qvg37snfa8s06q5crx25m1r1n4l0wvfpkbdxz17q7whp0plrl6"))))
42 (build-system gnu-build-system)
43 (native-inputs
44 `(("which" ,which)
45 ("autogen" ,autogen)))
46 (home-page "http://www.gnu.org/software/gnu-pw-mgr/")
47 (synopsis "Retrieve login credentials without recording passwords")
48 (description
49 "This program is designed to make it easy to reconstruct difficult
50 passwords when they are needed while limiting the risk of attack. The
51 user of this program inputs a self-defined transformation of a web
52 site URL and obtains the password and user name hint for that web
53 site.")
54 (license gpl3+)))