gnu: python-pandas: Fix build on 32-bit.
[jackhill/guix/guix.git] / gnu / packages / ftp.scm
1 ;;; GNU Guix --- Functional package management for GNU
2 ;;; Copyright © 2014, 2015 Ludovic Courtès <ludo@gnu.org>
3 ;;; Copyright © 2015 Andreas Enge <andreas@enge.fr>
4 ;;; Copyright © 2015 Mark H Weaver <mhw@netris.org>
5 ;;; Copyright © 2016 Tobias Geerinckx-Rice <me@tobias.gr>
6 ;;; Copyright © 2017 Rene Saavedra <rennes@openmailbox.org>
7 ;;;
8 ;;; This file is part of GNU Guix.
9 ;;;
10 ;;; GNU Guix is free software; you can redistribute it and/or modify it
11 ;;; under the terms of the GNU General Public License as published by
12 ;;; the Free Software Foundation; either version 3 of the License, or (at
13 ;;; your option) any later version.
14 ;;;
15 ;;; GNU Guix is distributed in the hope that it will be useful, but
16 ;;; WITHOUT ANY WARRANTY; without even the implied warranty of
17 ;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
18 ;;; GNU General Public License for more details.
19 ;;;
20 ;;; You should have received a copy of the GNU General Public License
21 ;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
22
23 (define-module (gnu packages ftp)
24 #:use-module ((guix licenses) #:select (gpl2+ gpl3+ clarified-artistic))
25 #:use-module (guix build-system gnu)
26 #:use-module (guix download)
27 #:use-module (guix packages)
28 #:use-module (gnu packages)
29 #:use-module (gnu packages autotools)
30 #:use-module (gnu packages check)
31 #:use-module (gnu packages compression)
32 #:use-module (gnu packages databases)
33 #:use-module (gnu packages freedesktop)
34 #:use-module (gnu packages gettext)
35 #:use-module (gnu packages glib)
36 #:use-module (gnu packages gtk)
37 #:use-module (gnu packages libidn)
38 #:use-module (gnu packages ncurses)
39 #:use-module (gnu packages nettle)
40 #:use-module (gnu packages pkg-config)
41 #:use-module (gnu packages readline)
42 #:use-module (gnu packages tls)
43 #:use-module (gnu packages wxwidgets)
44 #:use-module (gnu packages xml))
45
46 (define-public lftp
47 (package
48 (name "lftp")
49 (version "4.7.5")
50 (source (origin
51 (method url-fetch)
52 ;; See https://lftp.tech/get.html for mirrors.
53 (uri (list (string-append "https://lftp.tech/ftp/lftp-"
54 version ".tar.xz")
55 (string-append "https://lftp.tech/ftp/old/lftp-"
56 version ".tar.xz")
57 (string-append "ftp://ftp.st.ryukoku.ac.jp/pub/network/"
58 "ftp/lftp/lftp-" version ".tar.xz")))
59 (sha256
60 (base32
61 "1n6h3y5jz1rxlx7ap46vykgm0q2rvzr7c5s5ry5l32z3lbmwbdak"))))
62 (build-system gnu-build-system)
63 (native-inputs
64 `(("pkg-config" ,pkg-config)))
65 (inputs
66 `(("zlib" ,zlib)
67 ("readline" ,readline)
68 ("gnutls" ,gnutls)))
69 (arguments
70 `(#:phases
71 (modify-phases %standard-phases
72 ;; Disable tests that require network access, which is most of them.
73 (add-before 'check 'disable-impure-tests
74 (lambda _
75 (substitute* "tests/Makefile"
76 (("(ftp-cls-l|ftp-list|http-get)\\$\\(EXEEXT\\)") "")
77 (("lftp-https-get ") "")))))
78 #:configure-flags
79 (list (string-append "--with-readline="
80 (assoc-ref %build-inputs "readline")))))
81 (home-page "https://lftp.tech/")
82 (synopsis "Command-line file transfer program")
83 (description
84 "LFTP is a sophisticated FTP/HTTP client, and a file transfer program
85 supporting a number of network protocols. Like Bash, it has job control and
86 uses the Readline library for input. It has bookmarks, a built-in mirror
87 command, and can transfer several files in parallel. It was designed with
88 reliability in mind.")
89 (license gpl3+)))
90
91 (define-public ncftp
92 (package
93 (name "ncftp")
94 (version "3.2.5")
95 (source (origin
96 (method url-fetch)
97 (uri (string-append "ftp://ftp.ncftp.com/ncftp/ncftp-"
98 version "-src.tar.bz2"))
99 (sha256
100 (base32
101 "0hlx12i0lwi99qsrx7nccf4nvwjj2gych4yks5y179b1ax0y5sxl"))
102 (modules '((guix build utils)))
103 (snippet
104 '(begin
105 ;; Use the right 'rm' and 'ls'.
106 (substitute* (cons "configure"
107 (find-files "."
108 "^(Makefile\\.in|.*\\.sh)$"))
109 (("/bin/(rm|ls)" _ command)
110 command))
111
112 ;; This is free software, avoid any confusion.
113 (substitute* (find-files "." "\\.c$")
114 (("a freeware program")
115 "free software"))))))
116 (build-system gnu-build-system)
117 (arguments
118 '(#:phases
119 (modify-phases %standard-phases
120 (replace 'configure
121 (lambda* (#:key outputs #:allow-other-keys)
122 ;; This is an old 'configure' script that doesn't
123 ;; understand variables passed as arguments.
124 (let ((out (assoc-ref outputs "out")))
125 (setenv "CONFIG_SHELL" (which "sh"))
126 (setenv "SHELL" (which "sh"))
127 (zero? (system* "./configure"
128 (string-append "--prefix=" out)))))))
129 #:tests? #f)) ;there are no tests
130 (inputs `(("ncurses" ,ncurses)))
131 (home-page "http://www.ncftp.com/ncftp/")
132 (synopsis "Command-line File Transfer Protocol (FTP) client")
133 (description
134 "NcFTP Client (or just NcFTP) is a set of command-line programs to access
135 File Transfer Protocol (FTP) servers. This includes 'ncftp', an interactive
136 FTP browser, as well as non-interactive commands such as 'ncftpput' and
137 'ncftpget'.")
138 (license clarified-artistic)))
139
140
141 (define-public weex
142 (package
143 (name "weex")
144 (version "2.8.2")
145 (source
146 (origin
147 (method url-fetch)
148 (uri
149 (string-append "mirror://sourceforge/weex/weex/"
150 "/weex_" version ".tar.gz"))
151 (sha256
152 (base32
153 "1ir761hjncr1bamaqcw9j7x57xi3s9jax3223bxwbq30a0vsw1pd"))))
154 (build-system gnu-build-system)
155 (native-inputs
156 `(("automake" ,automake)
157 ("autoconf" ,autoconf)
158 ("gettext" ,gettext-minimal)))
159 (arguments
160 `(#:phases
161 (modify-phases %standard-phases
162 (add-before 'configure 'bootstrap
163 (lambda _ (zero? (system* "autoreconf" "-vfi")))))))
164 (home-page "http://weex.sourceforge.net/")
165 (synopsis "Non-interactive client for FTP synchronization")
166 (description
167 "Weex is a utility designed to automate the task of remotely
168 maintaining a web page or other FTP archive. It synchronizes a set of
169 local files to a remote server by performing uploads and remote deletes
170 as required.")
171 (license gpl2+)))
172
173 (define-public libfilezilla
174 (package
175 (name "libfilezilla")
176 (version "0.9.0")
177 (source
178 (origin
179 (method url-fetch)
180 (uri (string-append "http://download.filezilla-project.org/"
181 name "/" name "-" version ".tar.bz2"))
182 (sha256
183 (base32
184 "0340v5xs48f28q2d16ldb9359dkzlhl4l449mgyv3qabnlz2pl21"))))
185 (build-system gnu-build-system)
186 (native-inputs
187 `(("cppunit" ,cppunit)))
188 (home-page "https://lib.filezilla-project.org")
189 (synopsis "Cross-platform C++ library used by Filezilla client")
190 (description
191 "This package provides some basic functionality to build high-performing,
192 platform-independent programs.")
193 (license gpl2+)))
194
195 (define-public filezilla
196 (package
197 (name "filezilla")
198 (version "3.24.1")
199 (source
200 (origin
201 (method url-fetch)
202 (uri (string-append "https://sourceforge.net/projects/" name
203 "/files/FileZilla_Client/" version
204 "/FileZilla_" version "_src" ".tar.bz2"))
205 (sha256
206 (base32
207 "0ahcld3g6jj92nakm5i58wgmcv6f4l9yisw3aqbc2ry0gs679pg6"))))
208 (build-system gnu-build-system)
209 (arguments
210 ;; Don't let filezilla phone home to check for updates.
211 '(#:configure-flags '("--disable-autoupdatecheck")))
212 (native-inputs
213 `(("gettext" ,gettext-minimal)
214 ("pkg-config" ,pkg-config)
215 ("pugixml" ,pugixml)
216 ("xdg-utils" ,xdg-utils)))
217 (inputs
218 `(("dbus" ,dbus)
219 ("gnutls" ,gnutls)
220 ("gtk+" ,gtk+)
221 ("libfilezilla" ,libfilezilla)
222 ("libidn" ,libidn)
223 ("nettle" ,nettle)
224 ("sqlite" ,sqlite)
225 ("wxwidgets" ,wxwidgets)))
226 (home-page "https://filezilla-project.org")
227 (synopsis "Full-featured graphical FTP/FTPS/SFTP client")
228 (description
229 "Filezilla client supports FTP, FTP over SSL/TLS (FTPS),
230 SSH File Transfer Protocol (SFTP), HTTP/1.1, SOCKS5, FTP-Proxy, IPv6
231 and others features such as bookmarks, drag and drop, filename filters,
232 directory comparison and more.")
233 (license gpl2+)
234 (properties '((upstream-name . "FileZilla")))))