gnu: python-pandas: Fix build on 32-bit.
[jackhill/guix/guix.git] / gnu / packages / enlightenment.scm
1 ;;; GNU Guix --- Functional package management for GNU
2 ;;; Copyright © 2015 Tomáš Čech <sleep_walker@suse.cz>
3 ;;; Copyright © 2015 Daniel Pimentel <d4n1@member.fsf.org>
4 ;;; Copyright © 2015, 2016, 2017 Efraim Flashner <efraim@flashner.co.il>
5 ;;;
6 ;;; This file is part of GNU Guix.
7 ;;;
8 ;;; GNU Guix is free software; you can redistribute it and/or modify it
9 ;;; under the terms of the GNU General Public License as published by
10 ;;; the Free Software Foundation; either version 3 of the License, or (at
11 ;;; your option) any later version.
12 ;;;
13 ;;; GNU Guix is distributed in the hope that it will be useful, but
14 ;;; WITHOUT ANY WARRANTY; without even the implied warranty of
15 ;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
16 ;;; GNU General Public License for more details.
17 ;;;
18 ;;; You should have received a copy of the GNU General Public License
19 ;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
20
21 (define-module (gnu packages enlightenment)
22 #:use-module ((guix licenses) #:prefix license:)
23 #:use-module (guix packages)
24 #:use-module (guix download)
25 #:use-module (guix build-system gnu)
26 #:use-module (guix build-system python)
27 #:use-module (gnu packages)
28 #:use-module (gnu packages bash)
29 #:use-module (gnu packages check)
30 #:use-module (gnu packages code)
31 #:use-module (gnu packages compression)
32 #:use-module (gnu packages curl)
33 #:use-module (gnu packages fontutils)
34 #:use-module (gnu packages freedesktop)
35 #:use-module (gnu packages fribidi)
36 #:use-module (gnu packages game-development)
37 #:use-module (gnu packages gettext)
38 #:use-module (gnu packages ghostscript)
39 #:use-module (gnu packages gl)
40 #:use-module (gnu packages glib)
41 #:use-module (gnu packages gnome)
42 #:use-module (gnu packages gstreamer)
43 #:use-module (gnu packages gtk)
44 #:use-module (gnu packages image)
45 #:use-module (gnu packages linux)
46 #:use-module (gnu packages llvm)
47 #:use-module (gnu packages lua)
48 #:use-module (gnu packages pdf)
49 #:use-module (gnu packages photo)
50 #:use-module (gnu packages pkg-config)
51 #:use-module (gnu packages pulseaudio)
52 #:use-module (gnu packages python)
53 #:use-module (gnu packages tls)
54 #:use-module (gnu packages video)
55 #:use-module (gnu packages xorg))
56
57 (define-public efl
58 (package
59 (name "efl")
60 (version "1.18.4")
61 (source (origin
62 (method url-fetch)
63 (uri (string-append
64 "https://download.enlightenment.org/rel/libs/efl/efl-"
65 version ".tar.xz"))
66 (sha256
67 (base32
68 "09c0ajszjarcs6d62zlgnf1aha2f921mfr0gxg6nwza36xzc1srr"))))
69 (build-system gnu-build-system)
70 (native-inputs
71 `(("pkg-config" ,pkg-config)))
72 (inputs
73 `(("alsa-lib" ,alsa-lib)
74 ("compositeproto" ,compositeproto)
75 ("curl" ,curl)
76 ("ghostscript" ,ghostscript)
77 ("giflib" ,giflib)
78 ("gstreamer" ,gstreamer)
79 ("gst-plugins-base" ,gst-plugins-base)
80 ("libexif" ,libexif)
81 ("libjpeg" ,libjpeg)
82 ("libraw" ,libraw)
83 ("librsvg" ,librsvg)
84 ("libspectre" ,libspectre)
85 ("libtiff" ,libtiff)
86 ("libwebp" ,libwebp)
87 ("libx11" ,libx11)
88 ("libxcomposite" ,libxcomposite)
89 ("libxcursor" ,libxcursor)
90 ("libxdmcp" ,libxdmcp)
91 ("libxext" ,libxext)
92 ("libxi" ,libxi)
93 ("libxkbfile" ,libxkbfile)
94 ("libxinerama" ,libxinerama)
95 ("libxp" ,libxp)
96 ("libxrandr" ,libxrandr)
97 ("libxscrnsaver" ,libxscrnsaver)
98 ("libxtst" ,libxtst)
99 ("lz4" ,lz4)
100 ("mesa" ,mesa)
101 ("openjpeg" ,openjpeg-1)
102 ("poppler" ,poppler)
103 ("printproto" ,printproto)
104 ("scrnsaverproto" ,scrnsaverproto)
105 ("xextproto" ,xextproto)
106 ("xinput" ,xinput)
107 ("xpr" ,xpr)
108 ("xproto" ,xproto)))
109 (propagated-inputs
110 ;; All these inputs are in package config files in section
111 ;; Require.private.
112 `(("bullet" ,bullet) ; ephysics.pc
113 ("dbus" ,dbus) ; eldbus.pc, elementary.pc, elocation.pc, ethumb_client.pc
114 ("eudev" ,eudev) ; eeze.pc
115 ("fontconfig" ,fontconfig) ; evas.pc, evas-cxx.pc
116 ("freetype" ,freetype) ; evas.pc, evas-cxx.pc
117 ("fribidi" ,fribidi) ; evas.pc, evas-cxx.pc
118 ("glib" ,glib) ; ecore.pc, ecore-cxx.pc
119 ("harfbuzz" ,harfbuzz) ; evas.pc, evas-cxx.pc
120 ("luajit" ,luajit) ; elua.pc, evas.pc, evas-cxx.pc
121 ("libpng" ,libpng) ; evas.pc, evas-cxx.pc
122 ("libsndfile" ,libsndfile) ; ecore-audio.pc, ecore-audio-cxx.pc
123 ("openssl" ,openssl) ; ecore-con.pc, eet.pc, eet-cxx.pc, emile.pc
124 ("pulseaudio" ,pulseaudio) ; ecore-audio.pc, ecore-audio-cxx.pc
125 ("util-linux" ,util-linux) ; eeze.pc
126 ("zlib" ,zlib))) ; eet.pc, eet-cxx.pc, emile.pc
127 (arguments
128 `(#:configure-flags '("--disable-silent-rules"
129 "--enable-liblz4"
130 "--enable-xinput22"
131 "--enable-image-loader-webp"
132 "--enable-multisense"
133 "--with-opengl=es"
134 "--enable-egl"
135 "--enable-harfbuzz")))
136 (home-page "https://www.enlightenment.org")
137 (synopsis "Enlightenment Foundation Libraries")
138 (description
139 "Enlightenment Foundation Libraries is a set of libraries developed
140 for Enlightenment. Libraries covers data serialization, wide support for
141 graphics rendering, UI layout and themes, interaction with OS, access to
142 removable devices or support for multimedia.")
143 ;; Different parts are under different licenses.
144 (license (list license:bsd-2 license:lgpl2.1 license:zlib))))
145
146 (define-public terminology
147 (package
148 (name "terminology")
149 (version "1.0.0")
150 (source (origin
151 (method url-fetch)
152 (uri
153 (string-append "https://download.enlightenment.org/rel/apps/"
154 "terminology/terminology-" version ".tar.xz"))
155 (sha256
156 (base32
157 "1x4j2q4qqj10ckbka0zaq2r2zm66ff1x791kp8slv1ff7fw45vdz"))))
158 (build-system gnu-build-system)
159 (native-inputs
160 `(("pkg-config" ,pkg-config)))
161 (inputs
162 `(("efl" ,efl)))
163 (home-page "https://www.enlightenment.org/about-terminology")
164 (synopsis "Powerful terminal emulator based on EFL")
165 (description
166 "Terminology is fast and feature rich terminal emulator. It is solely
167 based on Enlightenment Foundation Libraries. It supports multiple tabs, UTF-8,
168 URL and local path detection, themes, popup based content viewer for non-text
169 contents and more.")
170 (license license:bsd-2)))
171
172 (define-public rage
173 (package
174 (name "rage")
175 (version "0.2.1")
176 (source (origin
177 (method url-fetch)
178 (uri
179 (string-append
180 "https://download.enlightenment.org/rel/apps/rage/rage-"
181 version ".tar.xz"))
182 (sha256
183 (base32
184 "06kbgcnbhl9clhdl7k983m4d0n6ggsl4qvizzi1nrp8c7np87fix"))))
185 (build-system gnu-build-system)
186 (native-inputs
187 `(("pkg-config" ,pkg-config)))
188 (inputs
189 `(("efl" ,efl)))
190 (home-page "https://www.enlightenment.org/about-rage")
191 (synopsis "Video and audio player based on EFL")
192 (description
193 "Rage is a video and audio player written with Enlightenment Foundation
194 Libraries with some extra bells and whistles.")
195 (license license:bsd-2)))
196
197 (define-public enlightenment
198 (package
199 (name "enlightenment")
200 (version "0.21.6")
201 (source (origin
202 (method url-fetch)
203 (uri
204 (string-append "https://download.enlightenment.org/rel/apps/"
205 name "/" name "-" version ".tar.xz"))
206 (sha256
207 (base32
208 "0gan3c8jbvhcmvb2fpbprr3m6db0afg1dnrb87nbqb399nsi81zd"))))
209 (build-system gnu-build-system)
210 (arguments
211 `(#:configure-flags '("--enable-mount-eeze")))
212 (native-inputs
213 `(("gettext" ,gettext-minimal)
214 ("pkg-config" ,pkg-config)))
215 (inputs
216 `(("alsa-lib" ,alsa-lib)
217 ("dbus" ,dbus)
218 ("efl" ,efl)
219 ("freetype" ,freetype)
220 ("libxcb" ,libxcb)
221 ("libxext" ,libxext)
222 ("linux-pam" ,linux-pam)
223 ("xcb-util-keysyms" ,xcb-util-keysyms)))
224 (home-page "https://www.enlightenment.org")
225 (synopsis "Lightweight desktop environment")
226 (description
227 "Enlightenment is resource friendly desktop environment with integrated
228 file manager, wide range of configuration options, plugin system allowing to
229 unload unused functionality, with support for touchscreen and suitable for
230 embedded systems.")
231 (license license:bsd-2)))
232
233 (define-public python-efl
234 (package
235 (name "python-efl")
236 (version "1.18.0")
237 (source
238 (origin
239 (method url-fetch)
240 (uri (pypi-uri "python-efl" version))
241 (sha256
242 (base32
243 "0x49rb7mx7ysjp23m919r2rx8qnl4xackhl9s9x2697m7cs77n1r"))))
244 (build-system python-build-system)
245 (arguments
246 '(#:phases
247 (modify-phases %standard-phases
248 (replace 'build
249 (lambda _
250 (zero?
251 (system* "env" "ENABLE_CYTHON=1" "python" "setup.py" "build"))))
252 (add-before 'build 'set-flags
253 (lambda _
254 (setenv "CFLAGS"
255 (string-append "-I" (assoc-ref %build-inputs "python-dbus")
256 "/include/dbus-1.0"))
257 #t))
258 (add-before 'check 'set-environment
259 (lambda _
260 ;; Some tests require write access to HOME.
261 (setenv "HOME" "/tmp")
262 #t)))
263 ;; FIXME: Some tests require a running D-Bus server or a network
264 ;; connection and should be disabled. Other test failures looks
265 ;; legitimate. Disabled for now, needs work!
266 #:tests? #f))
267 (native-inputs
268 `(("pkg-config" ,pkg-config)
269 ("python-cython" ,python-cython)))
270 (inputs
271 `(("efl" ,efl)
272 ("python-dbus" ,python-dbus)))
273 (home-page "https://www.enlightenment.org/")
274 (synopsis "Python bindings for EFL")
275 (description
276 "PYTHON-EFL are the python bindings for the whole Enlightenment Foundation
277 Libraries stack (eo, evas, ecore, edje, emotion, ethumb and elementary).")
278 (license license:lgpl3)))
279
280 (define-public python2-efl
281 (package-with-python2 python-efl))
282
283 (define-public edi
284 (package
285 (name "edi")
286 (version "0.4.0")
287 (source
288 (origin
289 (method url-fetch)
290 (uri (string-append "https://github.com/ajwillia-ms/edi/releases/"
291 "download/v" version "/edi-" version ".tar.bz2"))
292 (sha256
293 (base32
294 "0qczz5psryxasphg5km95845h510237rf0k1dy8f0dad52ii90j1"))))
295 (build-system gnu-build-system)
296 (arguments '(#:configure-flags '("--with-tests=coverage")))
297 (native-inputs
298 `(("check" ,check)
299 ("lcov" ,lcov)
300 ("pkg-config" ,pkg-config)))
301 (inputs
302 `(("clang" ,clang)
303 ("efl" ,efl)))
304 (home-page "https://www.enlightenment.org/about-edi")
305 (synopsis "Development environment for Enlightenment")
306 (description "EDI is a development environment designed for and built using
307 the EFL. It's aim is to create a new, native development environment for Linux
308 that tries to lower the barrier to getting involved in Enlightenment development
309 and in creating applications based on the Enlightenment Foundation Library suite.")
310 (license (list license:public-domain ; data/extra/skeleton
311 license:gpl2)))) ; edi
312
313 (define-public lekha
314 (package
315 (name "lekha")
316 (version "0.2.1")
317 (source (origin
318 (method url-fetch)
319 (uri (pypi-uri "Lekha" version))
320 (sha256
321 (base32
322 "0zr6i74ik58pbzrd7r9l7sawqbdv0r2c1a9927qkqzwga27x8j15"))))
323 (build-system python-build-system)
324 (arguments
325 `(#:tests? #f ; no test target
326 #:python ,python-2
327 #:phases
328 (modify-phases %standard-phases
329 (add-after 'unpack 'fix-data-location
330 (lambda _ (substitute* "setup.py"
331 (("'/usr/")"'"))
332 #t)))))
333 (propagated-inputs
334 `(("python2-efl" ,python2-efl)
335 ("python2-pypdf2" ,python2-pypdf2)
336 ("python2-pyxdg" ,python2-pyxdg)))
337 (synopsis "Simple PDF viewer")
338 (description
339 "Simple PDF viewer based on the Enlightenment Foundation Libraries.")
340 (home-page "https://github.com/kaihu/lekha")
341 (license license:gpl3+)))