gnu: python-pandas: Fix build on 32-bit.
[jackhill/guix/guix.git] / gnu / packages / djvu.scm
1 ;;; GNU Guix --- Functional package management for GNU
2 ;;; Copyright © 2015 Paul van der Walt <paul@denknerd.org>
3 ;;;
4 ;;; This file is part of GNU Guix.
5 ;;;
6 ;;; GNU Guix is free software; you can redistribute it and/or modify it
7 ;;; under the terms of the GNU General Public License as published by
8 ;;; the Free Software Foundation; either version 3 of the License, or (at
9 ;;; your option) any later version.
10 ;;;
11 ;;; GNU Guix is distributed in the hope that it will be useful, but
12 ;;; WITHOUT ANY WARRANTY; without even the implied warranty of
13 ;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
14 ;;; GNU General Public License for more details.
15 ;;;
16 ;;; You should have received a copy of the GNU General Public License
17 ;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
18
19 (define-module (gnu packages djvu)
20 #:use-module ((guix licenses) #:prefix license:)
21 #:use-module (guix packages)
22 #:use-module (guix download)
23 #:use-module (guix build-system gnu))
24
25 (define-public djvulibre
26 (package
27 (name "djvulibre")
28 (version "3.5.27")
29 (source (origin
30 (method url-fetch)
31 (uri (string-append "mirror://sourceforge/djvu/DjVuLibre/"
32 version "/djvulibre-" version ".tar.gz"))
33 (sha256
34 (base32
35 "0psh3zl9dj4n4r3lx25390nx34xz0bg0ql48zdskhq354ljni5p6"))))
36 (build-system gnu-build-system)
37 (home-page "http://djvu.sourceforge.net/")
38 (synopsis "Implementation of DjVu, the document format")
39 (description "DjVuLibre is an implementation of DjVu,
40 including viewers, browser plugins, decoders, simple encoders, and
41 utilities.")
42 (license license:gpl2+)))