gnu: python-pandas: Fix build on 32-bit.
[jackhill/guix/guix.git] / gnu / packages / datastructures.scm
1 ;;; GNU Guix --- Functional package management for GNU
2 ;;; Copyright © 2015, 2016 Ricardo Wurmus <rekado@elephly.net>
3 ;;; Copyright © 2016 Tobias Geerinckx-Rice <me@tobias.gr>
4 ;;;
5 ;;; This file is part of GNU Guix.
6 ;;;
7 ;;; GNU Guix is free software; you can redistribute it and/or modify it
8 ;;; under the terms of the GNU General Public License as published by
9 ;;; the Free Software Foundation; either version 3 of the License, or (at
10 ;;; your option) any later version.
11 ;;;
12 ;;; GNU Guix is distributed in the hope that it will be useful, but
13 ;;; WITHOUT ANY WARRANTY; without even the implied warranty of
14 ;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
15 ;;; GNU General Public License for more details.
16 ;;;
17 ;;; You should have received a copy of the GNU General Public License
18 ;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
19
20 (define-module (gnu packages datastructures)
21 #:use-module (gnu packages)
22 #:use-module ((guix licenses) #:prefix license:)
23 #:use-module (guix packages)
24 #:use-module (guix download)
25 #:use-module (guix build-system gnu))
26
27 (define-public gdsl
28 (package
29 (name "gdsl")
30 (version "1.8")
31 (source (origin
32 (method url-fetch)
33 (uri (string-append "http://download.gna.org/gdsl/"
34 "gdsl-" version ".tar.gz"))
35 (sha256
36 (base32
37 "1v64jvlnj8jfpphphgjgb36p0kv50kwfyqncf0y12f16v8ydyiaw"))))
38 (build-system gnu-build-system)
39 (home-page "http://home.gna.org/gdsl/")
40 (synopsis "Generic data structures library")
41 (description "The Generic Data Structures Library (GDSL) is a collection
42 of routines for generic data structures manipulation. It is a re-entrant
43 library fully written from scratch in pure ANSI C. It is designed to offer
44 for C programmers common data structures with powerful algorithms, and hidden
45 implementation. Available structures are lists, queues, stacks, hash tables,
46 binary trees, binary search trees, red-black trees, 2D arrays, permutations
47 and heaps.")
48 (license license:gpl2+)))
49
50 (define-public sparsehash
51 (package
52 (name "sparsehash")
53 (version "2.0.3")
54 (source (origin
55 (method url-fetch)
56 (uri (string-append "https://github.com/sparsehash/sparsehash/"
57 "archive/sparsehash-" version ".tar.gz"))
58 (sha256
59 (base32
60 "133szz0ldwch0kd91l0sa57qsnl020njn622szd9cxrjqyjqds85"))))
61 (build-system gnu-build-system)
62 (synopsis "Memory-efficient hashtable implementations")
63 (description
64 "This library contains several hash-map implementations, similar in API
65 to SGI's @code{hash_map} class, but with different performance
66 characteristics. @code{sparse_hash_map} uses very little space overhead, 1-2
67 bits per entry. @code{dense_hash_map} is very fast, particulary on lookup.
68 @code{sparse_hash_set} and @code{dense_hash_set} are the set versions of these
69 routines. All these implementation use a hashtable with internal quadratic
70 probing. This method is space-efficient -- there is no pointer overhead --
71 and time-efficient for good hash functions.")
72 (home-page "https://github.com/sparsehash/sparsehash")
73 (license license:bsd-3)))
74
75 (define-public ssdeep
76 (package
77 (name "ssdeep")
78 (version "2.13")
79 (source (origin
80 (method url-fetch)
81 (uri (string-append "mirror://sourceforge/ssdeep/"
82 name "-" version "/"
83 name "-" version ".tar.gz"))
84 (sha256
85 (base32
86 "1igqy0j7jrklb8fdlrm6ald4cyl1fda5ipfl8crzyl6bax2ajk3f"))))
87 (build-system gnu-build-system)
88 (home-page "http://ssdeep.sourceforge.net")
89 (synopsis "Context-triggered piecewise hashing algorithm")
90 (description "ssdeep computes and matches context triggered piecewise
91 hashes (CTPH), also called fuzzy checksums. It can identify similar files
92 that have sequences of identical bytes in the same order, even though bytes
93 in between these sequences may be different in both content and length.")
94 (license license:gpl2+)))