gnu: python-pandas: Fix build on 32-bit.
[jackhill/guix/guix.git] / gnu / packages / compton.scm
1 ;;; GNU Guix --- Functional package management for GNU
2 ;;; Copyright © 2017 José Miguel Sánchez García <jmi2k@openmailbox.org>
3 ;;;
4 ;;; This file is part of GNU Guix.
5 ;;;
6 ;;; GNU Guix is free software; you can redistribute it and/or modify it
7 ;;; under the terms of the GNU General Public License as published by
8 ;;; the Free Software Foundation; either version 3 of the License, or (at
9 ;;; your option) any later version.
10 ;;;
11 ;;; GNU Guix is distributed in the hope that it will be useful, but
12 ;;; WITHOUT ANY WARRANTY; without even the implied warranty of
13 ;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
14 ;;; GNU General Public License for more details.
15 ;;;
16 ;;; You should have received a copy of the GNU General Public License
17 ;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
18
19 (define-module (gnu packages compton)
20 #:use-module ((guix licenses) #:prefix license:)
21 #:use-module (guix packages)
22 #:use-module (guix download)
23 #:use-module (guix build-system gnu)
24 #:use-module (gnu packages docbook)
25 #:use-module (gnu packages documentation)
26 #:use-module (gnu packages gl)
27 #:use-module (gnu packages glib)
28 #:use-module (gnu packages pkg-config)
29 #:use-module (gnu packages python)
30 #:use-module (gnu packages textutils)
31 #:use-module (gnu packages xdisorg)
32 #:use-module (gnu packages xml)
33 #:use-module (gnu packages xorg))
34
35 (define-public compton
36 (let ((upstream-version "0.1_beta2"))
37 (package
38 (name "compton")
39 (version (string-filter (char-set-complement (char-set #\_))
40 upstream-version))
41 (source (origin
42 (method url-fetch)
43 (uri (string-append
44 "https://github.com/chjj/" name "/archive/v"
45 upstream-version ".tar.gz"))
46 (sha256
47 (base32
48 "02dhlqqcwnmlf2dxg7rd4lapgqahgndzixdkbpxicq9jawmdb73v"))
49 (file-name (string-append name "-" version "-checkout"))))
50 (build-system gnu-build-system)
51 (inputs
52 `(("dbus" ,dbus)
53 ("docbook-xml" ,docbook-xml)
54 ("libconfig" ,libconfig)
55 ("libx11" ,libx11)
56 ("libxcomposite" ,libxcomposite)
57 ("libxdamage" ,libxdamage)
58 ("libxext" ,libxext)
59 ("libxfixes" ,libxfixes)
60 ("libxinerama" ,libxinerama)
61 ("libxml2" ,libxml2)
62 ("libxrandr" ,libxrandr)
63 ("libxrender" ,libxrender)
64 ("libxslt" ,libxslt)
65 ("mesa" ,mesa)
66 ("xprop" ,xprop)
67 ("xwininfo" ,xwininfo)))
68 (native-inputs
69 `(("asciidoc" ,asciidoc)
70 ("libdrm" ,libdrm)
71 ("pkg-config" ,pkg-config)
72 ("python" ,python)
73 ("xproto" ,xproto)))
74 (arguments
75 `(#:make-flags (list
76 "CC=gcc"
77 "NO_REGEX_PCRE=1" ; pcre makes build fail
78 (string-append "PREFIX=" (assoc-ref %outputs "out")))
79 #:tests? #f ; no tests
80 #:phases
81 (modify-phases %standard-phases
82 (delete 'configure))))
83 (home-page "https://github.com/chjj/compton")
84 (synopsis "Compositor for X11")
85 (description
86 "Compton is a compositor for the Xorg display server and a for of
87 xcompmgr-dana, which implements some changes like:
88
89 @itemize
90 @item OpenGL backend (@command{--backend glx}), in addition to the old X Render
91 backend.
92 @item Inactive window transparency (@command{-i}) and dimming
93 (@command{--inactive-dim}).
94 @item Menu transparency (@command{-m}, thanks to Dana).
95 @item Shadows are now enabled for argb windows, e.g terminals with transparency
96 @item Removed serverside shadows (and simple compositing) to clean the code,
97 the only option that remains is clientside shadows.
98 @item Configuration files (see the man page for more details).
99 @item Colored shadows (@command{--shadow-[red/green/blue]}).
100 @item A new fade system.
101 @item VSync support (not always working).
102 @item Blur of background of transparent windows, window color inversion (bad in
103 performance).
104 @item Some more options...
105 @end itemize\n")
106 (license license:expat))))