gnu: python-pandas: Fix build on 32-bit.
[jackhill/guix/guix.git] / gnu / packages / autogen.scm
1 ;;; GNU Guix --- Functional package management for GNU
2 ;;; Copyright © 2013, 2014 Eric Bavier <bavier@member.fsf.org>
3 ;;; Copyright © 2015, 2016 Efraim Flashner <efraim@flashner.co.il>
4 ;;;
5 ;;; This file is part of GNU Guix.
6 ;;;
7 ;;; GNU Guix is free software; you can redistribute it and/or modify it
8 ;;; under the terms of the GNU General Public License as published by
9 ;;; the Free Software Foundation; either version 3 of the License, or (at
10 ;;; your option) any later version.
11 ;;;
12 ;;; GNU Guix is distributed in the hope that it will be useful, but
13 ;;; WITHOUT ANY WARRANTY; without even the implied warranty of
14 ;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
15 ;;; GNU General Public License for more details.
16 ;;;
17 ;;; You should have received a copy of the GNU General Public License
18 ;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
19
20 (define-module (gnu packages autogen)
21 #:use-module (guix packages)
22 #:use-module (guix licenses)
23 #:use-module (guix download)
24 #:use-module (guix build-system gnu)
25 #:use-module (gnu packages)
26 #:use-module (gnu packages perl)
27 #:use-module (gnu packages pkg-config)
28 #:use-module (gnu packages base)
29 #:use-module (gnu packages guile))
30
31 (define-public autogen
32 (package
33 (name "autogen")
34 (version "5.18.12")
35 (source
36 (origin
37 (method url-fetch)
38 (uri (string-append "mirror://gnu/autogen/rel" version
39 "/autogen-" version ".tar.xz"))
40 (sha256
41 (base32
42 "1n5zq4872sakvz9c7ncsdcfp0z8rsybsxvbmhkpbd19ii0pacfxy"))))
43 (build-system gnu-build-system)
44 (native-inputs `(("perl" ,perl) ;for doc generator mdoc
45 ("pkg-config" ,pkg-config)))
46 (inputs `(("which" ,which)
47 ("guile" ,guile-2.0)))
48 (arguments
49 '(#:phases
50 (modify-phases %standard-phases
51 (add-before 'patch-source-shebangs 'patch-test-scripts
52 (lambda _
53 (let ((sh (which "sh")))
54 (substitute*
55 (append (find-files "agen5/test" "\\.test$")
56 (find-files "autoopts/test" "\\.(test|in)$"))
57 (("/bin/sh") sh)
58 (("/usr/bin/tr") "tr"))
59 #t))))))
60 (home-page "https://www.gnu.org/software/autogen/")
61 (synopsis "Automated program generator")
62 (description
63 "AutoGen is a program to ease the maintenance of programs that contain
64 large amounts of repetitive text. It automates the construction of these
65 sections of the code, simplifying the task of keeping the text in sync. It
66 also includes an add-on package called AutoOpts, which is specialized for the
67 maintenance and documentation of program options.")
68 (license gpl3+)))