gnu: r-dose: Update to 3.10.2.
[jackhill/guix/guix.git] / gnu / packages / fribidi.scm
1 ;;; GNU Guix --- Functional package management for GNU
2 ;;; Copyright © 2014 Marek Benc <merkur32@gmail.com>
3 ;;; Copyright © 2016 Efraim Flashner <efraim@flashner.co.il>
4 ;;; Copyright © 2018 Tobias Geerinckx-Rice <me@tobias.gr>
5 ;;;
6 ;;; This file is part of GNU Guix.
7 ;;;
8 ;;; GNU Guix is free software; you can redistribute it and/or modify it
9 ;;; under the terms of the GNU General Public License as published by
10 ;;; the Free Software Foundation; either version 3 of the License, or (at
11 ;;; your option) any later version.
12 ;;;
13 ;;; GNU Guix is distributed in the hope that it will be useful, but
14 ;;; WITHOUT ANY WARRANTY; without even the implied warranty of
15 ;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
16 ;;; GNU General Public License for more details.
17 ;;;
18 ;;; You should have received a copy of the GNU General Public License
19 ;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
20
21 (define-module (gnu packages fribidi)
22 #:use-module (guix packages)
23 #:use-module (guix download)
24 #:use-module (guix build-system gnu)
25 #:use-module (guix licenses))
26
27 (define-public fribidi
28 (package
29 (name "fribidi")
30 (version "1.0.5")
31 (source
32 (origin
33 (method url-fetch)
34 (uri
35 (string-append "https://github.com/fribidi/fribidi/releases"
36 "/download/v" version "/fribidi-" version
37 ".tar.bz2"))
38 (sha256
39 (base32 "1kp4b1hpx2ky20ixgy2xhj5iygfl7ps5k9kglh1z5i7mhykg4r3a"))))
40 (build-system gnu-build-system)
41 (synopsis "Implementation of the Unicode bidirectional algorithm")
42 (description
43 "GNU FriBidi is an implementation of the Unicode Bidirectional
44 Algorithm. This algorithm is used to properly display text in left-to-right
45 or right-to-left ordering as necessary.")
46 (home-page "https://github.com/fribidi/fribidi")
47 (license lgpl2.1+)))