gnu: gash, gash-utils: Build with Guile 3.0.
[jackhill/guix/guix.git] / gnu / packages / patches / gash-utils-ls-test.patch
1 'ls.scm' monkey-patches (ice-9 getopt-long) to allow it to recognize '-1'
2 as a valid option. Unfortunately, monkey patching no longer works with
3 Guile 3.0 due to inlining, so change the test to make do without '-1'.
4
5 diff --git a/tests/core-utils.org b/tests/core-utils.org
6 index d35ede8..22718e3 100644
7 --- a/tests/core-utils.org
8 +++ b/tests/core-utils.org
9 @@ -93,14 +93,11 @@
10 * ls
11 :script:
12 #+begin_src sh
13 - ls -1 tests/data/star
14 + ls tests/data/star
15 #+end_src
16 :stdout:
17 #+begin_example
18 - 0
19 - 1
20 - 2
21 - 3
22 + 0 1 2 3
23 #+end_example
24
25 * test-file