gnu: tvtime: Update to 1.0.10.
[jackhill/guix/guix.git] / gnu / packages / tv.scm
1 ;;; GNU Guix --- Functional package management for GNU
2 ;;; Copyright © 2015, 2016 Alex Kost <alezost@gmail.com>
3 ;;;
4 ;;; This file is part of GNU Guix.
5 ;;;
6 ;;; GNU Guix is free software; you can redistribute it and/or modify it
7 ;;; under the terms of the GNU General Public License as published by
8 ;;; the Free Software Foundation; either version 3 of the License, or (at
9 ;;; your option) any later version.
10 ;;;
11 ;;; GNU Guix is distributed in the hope that it will be useful, but
12 ;;; WITHOUT ANY WARRANTY; without even the implied warranty of
13 ;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
14 ;;; GNU General Public License for more details.
15 ;;;
16 ;;; You should have received a copy of the GNU General Public License
17 ;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
18
19 (define-module (gnu packages tv)
20 #:use-module (guix packages)
21 #:use-module (guix download)
22 #:use-module (guix build-system gnu)
23 #:use-module ((guix licenses) #:prefix license:)
24 #:use-module (gnu packages)
25 #:use-module (gnu packages compression)
26 #:use-module (gnu packages fontutils)
27 #:use-module (gnu packages image)
28 #:use-module (gnu packages linux)
29 #:use-module (gnu packages xml)
30 #:use-module (gnu packages xorg))
31
32 (define-public tvtime
33 (package
34 (name "tvtime")
35 (version "1.0.10")
36 (source (origin
37 (method url-fetch)
38 (uri (string-append
39 "http://linuxtv.org/downloads/tvtime/tvtime-"
40 version ".tar.gz"))
41 (sha256
42 (base32
43 "1mk6dni82n8jv5wsrrpqzcwrg9ccx9vijb5sbm7gqm2y0h40q5y9"))))
44 (build-system gnu-build-system)
45 (inputs
46 `(("alsa-lib" ,alsa-lib)
47 ("libx11" ,libx11)
48 ("libxext" ,libxext)
49 ("libxt" ,libxt)
50 ("libxtst" ,libxtst)
51 ("libxinerama" ,libxinerama)
52 ("libxv" ,libxv)
53 ("libxxf86vm" ,libxxf86vm)
54 ("libpng" ,libpng)
55 ("libxml2" ,libxml2)
56 ("freetype" ,freetype)
57 ("zlib" ,zlib)))
58 (home-page "http://tvtime.sourceforge.net")
59 (synopsis "Television viewer")
60 (description
61 "Tvtime processes the input from your video capture card and
62 displays it on a monitor. It focuses on a high visual quality.")
63 (license license:gpl2+)))