gnu: screen: Patch CVE-2021-26937.
[jackhill/guix/guix.git] / gnu / packages / patches / scalapack-blacs-mpi-deprecations.patch
1 From f11c3f094ed5ca727ec819983425b6641db8227c Mon Sep 17 00:00:00 2001
2 From: Eric Bavier <bavier@member.fsf.org>
3 Date: Wed, 13 Feb 2019 09:32:11 -0600
4 Subject: [PATCH] BLACS: Remove use of long-deprecated MPI1 functions.
5
6 * BLACS/SRC/blacs_get_.c: 'MPI_Attr_get' -> 'MPI_Comm_get_attr'.
7 * BLACS/SRC/cgamn2d_.c, BLACS/SRC/cgamx2d_.c, BLACS/SRC/dgamn2d_.c,
8 BLACS/SRC/dgamx2d_.c, BLACS/SRC/igamn2d_.c, BLACS/SRC/igamx2d_.c,
9 BLACS/SRC/sgamn2d_.c, BLACS/SRC/sgamx2d_.c, BLACS/SRC/zgamn2d_.c,
10 BLACS/SRC/zgamx2d_.c: 'MPI_Type_struct' -> 'MPI_Type_create_struct'.
11 ---
12 BLACS/SRC/blacs_get_.c | 2 +-
13 BLACS/SRC/cgamn2d_.c | 2 +-
14 BLACS/SRC/cgamx2d_.c | 2 +-
15 BLACS/SRC/dgamn2d_.c | 2 +-
16 BLACS/SRC/dgamx2d_.c | 2 +-
17 BLACS/SRC/igamn2d_.c | 2 +-
18 BLACS/SRC/igamx2d_.c | 2 +-
19 BLACS/SRC/sgamn2d_.c | 2 +-
20 BLACS/SRC/sgamx2d_.c | 2 +-
21 BLACS/SRC/zgamn2d_.c | 2 +-
22 BLACS/SRC/zgamx2d_.c | 2 +-
23 11 files changed, 11 insertions(+), 11 deletions(-)
24
25 diff --git a/BLACS/SRC/blacs_get_.c b/BLACS/SRC/blacs_get_.c
26 index e979767..d4b04cf 100644
27 --- a/BLACS/SRC/blacs_get_.c
28 +++ b/BLACS/SRC/blacs_get_.c
29 @@ -23,7 +23,7 @@ F_VOID_FUNC blacs_get_(int *ConTxt, int *what, int *val)
30 case SGET_MSGIDS:
31 if (BI_COMM_WORLD == NULL) Cblacs_pinfo(val, &val[1]);
32 iptr = &val[1];
33 - ierr=MPI_Attr_get(MPI_COMM_WORLD, MPI_TAG_UB, (BVOID **) &iptr,val);
34 + ierr=MPI_Comm_get_attr(MPI_COMM_WORLD, MPI_TAG_UB, (BVOID **) &iptr,val);
35 val[0] = 0;
36 val[1] = *iptr;
37 break;
38 diff --git a/BLACS/SRC/cgamn2d_.c b/BLACS/SRC/cgamn2d_.c
39 index 2db6ccb..6958f32 100644
40 --- a/BLACS/SRC/cgamn2d_.c
41 +++ b/BLACS/SRC/cgamn2d_.c
42 @@ -221,7 +221,7 @@ F_VOID_FUNC cgamn2d_(int *ConTxt, F_CHAR scope, F_CHAR top, int *m, int *n,
43 {
44 #endif
45 i = 2;
46 - ierr=MPI_Type_struct(i, len, disp, dtypes, &MyType);
47 + ierr=MPI_Type_create_struct(i, len, disp, dtypes, &MyType);
48 ierr=MPI_Type_commit(&MyType);
49 bp->N = bp2->N = 1;
50 bp->dtype = bp2->dtype = MyType;
51 diff --git a/BLACS/SRC/cgamx2d_.c b/BLACS/SRC/cgamx2d_.c
52 index 707c0b6..f802d01 100644
53 --- a/BLACS/SRC/cgamx2d_.c
54 +++ b/BLACS/SRC/cgamx2d_.c
55 @@ -221,7 +221,7 @@ F_VOID_FUNC cgamx2d_(int *ConTxt, F_CHAR scope, F_CHAR top, int *m, int *n,
56 {
57 #endif
58 i = 2;
59 - ierr=MPI_Type_struct(i, len, disp, dtypes, &MyType);
60 + ierr=MPI_Type_create_struct(i, len, disp, dtypes, &MyType);
61 ierr=MPI_Type_commit(&MyType);
62 bp->N = bp2->N = 1;
63 bp->dtype = bp2->dtype = MyType;
64 diff --git a/BLACS/SRC/dgamn2d_.c b/BLACS/SRC/dgamn2d_.c
65 index dff23b4..a2627ac 100644
66 --- a/BLACS/SRC/dgamn2d_.c
67 +++ b/BLACS/SRC/dgamn2d_.c
68 @@ -221,7 +221,7 @@ F_VOID_FUNC dgamn2d_(int *ConTxt, F_CHAR scope, F_CHAR top, int *m, int *n,
69 {
70 #endif
71 i = 2;
72 - ierr=MPI_Type_struct(i, len, disp, dtypes, &MyType);
73 + ierr=MPI_Type_create_struct(i, len, disp, dtypes, &MyType);
74 ierr=MPI_Type_commit(&MyType);
75 bp->N = bp2->N = 1;
76 bp->dtype = bp2->dtype = MyType;
77 diff --git a/BLACS/SRC/dgamx2d_.c b/BLACS/SRC/dgamx2d_.c
78 index a51f731..2a644d0 100644
79 --- a/BLACS/SRC/dgamx2d_.c
80 +++ b/BLACS/SRC/dgamx2d_.c
81 @@ -221,7 +221,7 @@ F_VOID_FUNC dgamx2d_(int *ConTxt, F_CHAR scope, F_CHAR top, int *m, int *n,
82 {
83 #endif
84 i = 2;
85 - ierr=MPI_Type_struct(i, len, disp, dtypes, &MyType);
86 + ierr=MPI_Type_create_struct(i, len, disp, dtypes, &MyType);
87 ierr=MPI_Type_commit(&MyType);
88 bp->N = bp2->N = 1;
89 bp->dtype = bp2->dtype = MyType;
90 diff --git a/BLACS/SRC/igamn2d_.c b/BLACS/SRC/igamn2d_.c
91 index 16bc003..f6a7859 100644
92 --- a/BLACS/SRC/igamn2d_.c
93 +++ b/BLACS/SRC/igamn2d_.c
94 @@ -218,7 +218,7 @@ F_VOID_FUNC igamn2d_(int *ConTxt, F_CHAR scope, F_CHAR top, int *m, int *n,
95 {
96 #endif
97 i = 2;
98 - ierr=MPI_Type_struct(i, len, disp, dtypes, &MyType);
99 + ierr=MPI_Type_create_struct(i, len, disp, dtypes, &MyType);
100 ierr=MPI_Type_commit(&MyType);
101 bp->N = bp2->N = 1;
102 bp->dtype = bp2->dtype = MyType;
103 diff --git a/BLACS/SRC/igamx2d_.c b/BLACS/SRC/igamx2d_.c
104 index 8165cbe..a7cfcc6 100644
105 --- a/BLACS/SRC/igamx2d_.c
106 +++ b/BLACS/SRC/igamx2d_.c
107 @@ -218,7 +218,7 @@ F_VOID_FUNC igamx2d_(int *ConTxt, F_CHAR scope, F_CHAR top, int *m, int *n,
108 {
109 #endif
110 i = 2;
111 - ierr=MPI_Type_struct(i, len, disp, dtypes, &MyType);
112 + ierr=MPI_Type_create_struct(i, len, disp, dtypes, &MyType);
113 ierr=MPI_Type_commit(&MyType);
114 bp->N = bp2->N = 1;
115 bp->dtype = bp2->dtype = MyType;
116 diff --git a/BLACS/SRC/sgamn2d_.c b/BLACS/SRC/sgamn2d_.c
117 index d6c95e5..569c797 100644
118 --- a/BLACS/SRC/sgamn2d_.c
119 +++ b/BLACS/SRC/sgamn2d_.c
120 @@ -221,7 +221,7 @@ F_VOID_FUNC sgamn2d_(int *ConTxt, F_CHAR scope, F_CHAR top, int *m, int *n,
121 {
122 #endif
123 i = 2;
124 - ierr=MPI_Type_struct(i, len, disp, dtypes, &MyType);
125 + ierr=MPI_Type_create_struct(i, len, disp, dtypes, &MyType);
126 ierr=MPI_Type_commit(&MyType);
127 bp->N = bp2->N = 1;
128 bp->dtype = bp2->dtype = MyType;
129 diff --git a/BLACS/SRC/sgamx2d_.c b/BLACS/SRC/sgamx2d_.c
130 index 4b0af6f..8897ece 100644
131 --- a/BLACS/SRC/sgamx2d_.c
132 +++ b/BLACS/SRC/sgamx2d_.c
133 @@ -221,7 +221,7 @@ F_VOID_FUNC sgamx2d_(int *ConTxt, F_CHAR scope, F_CHAR top, int *m, int *n,
134 {
135 #endif
136 i = 2;
137 - ierr=MPI_Type_struct(i, len, disp, dtypes, &MyType);
138 + ierr=MPI_Type_create_struct(i, len, disp, dtypes, &MyType);
139 ierr=MPI_Type_commit(&MyType);
140 bp->N = bp2->N = 1;
141 bp->dtype = bp2->dtype = MyType;
142 diff --git a/BLACS/SRC/zgamn2d_.c b/BLACS/SRC/zgamn2d_.c
143 index 9de2b23..37897df 100644
144 --- a/BLACS/SRC/zgamn2d_.c
145 +++ b/BLACS/SRC/zgamn2d_.c
146 @@ -221,7 +221,7 @@ F_VOID_FUNC zgamn2d_(int *ConTxt, F_CHAR scope, F_CHAR top, int *m, int *n,
147 {
148 #endif
149 i = 2;
150 - ierr=MPI_Type_struct(i, len, disp, dtypes, &MyType);
151 + ierr=MPI_Type_create_struct(i, len, disp, dtypes, &MyType);
152 ierr=MPI_Type_commit(&MyType);
153 bp->N = bp2->N = 1;
154 bp->dtype = bp2->dtype = MyType;
155 diff --git a/BLACS/SRC/zgamx2d_.c b/BLACS/SRC/zgamx2d_.c
156 index 414c381..0e9d474 100644
157 --- a/BLACS/SRC/zgamx2d_.c
158 +++ b/BLACS/SRC/zgamx2d_.c
159 @@ -221,7 +221,7 @@ F_VOID_FUNC zgamx2d_(int *ConTxt, F_CHAR scope, F_CHAR top, int *m, int *n,
160 {
161 #endif
162 i = 2;
163 - ierr=MPI_Type_struct(i, len, disp, dtypes, &MyType);
164 + ierr=MPI_Type_create_struct(i, len, disp, dtypes, &MyType);
165 ierr=MPI_Type_commit(&MyType);
166 bp->N = bp2->N = 1;
167 bp->dtype = bp2->dtype = MyType;
168 --
169 2.20.1
170