gnu: Add perl-crypt-openssl-bignum.
[jackhill/guix/guix.git] / gnu / packages / speech.scm
1 ;;; GNU Guix --- Functional package management for GNU
2 ;;; Copyright © 2016 David Thompson <davet@gnu.org>
3 ;;;
4 ;;; This file is part of GNU Guix.
5 ;;;
6 ;;; GNU Guix is free software; you can redistribute it and/or modify it
7 ;;; under the terms of the GNU General Public License as published by
8 ;;; the Free Software Foundation; either version 3 of the License, or (at
9 ;;; your option) any later version.
10 ;;;
11 ;;; GNU Guix is distributed in the hope that it will be useful, but
12 ;;; WITHOUT ANY WARRANTY; without even the implied warranty of
13 ;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
14 ;;; GNU General Public License for more details.
15 ;;;
16 ;;; You should have received a copy of the GNU General Public License
17 ;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
18
19 (define-module (gnu packages speech)
20 #:use-module ((guix licenses) #:prefix license:)
21 #:use-module (guix packages)
22 #:use-module (guix download)
23 #:use-module (guix build-system gnu)
24 #:use-module (gnu packages)
25 #:use-module (gnu packages gcc))
26
27 (define-public mitlm
28 (package
29 (name "mitlm")
30 (version "0.4.1")
31 ;; No official release tarballs, so for now we use the one from Debian
32 ;; that is maintained by one of the project developers.
33 ;;
34 ;; See: https://github.com/mitlm/mitlm/issues/54
35 (source (origin
36 (method url-fetch)
37 (uri (string-append "mirror://debian/pool/main/m/mitlm/mitlm_"
38 version ".orig.tar.gz"))
39 (sha256
40 (base32
41 "12m09xxx8jbir9cnzzaysvni5sfijpfj96z1x1520qqvmpc8lmn7"))))
42 (build-system gnu-build-system)
43 (native-inputs
44 `(("gfortran" ,gfortran)))
45 (synopsis "The MIT Language Modeling toolkit")
46 (description "The MIT Language Modeling (MITLM) toolkit is a set of
47 tools designed for the efficient estimation of statistical n-gram language
48 models involving iterative parameter estimation. It achieves much of its
49 efficiency through the use of a compact vector representation of n-grams.")
50 (home-page "https://github.com/mitlm/mitlm")
51 (license license:expat)))