gnu: Add perl-crypt-openssl-bignum.
[jackhill/guix/guix.git] / gnu / packages / datamash.scm
1 ;;; GNU Guix --- Functional package management for GNU
2 ;;; Copyright © 2014 Eric Bavier <bavier@member.fsf.org>
3 ;;; Copyright © 2016 Efraim Flashner <efraim@flashner.co.il>
4 ;;;
5 ;;; This file is part of GNU Guix.
6 ;;;
7 ;;; GNU Guix is free software; you can redistribute it and/or modify it
8 ;;; under the terms of the GNU General Public License as published by
9 ;;; the Free Software Foundation; either version 3 of the License, or (at
10 ;;; your option) any later version.
11 ;;;
12 ;;; GNU Guix is distributed in the hope that it will be useful, but
13 ;;; WITHOUT ANY WARRANTY; without even the implied warranty of
14 ;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
15 ;;; GNU General Public License for more details.
16 ;;;
17 ;;; You should have received a copy of the GNU General Public License
18 ;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
19
20 (define-module (gnu packages datamash)
21 #:use-module (guix packages)
22 #:use-module (guix licenses)
23 #:use-module (guix download)
24 #:use-module (guix build-system gnu)
25 #:use-module (gnu packages perl)
26 #:use-module (gnu packages base))
27
28 (define-public datamash
29 (package
30 (name "datamash")
31 (version "1.1.0")
32 (source
33 (origin
34 (method url-fetch)
35 (uri (string-append "mirror://gnu/datamash/datamash-"
36 version ".tar.gz"))
37 (sha256
38 (base32
39 "1c2bj0jrm4fxkf0ykxkzgyk1l9s0idqm8rbzmk3n9pgldb4arrd9"))))
40 (native-inputs
41 `(("which" ,which) ;for tests
42 ("perl" ,perl))) ;for help2man
43 (build-system gnu-build-system)
44 (home-page "https://www.gnu.org/software/datamash/")
45 (synopsis "Scriptable statistics and data calculation")
46 (description
47 "Perform basic numeric, textual and statistical operations on plain text
48 files. Designed to work within standard pipelines without additional code.")
49 (license gpl3+)))