Merge branch 'master' into core-updates
[jackhill/guix/guix.git] / gnu / packages / libunistring.scm
1 ;;; GNU Guix --- Functional package management for GNU
2 ;;; Copyright © 2012, 2013, 2014 Ludovic Courtès <ludo@gnu.org>
3 ;;; Copyright © 2015 Mark H Weaver <mhw@netris.org>
4 ;;; Copyright © 2016, 2018 Efraim Flashner <efraim@flashner.co.il>
5 ;;; Copyright © 2016 Jan Nieuwenhuizen <janneke@gnu.org>
6 ;;; Copyright © 2017 Mathieu Othacehe <m.othacehe@gmail.com>
7 ;;; Copyright © 2017 Eric Bavier <bavier@member.fsf.org>
8 ;;; Copyright © 2018 Tobias Geerinckx-Rice <me@tobias.gr>
9 ;;;
10 ;;; This file is part of GNU Guix.
11 ;;;
12 ;;; GNU Guix is free software; you can redistribute it and/or modify it
13 ;;; under the terms of the GNU General Public License as published by
14 ;;; the Free Software Foundation; either version 3 of the License, or (at
15 ;;; your option) any later version.
16 ;;;
17 ;;; GNU Guix is distributed in the hope that it will be useful, but
18 ;;; WITHOUT ANY WARRANTY; without even the implied warranty of
19 ;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
20 ;;; GNU General Public License for more details.
21 ;;;
22 ;;; You should have received a copy of the GNU General Public License
23 ;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
24
25 (define-module (gnu packages libunistring)
26 #:use-module (guix licenses)
27 #:use-module (guix packages)
28 #:use-module (guix download)
29 #:use-module (guix build-system gnu)
30 #:use-module (gnu packages)
31 #:use-module (gnu packages base))
32
33 (define-public libunistring
34 (package
35 (name "libunistring")
36 (version "0.9.10")
37 (source (origin
38 (method url-fetch)
39 (uri (string-append
40 "mirror://gnu/libunistring/libunistring-"
41 version ".tar.xz"))
42 (sha256
43 (base32
44 "1mq57h06622m6qc5cv347fc3qk5mj840axw3c0vd7qmnwk1v53zb"))))
45 (propagated-inputs (libiconv-if-needed))
46 (build-system gnu-build-system)
47 (arguments
48 ;; Work around parallel build issue whereby C files may be compiled before
49 ;; config.h is built: see <http://hydra.gnu.org/build/59381/nixlog/2/raw> and
50 ;; <http://lists.openembedded.org/pipermail/openembedded-core/2012-April/059850.html>.
51 '(#:parallel-build? #f))
52 (synopsis "C library for manipulating Unicode strings")
53 (description
54 "GNU libunistring is a library providing functions to manipulate
55 Unicode strings and for manipulating C strings according to the Unicode
56 standard.")
57 (home-page "https://www.gnu.org/software/libunistring/")
58 (license (list lgpl3+ gpl2))))