Merge branch 'master' into core-updates
[jackhill/guix/guix.git] / gnu / packages / irc.scm
1 ;;; GNU Guix --- Functional package management for GNU
2 ;;; Copyright © 2013 Cyril Roelandt <tipecaml@gmail.com>
3 ;;; Copyright © 2014 Kevin Lemonnier <lemonnierk@ulrar.net>
4 ;;; Copyright © 2015, 2017 Ludovic Courtès <ludo@gnu.org>
5 ;;; Copyright © 2015, 2016, 2017, 2018 Efraim Flashner <efraim@flashner.co.il>
6 ;;; Copyright © 2016 Nils Gillmann <ng0@n0.is>
7 ;;; Copyright © 2017 Marius Bakke <mbakke@fastmail.com>
8 ;;; Copyright © 2017, 2018 Tobias Geerinckx-Rice <me@tobias.gr>
9 ;;;
10 ;;; This file is part of GNU Guix.
11 ;;;
12 ;;; GNU Guix is free software; you can redistribute it and/or modify it
13 ;;; under the terms of the GNU General Public License as published by
14 ;;; the Free Software Foundation; either version 3 of the License, or (at
15 ;;; your option) any later version.
16 ;;;
17 ;;; GNU Guix is distributed in the hope that it will be useful, but
18 ;;; WITHOUT ANY WARRANTY; without even the implied warranty of
19 ;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
20 ;;; GNU General Public License for more details.
21 ;;;
22 ;;; You should have received a copy of the GNU General Public License
23 ;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
24
25 (define-module (gnu packages irc)
26 #:use-module ((guix licenses) #:prefix license:)
27 #:use-module (guix download)
28 #:use-module (guix packages)
29 #:use-module (guix build-system cmake)
30 #:use-module (guix build-system gnu)
31 #:use-module (guix build-system python)
32 #:use-module (gnu packages)
33 #:use-module (gnu packages aspell)
34 #:use-module (gnu packages autogen)
35 #:use-module (gnu packages autotools)
36 #:use-module (gnu packages base)
37 #:use-module (gnu packages backup)
38 #:use-module (gnu packages check)
39 #:use-module (gnu packages compression)
40 #:use-module (gnu packages curl)
41 #:use-module (gnu packages cyrus-sasl)
42 #:use-module (gnu packages databases)
43 #:use-module (gnu packages file)
44 #:use-module (gnu packages gettext)
45 #:use-module (gnu packages glib)
46 #:use-module (gnu packages gnupg)
47 #:use-module (gnu packages guile)
48 #:use-module (gnu packages lua)
49 #:use-module (gnu packages ncurses)
50 #:use-module (gnu packages kde)
51 #:use-module (gnu packages kde-frameworks)
52 #:use-module (gnu packages perl)
53 #:use-module (gnu packages pkg-config)
54 #:use-module (gnu packages python)
55 #:use-module (gnu packages python-crypto)
56 #:use-module (gnu packages ruby)
57 #:use-module (gnu packages qt)
58 #:use-module (gnu packages tcl)
59 #:use-module (gnu packages time)
60 #:use-module (gnu packages tls)
61 #:use-module (gnu packages web)
62 #:use-module (srfi srfi-1)
63 #:use-module (srfi srfi-26))
64
65 (define-public quassel
66 (package
67 (name "quassel")
68 (version "0.12.5")
69 (source
70 (origin
71 (method url-fetch)
72 (uri (string-append "http://quassel-irc.org/pub/quassel-"
73 version ".tar.bz2"))
74 (sha256
75 (base32
76 "1qkl3sb4ijx4k17m0c42j2p5bc4jymypwhmplm942rbrzm6mg50q"))
77 (modules '((guix build utils)))
78 ;; We don't want to install the bundled scripts.
79 (snippet
80 '(begin
81 (delete-file-recursively "data/scripts")
82 (substitute* "data/CMakeLists.txt"
83 (("NOT WIN32") "WIN32"))
84 #t))))
85 (build-system cmake-build-system)
86 (arguments
87 ;; The three binaries are not mutually exlusive, and are all built
88 ;; by default.
89 '(#:configure-flags '(;;"-DWANT_QTCLIENT=OFF" ; 5.2 MiB
90 ;;"-DWANT_CORE=OFF" ; 2.4 MiB
91 ;;"-DWANT_MONO=OFF" ; 6.4 MiB
92 "-DUSE_QT5=ON" ; default is qt4
93 "-DWITH_KDE=OFF" ; no to kde integration ...
94 "-DWITH_OXYGEN=ON" ; therefore we install bundled icons
95 "-DWITH_WEBKIT=OFF") ; we don't depend on qtwebkit
96 #:tests? #f)) ; no test target
97 (native-inputs
98 `(("extra-cmake-modules" ,extra-cmake-modules)
99 ("pkg-config" ,pkg-config)
100 ("qttools" ,qttools)))
101 (inputs
102 `(("qca" ,qca)
103 ("qtbase" ,qtbase)
104 ("qtscript" ,qtscript)
105 ("snorenotify" ,snorenotify)
106 ("zlib" ,zlib)))
107 (home-page "https://quassel-irc.org/")
108 (synopsis "Distributed IRC client")
109 (description "Quassel is a distributed IRC client, meaning that one or more
110 clients can attach to and detach from the central core. It resembles the
111 popular combination of screen and a text-based IRC client such as WeeChat or
112 irssi, but graphical.")
113 (license (list license:gpl2 license:gpl3)))) ;; dual licensed
114
115 (define-public irssi
116 (package
117 (name "irssi")
118 (version "1.1.1")
119 (source (origin
120 (method url-fetch)
121 (uri (string-append "https://github.com/irssi/irssi/"
122 "releases/download/" version "/irssi-"
123 version ".tar.xz"))
124 (sha256
125 (base32
126 "1gx1flfh4a09nb3b5pvf0ygnbl7rry3l4gph8wij29dsl7khfj3q"))))
127 (build-system gnu-build-system)
128 (arguments
129 `(#:phases
130 (modify-phases %standard-phases
131 (replace 'configure
132 (lambda* (#:key inputs outputs #:allow-other-keys)
133 (let ((out (assoc-ref outputs "out")))
134 (setenv "CONFIG_SHELL" (which "bash"))
135 (invoke "./configure"
136 (string-append "--prefix=" out)
137 (string-append "--with-proxy")
138 (string-append "--with-socks")
139 (string-append "--with-bot"))))))))
140 (inputs
141 `(("glib" ,glib)
142 ("ncurses" ,ncurses)
143 ("openssl" ,openssl)
144 ("perl" ,perl)))
145 (native-inputs
146 `(("pkg-config" ,pkg-config)))
147 (home-page "https://irssi.org/")
148 (synopsis "Terminal-based IRC client")
149 (description
150 "Irssi is a terminal based IRC client for UNIX systems. It also supports
151 SILC and ICB protocols via plugins.")
152 (license license:gpl2+)))
153
154 (define-public weechat
155 (package
156 (name "weechat")
157 (version "2.1")
158 (source (origin
159 (method url-fetch)
160 (uri (string-append "https://weechat.org/files/src/weechat-"
161 version ".tar.xz"))
162 (sha256
163 (base32
164 "0f7d2vdbxc5kgjl7lkamnbxvidgxwa8f9j3nr9fd4gr4z0gzi86d"))
165 (patches (search-patches "weechat-python.patch"))))
166 (build-system cmake-build-system)
167 (native-inputs
168 `(("gettext" ,gettext-minimal)
169 ("pkg-config" ,pkg-config)
170 ;; For tests.
171 ("cpputest" ,cpputest)))
172 (inputs `(("ncurses" ,ncurses)
173 ("libgcrypt" ,libgcrypt "out")
174 ("zlib" ,zlib)
175 ("aspell" ,aspell)
176 ("curl" ,curl)
177 ("gnutls" ,gnutls)
178 ("guile" ,guile-2.0)
179 ("lua" ,lua-5.1)
180 ("python" ,python-2)
181 ("perl" ,perl)
182 ("tcl" ,tcl)))
183 (arguments
184 `(#:configure-flags
185 (list "-DENABLE_TESTS=ON") ; ‘make test’ fails otherwise
186 ;; Tests hang indefinately on non-Intel platforms.
187 #:tests? ,(if (any (cute string-prefix? <> (or (%current-target-system)
188 (%current-system)))
189 '("i686" "x86_64"))
190 '#t '#f)
191 #:phases
192 (modify-phases %standard-phases
193 (add-after 'unpack 'disable-failing-tests
194 ;; For reasons best left to the imagination, CppUTest cannot skip
195 ;; more than one single test... Resort to manual patching instead.
196 ;; See <https://cpputest.github.io/manual.html#command_line>.
197 (λ _
198 ;; Don't test plugin support for languages we don't enable.
199 (substitute* "tests/unit/test-plugins.cpp"
200 ((".*\\$\\{plugin.name\\} == (javascript|php|ruby)" all)
201 (string-append "// SKIP" all)))
202 (substitute* "tests/scripts/test-scripts.cpp"
203 ((".*\\{ \"(jvascript|php|ruby)\", " all) ; sic
204 (string-append "// SKIP" all)))
205 #t))
206 (add-after 'install 'wrap
207 (lambda* (#:key inputs outputs #:allow-other-keys)
208 (let ((out (assoc-ref outputs "out"))
209 (py2 (assoc-ref inputs "python")))
210 (wrap-program (string-append out "/bin/weechat")
211 `("PATH" ":" prefix (,(string-append py2 "/bin"))))
212 #t))))))
213 (synopsis "Extensible chat client")
214 (description "WeeChat (Wee Enhanced Environment for Chat) is an
215 @dfn{Internet Relay Chat} (IRC) client, which is designed to be light and fast.
216 The client uses a curses frontend, and there are remote interfaces for Web,
217 Qt, Android, and Emacs.
218
219 Everything in WeeChat can be done with the keyboard, though it also supports
220 using a mouse. It is customizable and extensible with plugins and scripts.")
221 (home-page "https://www.weechat.org/")
222 (license license:gpl3)))
223
224 (define-public ircii
225 (package
226 (name "ircii")
227 (version "20151120")
228 (source (origin
229 (method url-fetch)
230 (uri (string-append "https://ircii.warped.com/"
231 name "-" version ".tar.gz"))
232 (sha256
233 (base32
234 "178dc279f5j894qvp96dzz7c0jpryqlcqw5g0dc9yaxg9kgw1lqm"))))
235 (build-system gnu-build-system)
236 ;; TODO: We should package a small socks4/5 library/server to configure
237 ;; ircii with socks client. `ghc-socks' pulls in lots of haskell, which
238 ;; is too big.
239 (arguments
240 `(#:tests? #f
241 #:configure-flags (list
242 "--enable-ipv6"
243 "--with-emacs-meta-keys"
244 (string-append "--with-openssl="
245 (assoc-ref %build-inputs "openssl")))
246 #:phases
247 (modify-phases %standard-phases
248 (add-after 'unpack 'patch-bsdinstall-absolute-path-bins
249 (lambda* (#:key inputs #:allow-other-keys)
250 (substitute* "bsdinstall"
251 (("/bin/strip") "strip")
252 (("/bin/cp") "cp")
253 (("/bin/chmod") "chmod")
254 (("/etc/chown") "chown")
255 (("/bin/chgrp") "chgrp")
256 (("/bin/mkdir") "mkdir")
257 (("/bin/rm") "rm")
258 (("/bin/mv") "mv")))))))
259 (inputs
260 `(("ncurses" ,ncurses)
261 ("openssl" ,openssl)))
262 (native-inputs
263 `(("pkg-config" ,pkg-config)
264 ("perl" ,perl)))
265 (home-page "http://www.eterna.com.au/ircii/")
266 (synopsis "Terminal-based IRC and ICB client")
267 (description
268 "ircII is a terminal based IRC and ICB client for UNIX systems.")
269 (license license:bsd-3)))
270
271 (define-public ii
272 (package
273 (name "ii")
274 (version "1.8")
275 (source (origin
276 (method url-fetch)
277 (uri (string-append "http://dl.suckless.org/tools/"
278 name "-" version ".tar.gz"))
279 (sha256
280 (base32
281 "1lk8vjl7i8dcjh4jkg8h8bkapcbs465sy8g9c0chfqsywbmf3ndr"))))
282 (build-system gnu-build-system)
283 (arguments
284 `(#:tests? #f ; no tests
285 #:make-flags (list (string-append "PREFIX=" %output)
286 "CC=gcc")
287 #:phases
288 (modify-phases %standard-phases
289 (delete 'configure)))) ; no configure
290 (home-page "https://tools.suckless.org/ii/")
291 (synopsis "FIFO and file system based IRC client")
292 (description
293 "ii (Irc it) is a minimalist FIFO and file system based IRC client.")
294 (license license:expat)))
295
296 (define-public sic
297 (package
298 (name "sic")
299 (version "1.2")
300 (source (origin
301 (method url-fetch)
302 (uri (string-append "http://dl.suckless.org/tools/"
303 name "-" version ".tar.gz"))
304 (sha256
305 (base32
306 "11aiavxp44yayibc58bvimi8mrxvbw1plbci8cnbl4syk42zj1xc"))))
307 (build-system gnu-build-system)
308 (arguments
309 `(#:tests? #f ; no tests
310 #:make-flags (list "CC=gcc"
311 (string-append "PREFIX=" %output))
312 #:phases
313 (modify-phases %standard-phases
314 (delete 'configure)))) ; no configure
315 (home-page "https://tools.suckless.org/sic/")
316 (synopsis "Simple IRC client")
317 (description
318 "sic is a simple IRC client, even more minimalistic than ii.")
319 (license license:expat)))
320
321 (define-public limnoria
322 (package
323 (name "limnoria")
324 (version "2017.10.01")
325 (source
326 (origin
327 (method url-fetch)
328 (uri (pypi-uri "limnoria" version))
329 (sha256
330 (base32
331 "1hd8h257x7a0s4rvb4aqvfi77qfcyv6jaz70nndg7y6p4yhvjmy6"))))
332 (build-system python-build-system)
333 (inputs
334 `(("python-pytz" ,python-pytz)
335 ("python-chardet" ,python-chardet)
336 ("python-dateutil" ,python-dateutil)
337 ("python-gnupg" ,python-gnupg)
338 ("python-feedparser" ,python-feedparser)
339 ("python-sqlalchemy" ,python-sqlalchemy)
340 ("python-socksipy-branch" ,python-socksipy-branch)
341 ("python-ecdsa" ,python-ecdsa)))
342 (native-inputs
343 `(("python-mock" ,python-mock)))
344 ;; Despite the existence of a test folder there is no test phase.
345 ;; We need to package https://github.com/ProgVal/irctest and write
346 ;; our own testphase.
347 (arguments
348 `(#:tests? #f))
349 (home-page "https://github.com/ProgVal/Limnoria")
350 (synopsis "Modified version of Supybot (an IRC bot and framework)")
351 (description
352 "Modified version of Supybot with Python 3 and IRCv3 support,
353 embedded web server, translations (fr, fi, it, hu, de), and many
354 other enhancements and bug fixes.")
355 (license license:bsd-3)))
356
357 (define-public epic5
358 (package
359 (name "epic5")
360 (version "2.0.1")
361 (source (origin
362 (method url-fetch)
363 (uri (string-append "http://ftp.epicsol.org/pub/"
364 "epic/EPIC5-PRODUCTION/"
365 name "-" version ".tar.xz"))
366 (sha256
367 (base32
368 "1ap73d5f4vccxjaaq249zh981z85106vvqmxfm4plvy76b40y9jm"))))
369 (build-system gnu-build-system)
370 (arguments
371 `(#:test-target "test"
372 #:phases
373 (modify-phases %standard-phases
374 (add-after 'unpack 'patch-perl
375 (lambda _
376 (substitute* "regress/crash-irc"
377 (("perl5") (which "perl")))
378 #t))
379 (add-after 'unpack 'patch-bsdinstall
380 ;; If we just remove /bin/ some part of the bsdinstall breaks.
381 ;; Furthermore bsdinstalls has a reference to /etc/chmod here, which
382 ;; means if we leave /etc/ in, install fails.
383 (lambda _
384 (substitute* "bsdinstall"
385 (("/bin/strip") "strip")
386 (("/bin/cp") "cp")
387 (("/bin/chmod") "chmod")
388 (("/bin/chgrp") "chgrp")
389 (("/bin/mkdir") "mkdir")
390 (("/bin/rm") "rm")
391 (("/bin/mv") "mv")
392 (("/etc/") ""))
393 #t))
394 (replace 'configure
395 (lambda* (#:key outputs #:allow-other-keys)
396 ;; The tarball uses a very old version of autconf. It does not
397 ;; understand extra flags like `--enable-fast-install', so
398 ;; we need to invoke it with just what it understands.
399 (let ((out (assoc-ref outputs "out")))
400 ;; 'configure' doesn't understand '--host'.
401 ,@(if (%current-target-system)
402 `((setenv "CHOST" ,(%current-target-system)))
403 '())
404 (setenv "CONFIG_SHELL" (which "bash"))
405 (setenv "SHELL" (which "bash"))
406 (invoke "./configure"
407 (string-append "--prefix=" out)
408 "--with-ipv6" "--with-libarchive"
409 ;; We use libressl because openssl does not come
410 ;; with the lib/libssl.a which is needed for epic5.
411 ;; XXX: No matter which implementation is chosen,
412 ;; epic5 fails to connect to tls ports of roundrobin
413 ;; irc networks. This however is believed to be an
414 ;; protocol issue at epic5 related to ircd.
415 (string-append "--with-ssl="
416 (assoc-ref %build-inputs "libressl"))
417 (string-append "--with-tcl="
418 (assoc-ref %build-inputs "tcl")
419 "/lib/tclConfig.sh"))))))))
420 (inputs
421 `(("libressl" ,libressl)
422 ("ncurses" ,ncurses)
423 ("libarchive" ,libarchive) ; CHANGELOG: "Support for loading zip files"
424 ("perl" ,perl)
425 ("tcl" ,tcl)
426 ("ruby" ,ruby)))
427 (native-inputs
428 `(("pkg-config" ,pkg-config)))
429 (home-page "http://epicsol.org")
430 (synopsis "Epic5 IRC Client")
431 (description
432 "EPIC is a IRC client that has been under active development for
433 over 20 years. It is stable and mature, and offers an excellent ircII
434 interface for those who are accustomed to the ircII way of doing things.")
435 (license (list license:bsd-3
436 license:isc
437 license:bsd-4
438 ;; The epic license is equal to the standard three-clause
439 ;; BSD license except that you are not permitted to remove the
440 ;; "Redistribution is permitted" clause of the license if you
441 ;; distribute binaries.
442 (license:non-copyleft "http://epicsol.org/copyright")))))