Merge branch 'master' into core-updates
[jackhill/guix/guix.git] / gnu / packages / cinnamon.scm
1 ;;; GNU Guix --- Functional package management for GNU
2 ;;; Copyright © 2017 Nils Gillmann <ng0@n0.is>
3 ;;;
4 ;;; This file is part of GNU Guix.
5 ;;;
6 ;;; GNU Guix is free software; you can redistribute it and/or modify it
7 ;;; under the terms of the GNU General Public License as published by
8 ;;; the Free Software Foundation; either version 3 of the License, or (at
9 ;;; your option) any later version.
10 ;;;
11 ;;; GNU Guix is distributed in the hope that it will be useful, but
12 ;;; WITHOUT ANY WARRANTY; without even the implied warranty of
13 ;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
14 ;;; GNU General Public License for more details.
15 ;;;
16 ;;; You should have received a copy of the GNU General Public License
17 ;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
18
19 (define-module (gnu packages cinnamon)
20 #:use-module ((guix licenses) #:prefix license:)
21 #:use-module (guix packages)
22 #:use-module (guix download)
23 #:use-module (guix utils)
24 #:use-module (guix build-system gnu)
25 #:use-module (gnu packages)
26 #:use-module (gnu packages autotools)
27 #:use-module (gnu packages freedesktop)
28 #:use-module (gnu packages gettext)
29 #:use-module (gnu packages glib)
30 #:use-module (gnu packages gtk)
31 #:use-module (gnu packages gnome)
32 #:use-module (gnu packages pkg-config)
33 #:use-module (gnu packages pulseaudio)
34 #:use-module (gnu packages python)
35 #:use-module (gnu packages xorg))
36
37 (define-public cinnamon-desktop
38 (package
39 (name "cinnamon-desktop")
40 (version "3.4.2")
41 (source (origin
42 (method url-fetch)
43 (uri (string-append "https://github.com/linuxmint/cinnamon-desktop/"
44 "archive/" version ".tar.gz"))
45 (file-name (string-append name "-" version ".tar.gz"))
46 (sha256
47 (base32
48 "1jf24csrbfi9aiza1g70jpvsbjiqwphk0i5wilxq9kpjjsl99maq"))))
49 (build-system gnu-build-system)
50 (arguments
51 `(#:phases
52 (modify-phases %standard-phases
53 (add-after 'unpack 'autoconf
54 (lambda _
55 (mkdir-p "m4")
56 (zero?
57 (and (system* "glib-gettextize" "--force" "--copy")
58 (system* "intltoolize" "--force" "--copy" "--automake")
59 (system* "autoreconf" "--verbose" "--force" "--install"))))))))
60 ;; TODO: package 'libgsystem'.
61 (inputs
62 `(("accountsservice" ,accountsservice)
63 ("gtk+" ,gtk+)
64 ("glib" ,glib)
65 ("gobject-introspection" ,gobject-introspection)
66 ("gnome-common" ,gnome-common)
67 ("libxkbfile" ,libxkbfile)
68 ("libxrandr" ,libxrandr)
69 ("python-2" ,python-2)
70 ("pulseaudio" ,pulseaudio)
71 ("xkeyboard-config" ,xkeyboard-config)))
72 (native-inputs
73 `(("autoconf" ,autoconf)
74 ("automake" ,automake)
75 ("gettext" ,gettext-minimal)
76 ("glib" ,glib "bin") ; glib-gettextize
77 ("intltool" ,intltool)
78 ("libtool" ,libtool)
79 ("pkg-config" ,pkg-config)))
80 (home-page "https://github.com/linuxmint/cinnamon-desktop/")
81 (synopsis "Library for the Cinnamon Desktop")
82 (description
83 "The cinnamon-desktop package contains the libcinnamon-desktop library,
84 as well as some desktop-wide documents.")
85 (license (list license:gpl2+ license:lgpl2.0+
86 license:expat)))) ;display-name.c , edid-parse.c