gnu: Update harfbuzz to 0.9.20.
[jackhill/guix/guix.git] / gnu / packages / xnee.scm
1 ;;; GNU Guix --- Functional package management for GNU
2 ;;; Copyright © 2013 Ludovic Courtès <ludo@gnu.org>
3 ;;;
4 ;;; This file is part of GNU Guix.
5 ;;;
6 ;;; GNU Guix is free software; you can redistribute it and/or modify it
7 ;;; under the terms of the GNU General Public License as published by
8 ;;; the Free Software Foundation; either version 3 of the License, or (at
9 ;;; your option) any later version.
10 ;;;
11 ;;; GNU Guix is distributed in the hope that it will be useful, but
12 ;;; WITHOUT ANY WARRANTY; without even the implied warranty of
13 ;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
14 ;;; GNU General Public License for more details.
15 ;;;
16 ;;; You should have received a copy of the GNU General Public License
17 ;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
18
19 (define-module (gnu packages xnee)
20 #:use-module (guix packages)
21 #:use-module (guix licenses)
22 #:use-module (guix download)
23 #:use-module (guix build-system gnu)
24 #:use-module (gnu packages xorg)
25 #:use-module (gnu packages pkg-config)
26 #:use-module (gnu packages gtk))
27
28 (define-public xnee
29 (package
30 (name "xnee")
31 (version "3.16")
32 (source (origin
33 (method url-fetch)
34 (uri (string-append "mirror://gnu/xnee/xnee-"
35 version ".tar.gz"))
36 (sha256
37 (base32
38 "1zkn66zpnbxryrb76cc3r2via6216868l1xsnl3vdymbsy23sf87"))))
39 (build-system gnu-build-system)
40 (inputs
41 `(("recordproto" ,recordproto)
42 ("pkg-config" ,pkg-config)
43 ("inputproto" ,inputproto)
44 ("libxi" ,libxi)
45 ("gtk+" ,gtk+)
46 ("libxtst" ,libxtst)
47 ("xextproto" ,xextproto)
48 ("libxext" ,libxext)
49 ("xproto" ,xproto)
50 ("libx11" ,libx11)))
51 (home-page "http://www.gnu.org/software/xnee/")
52 (synopsis "Record, replay and distribute user actions under X11")
53 (description
54 "GNU Xnee is a suite of programs that can record, replay and distribute
55 user actions under the X11 environment. Think of it as a robot that can
56 imitate the job you just did. Xnee can be used to automate tests, demonstrate
57 programs, distribute actions, record & replay \"macros\", retype a file.")
58 (license gpl3+)))