gnu: Update harfbuzz to 0.9.20.
[jackhill/guix/guix.git] / gnu / packages / xml.scm
1 ;;; GNU Guix --- Functional package management for GNU
2 ;;; Copyright © 2013 Ludovic Courtès <ludo@gnu.org>
3 ;;; Copyright © 2013 Andreas Enge <andreas@enge.fr>
4 ;;;
5 ;;; This file is part of GNU Guix.
6 ;;;
7 ;;; GNU Guix is free software; you can redistribute it and/or modify it
8 ;;; under the terms of the GNU General Public License as published by
9 ;;; the Free Software Foundation; either version 3 of the License, or (at
10 ;;; your option) any later version.
11 ;;;
12 ;;; GNU Guix is distributed in the hope that it will be useful, but
13 ;;; WITHOUT ANY WARRANTY; without even the implied warranty of
14 ;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
15 ;;; GNU General Public License for more details.
16 ;;;
17 ;;; You should have received a copy of the GNU General Public License
18 ;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
19
20 (define-module (gnu packages xml)
21 #:use-module (gnu packages)
22 #:use-module (gnu packages compression)
23 #:use-module (gnu packages gnupg)
24 #:use-module (gnu packages perl)
25 #:use-module (gnu packages python)
26 #:use-module ((guix licenses)
27 #:renamer (symbol-prefix-proc 'license:))
28 #:use-module (guix packages)
29 #:use-module (guix download)
30 #:use-module (guix build-system gnu)
31 #:use-module (guix build-system perl)
32 #:use-module (gnu packages linux))
33
34 (define-public expat
35 (package
36 (name "expat")
37 (version "2.1.0")
38 (source (origin
39 (method url-fetch)
40 (uri (string-append "mirror://sourceforge/expat/expat/"
41 version "/expat-" version ".tar.gz"))
42 (sha256
43 (base32
44 "11pblz61zyxh68s5pdcbhc30ha1b2vfjd83aiwfg4vc15x3hadw2"))))
45 (build-system gnu-build-system)
46 (home-page "http://www.libexpat.org/")
47 (synopsis "A stream-oriented XML parser library written in C")
48 (description
49 "Expat is an XML parser library written in C. It is a
50 stream-oriented parser in which an application registers handlers for
51 things the parser might find in the XML document (like start tags).")
52 (license license:expat)))
53
54 (define-public libxml2
55 (package
56 (name "libxml2")
57 (version "2.9.0")
58 (source (origin
59 (method url-fetch)
60 (uri (string-append "ftp://xmlsoft.org/libxml2/libxml2-"
61 version ".tar.gz"))
62 (sha256
63 (base32
64 "10ib8bpar2pl68aqksfinvfmqknwnk7i35ibq6yjl8dpb0cxj9dd"))))
65 (build-system gnu-build-system)
66 (home-page "http://www.xmlsoft.org/")
67 (synopsis "libxml2, a C parser for XML")
68 (inputs `(("perl" ,perl)
69 ("python" ,python)
70 ("zlib" ,zlib)))
71 (arguments
72 `(#:phases
73 (alist-replace
74 'install
75 (lambda* (#:key inputs outputs #:allow-other-keys #:rest args)
76 (let ((install (assoc-ref %standard-phases 'install))
77 (glibc (assoc-ref inputs "libc"))
78 (out (assoc-ref outputs "out")))
79 (apply install args)
80 (chdir "python")
81 (substitute* "setup.py" (("/opt/include") (string-append glibc "/include")))
82 (system* "python" "setup.py" "install" (string-append "--prefix=" out))))
83 %standard-phases)))
84 (description
85 "Libxml2 is the XML C parser and toolkit developed for the Gnome project
86 (but it is usable outside of the Gnome platform).")
87 (license license:x11)))
88
89 (define-public libxslt
90 (package
91 (name "libxslt")
92 (version "1.1.28")
93 (source (origin
94 (method url-fetch)
95 (uri (string-append "ftp://xmlsoft.org/libxslt/libxslt-"
96 version ".tar.gz"))
97 (sha256
98 (base32
99 "13029baw9kkyjgr7q3jccw2mz38amq7mmpr5p3bh775qawd1bisz"))))
100 (build-system gnu-build-system)
101 (home-page "http://xmlsoft.org/XSLT/index.html")
102 (synopsis "libxslt, a C library for applying XSLT stylesheets to XML documents")
103 (inputs `(("libgcrypt" ,libgcrypt)
104 ("libxml2" ,libxml2)
105 ("python" ,python)
106 ("zlib" ,zlib)))
107 (description
108 "Libxslt is an XSLT C library developed for the GNOME project. It is
109 based on libxml for XML parsing, tree manipulation and XPath support.")
110 (license license:x11)))
111
112 (define-public perl-xml-parser
113 (package
114 (name "perl-xml-parser")
115 (version "2.41")
116 (source (origin
117 (method url-fetch)
118 (uri (string-append
119 "mirror://cpan/authors/id/T/TO/TODDR/XML-Parser-"
120 version ".tar.gz"))
121 (sha256
122 (base32
123 "1sadi505g5qmxr36lgcbrcrqh3a5gcdg32b405gnr8k54b6rg0dl"))))
124 (build-system perl-build-system)
125 (arguments `(#:make-maker-flags
126 (let ((expat (assoc-ref %build-inputs "expat")))
127 (list (string-append "EXPATLIBPATH=" expat "/lib")
128 (string-append "EXPATINCPATH=" expat "/include")))))
129 (inputs `(("expat" ,expat)))
130 (license (package-license perl))
131 (synopsis "Perl bindings to the Expat XML parsing library")
132 (description
133 "This module provides ways to parse XML documents. It is built on top of
134 XML::Parser::Expat, which is a lower level interface to James Clark's expat
135 library. Each call to one of the parsing methods creates a new instance of
136 XML::Parser::Expat which is then used to parse the document. Expat options
137 may be provided when the XML::Parser object is created. These options are
138 then passed on to the Expat object on each parse call. They can also be given
139 as extra arguments to the parse methods, in which case they override options
140 given at XML::Parser creation time.")
141 (home-page "http://search.cpan.org/~toddr/XML-Parser-2.41/Parser.pm")))
142
143 (define-public xmlto
144 (package
145 (name "xmlto")
146 (version "0.0.25")
147 (source
148 (origin
149 (method url-fetch)
150 (uri (string-append
151 "https://fedorahosted.org/releases/x/m/xmlto/xmlto-"
152 version ".tar.bz2"))
153 (sha256
154 (base32
155 "0dp5nxq491gymq806za0dk4hngfmq65ysrqbn0ypajqbbl6vf71n"))))
156 (build-system gnu-build-system)
157 (inputs
158 `(("util-linux" ,util-linux)))
159 (home-page "http://cyberelk.net/tim/software/xmlto/")
160 (synopsis "Front-end to an XSL toolchain")
161 (description
162 "Xmlto is a front-end to an XSL toolchain. It chooses an appropriate
163 stylesheet for the conversion you want and applies it using an external
164 XSL-T processor. It also performs any necessary post-processing.")
165 (license license:gpl2+)))