gnu: Update harfbuzz to 0.9.20.
[jackhill/guix/guix.git] / gnu / packages / which.scm
1 ;;; GNU Guix --- Functional package management for GNU
2 ;;; Copyright © 2012 Nikita Karetnikov <nikita@karetnikov.org>
3 ;;;
4 ;;; This file is part of GNU Guix.
5 ;;;
6 ;;; GNU Guix is free software; you can redistribute it and/or modify it
7 ;;; under the terms of the GNU General Public License as published by
8 ;;; the Free Software Foundation; either version 3 of the License, or (at
9 ;;; your option) any later version.
10 ;;;
11 ;;; GNU Guix is distributed in the hope that it will be useful, but
12 ;;; WITHOUT ANY WARRANTY; without even the implied warranty of
13 ;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
14 ;;; GNU General Public License for more details.
15 ;;;
16 ;;; You should have received a copy of the GNU General Public License
17 ;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
18
19 (define-module (gnu packages which)
20 #:use-module (guix licenses)
21 #:use-module (guix packages)
22 #:use-module (guix download)
23 #:use-module (guix build-system gnu))
24
25 (define-public which
26 (package
27 (name "which")
28 (version "2.20")
29 (source
30 (origin
31 (method url-fetch)
32 (uri (string-append "mirror://gnu/which/which-"
33 version ".tar.gz"))
34 (sha256
35 (base32
36 "1y2p50zadb36izzh2zw4dm5hvdiydqf3qa88l8kav20dcmfbc5yl"))))
37 (build-system gnu-build-system)
38 (home-page "https://gnu.org/software/which/")
39 (synopsis "Find full path of shell commands")
40 (description
41 "GNU Which takes one or more arguments. For each of its arguments
42 it prints to stdout the full path of the executables that would have
43 been executed when this argument had been entered at the shell
44 prompt. It does this by searching for an executable or script in the
45 directories listed in the environment variable PATH using the same
46 algorithm as bash(1).")
47 (license gpl3+))) ; some files are under GPLv2+