gnu: Update harfbuzz to 0.9.20.
[jackhill/guix/guix.git] / gnu / packages / valgrind.scm
1 ;;; GNU Guix --- Functional package management for GNU
2 ;;; Copyright © 2013 Ludovic Courtès <ludo@gnu.org>
3 ;;;
4 ;;; This file is part of GNU Guix.
5 ;;;
6 ;;; GNU Guix is free software; you can redistribute it and/or modify it
7 ;;; under the terms of the GNU General Public License as published by
8 ;;; the Free Software Foundation; either version 3 of the License, or (at
9 ;;; your option) any later version.
10 ;;;
11 ;;; GNU Guix is distributed in the hope that it will be useful, but
12 ;;; WITHOUT ANY WARRANTY; without even the implied warranty of
13 ;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
14 ;;; GNU General Public License for more details.
15 ;;;
16 ;;; You should have received a copy of the GNU General Public License
17 ;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
18
19 (define-module (gnu packages valgrind)
20 #:use-module (guix packages)
21 #:use-module (guix download)
22 #:use-module (guix build-system gnu)
23 #:use-module (guix licenses)
24 #:use-module (gnu packages gdb)
25 #:use-module (gnu packages perl)
26 #:use-module (gnu packages))
27
28 (define-public valgrind
29 (package
30 (name "valgrind")
31 (version "3.8.1")
32 (source (origin
33 (method url-fetch)
34 (uri (string-append "http://valgrind.org/downloads/valgrind-"
35 version ".tar.bz2"))
36 (sha256
37 (base32
38 "1nsqk70ry3221sd62s4f0njcrncppszs4xxjcak13lxyfq2y0fs7"))))
39 (build-system gnu-build-system)
40 (arguments
41 '(#:patches (list (assoc-ref %build-inputs "patch/glibc-2.17"))
42 #:phases (alist-cons-after
43 'install 'patch-suppression-files
44 (lambda* (#:key outputs #:allow-other-keys)
45 ;; Don't assume the FHS.
46 (let* ((out (assoc-ref outputs "out"))
47 (dir (string-append out "/lib/valgrind")))
48 (substitute* (find-files dir "\\.supp$")
49 (("obj:/lib") "obj:*/lib")
50 (("obj:/usr/X11R6/lib") "obj:*/lib")
51 (("obj:/usr/lib") "obj:*/lib"))
52 #t))
53 %standard-phases)))
54 (inputs `(;; GDB is needed to provide a sane default for `--db-command'.
55 ("gdb" ,gdb)
56
57 ("patch/glibc-2.17"
58 ,(search-patch "valgrind-glibc.patch"))))
59 (native-inputs `(("perl" ,perl)))
60 (home-page "http://www.valgrind.org/")
61 (synopsis "Debugging and profiling tool suite")
62 (description
63 "Valgrind is an instrumentation framework for building dynamic analysis
64 tools. There are Valgrind tools that can automatically detect many memory
65 management and threading bugs, and profile your programs in detail. You can
66 also use Valgrind to build new tools.")
67 (license gpl2+)))