gnu: Update harfbuzz to 0.9.20.
[jackhill/guix/guix.git] / gnu / packages / pkg-config.scm
1 ;;; GNU Guix --- Functional package management for GNU
2 ;;; Copyright © 2012, 2013 Ludovic Courtès <ludo@gnu.org>
3 ;;;
4 ;;; This file is part of GNU Guix.
5 ;;;
6 ;;; GNU Guix is free software; you can redistribute it and/or modify it
7 ;;; under the terms of the GNU General Public License as published by
8 ;;; the Free Software Foundation; either version 3 of the License, or (at
9 ;;; your option) any later version.
10 ;;;
11 ;;; GNU Guix is distributed in the hope that it will be useful, but
12 ;;; WITHOUT ANY WARRANTY; without even the implied warranty of
13 ;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
14 ;;; GNU General Public License for more details.
15 ;;;
16 ;;; You should have received a copy of the GNU General Public License
17 ;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
18
19 (define-module (gnu packages pkg-config)
20 #:use-module (guix licenses)
21 #:use-module (guix packages)
22 #:use-module (guix download)
23 #:use-module (guix build-system gnu)
24 #:use-module (guix build-system trivial)
25 #:export (pkg-config))
26
27 ;; This is the "primitive" pkg-config package. People should use `pkg-config'
28 ;; (see below) rather than `%pkg-config', but we export `%pkg-config' so that
29 ;; `fold-packages' finds it.
30 (define-public %pkg-config
31 (package
32 (name "pkg-config")
33 (version "0.27.1")
34 (source (origin
35 (method url-fetch)
36 (uri (string-append
37 "http://pkgconfig.freedesktop.org/releases/pkg-config-"
38 version ".tar.gz"))
39 (sha256
40 (base32
41 "05wc5nwkqz7saj2v33ydmz1y6jdg659dll4jjh91n41m63gx0qsg"))))
42 (build-system gnu-build-system)
43 (arguments `(#:configure-flags '("--with-internal-glib")))
44 (native-search-paths
45 (list (search-path-specification
46 (variable "PKG_CONFIG_PATH")
47 (directories '("lib/pkgconfig" "lib64/pkgconfig"
48 "share/pkgconfig")))))
49 (home-page "http://www.freedesktop.org/wiki/Software/pkg-config")
50 (license gpl2+)
51 (synopsis "a helper tool used when compiling applications and
52 libraries")
53 (description
54 "pkg-config is a helper tool used when compiling applications and
55 libraries. It helps you insert the correct compiler options on the
56 command line so an application can use gcc -o test test.c `pkg-config
57 --libs --cflags glib-2.0` for instance, rather than hard-coding values
58 on where to find glib (or other libraries). It is language-agnostic, so
59 it can be used for defining the location of documentation tools, for
60 instance.")))
61
62 (define (cross-pkg-config target)
63 "Return a pkg-config for TARGET, essentially just a wrapper called
64 `TARGET-pkg-config', as `configure' scripts like it."
65 ;; See <http://www.flameeyes.eu/autotools-mythbuster/pkgconfig/cross-compiling.html>
66 ;; for details.
67 (package (inherit %pkg-config)
68 (name (string-append (package-name %pkg-config) "-" target))
69 (build-system trivial-build-system)
70 (arguments
71 `(#:modules ((guix build utils))
72 #:builder (begin
73 (use-modules (guix build utils))
74
75 (let* ((out (assoc-ref %outputs "out"))
76 (bin (string-append out "/bin"))
77 (prog (string-append ,target "-pkg-config"))
78 (native
79 (string-append
80 (assoc-ref %build-inputs "pkg-config")
81 "/bin/pkg-config")))
82
83 (mkdir-p bin)
84
85 ;; Create a `TARGET-pkg-config' -> `pkg-config' symlink.
86 ;; This satisfies the pkg.m4 macros, which use
87 ;; AC_PROG_TOOL to determine the `pkg-config' program
88 ;; name.
89 (symlink native (string-append bin "/" prog))))))
90 (native-inputs `(("pkg-config" ,%pkg-config)))
91
92 ;; Ignore native inputs, and set `PKG_CONFIG_PATH' for target inputs.
93 (native-search-paths '())
94 (search-paths (package-native-search-paths %pkg-config))))
95
96 (define (pkg-config-for-target target)
97 "Return a pkg-config package for TARGET, which may be either #f for a native
98 build, or a GNU triplet."
99 (if target
100 (cross-pkg-config target)
101 %pkg-config))
102
103 ;; This hack allows us to automatically choose the native or the cross
104 ;; `pkg-config' depending on whether it's being used in a cross-build
105 ;; environment or not.
106 (define-syntax pkg-config
107 (identifier-syntax (pkg-config-for-target (%current-target-system))))