gnu: Update harfbuzz to 0.9.20.
[jackhill/guix/guix.git] / gnu / packages / openldap.scm
1 ;;; GNU Guix --- Functional package management for GNU
2 ;;; Copyright © 2013 Ludovic Courtès <ludo@gnu.org>
3 ;;; Copyright © 2013 Andreas Enge <andreas@enge.fr>
4 ;;;
5 ;;; This file is part of GNU Guix.
6 ;;;
7 ;;; GNU Guix is free software; you can redistribute it and/or modify it
8 ;;; under the terms of the GNU General Public License as published by
9 ;;; the Free Software Foundation; either version 3 of the License, or (at
10 ;;; your option) any later version.
11 ;;;
12 ;;; GNU Guix is distributed in the hope that it will be useful, but
13 ;;; WITHOUT ANY WARRANTY; without even the implied warranty of
14 ;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
15 ;;; GNU General Public License for more details.
16 ;;;
17 ;;; You should have received a copy of the GNU General Public License
18 ;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
19
20 (define-module (gnu packages openldap)
21 #:use-module (gnu packages autotools)
22 #:use-module (gnu packages bdb)
23 #:use-module (gnu packages compression)
24 #:use-module (gnu packages cyrus-sasl)
25 #:use-module (gnu packages gnupg)
26 #:use-module (gnu packages groff)
27 #:use-module (gnu packages icu4c)
28 #:use-module (gnu packages openssl)
29 #:use-module ((guix licenses) #:select (openldap2.8))
30 #:use-module (guix packages)
31 #:use-module (guix download)
32 #:use-module (guix build-system gnu))
33
34 (define-public openldap
35 (package
36 (name "openldap")
37 (version "2.4.33")
38 (source (origin
39 (method url-fetch)
40 (uri (string-append
41 "ftp://sunsite.cnlab-switch.ch/mirror/OpenLDAP/openldap-release/openldap-"
42 version ".tgz"))
43 (sha256 (base32
44 "0k51mhrs7pkwph2j38w09x7xl1ii69mcdi7b2mfrm9hp1yifrsc1"))))
45 (build-system gnu-build-system)
46 (inputs `(("bdb" ,bdb)
47 ("openssl" ,openssl)
48 ("cyrus-sasl" ,cyrus-sasl)
49 ("groff" ,groff)
50 ("icu4c" ,icu4c)
51 ("libgcrypt" ,libgcrypt)
52 ;; FIXME: currently, openldap requires openssl or gnutls<3, see
53 ;; http://www.openldap.org/its/index.cgi/Incoming?id=7430;page=17
54 ;; Once this is fixed, switch to gnutls.
55 ("libtool" ,libtool "bin")
56 ("zlib" ,zlib)))
57 (arguments
58 `(#:tests? #f
59 #:phases
60 (alist-replace
61 'configure
62 (lambda* (#:key #:allow-other-keys #:rest args)
63 (let ((configure (assoc-ref %standard-phases 'configure)))
64 (apply configure args)
65 (copy-file (which "libtool") "libtool")))
66 %standard-phases)))
67 (synopsis "openldap, an implementation of the Lightweight Directory Access Protocol")
68 (description
69 "OpenLDAP is a free implementation of the Lightweight Directory Access Protocol.")
70 (license openldap2.8)
71 (home-page "http://www.openldap.org/")))