gnu: Update harfbuzz to 0.9.20.
[jackhill/guix/guix.git] / gnu / packages / mp3.scm
1 ;;; GNU Guix --- Functional package management for GNU
2 ;;; Copyright © 2013 Andreas Enge <andreas@enge.fr>
3 ;;;
4 ;;; This file is part of GNU Guix.
5 ;;;
6 ;;; GNU Guix is free software; you can redistribute it and/or modify it
7 ;;; under the terms of the GNU General Public License as published by
8 ;;; the Free Software Foundation; either version 3 of the License, or (at
9 ;;; your option) any later version.
10 ;;;
11 ;;; GNU Guix is distributed in the hope that it will be useful, but
12 ;;; WITHOUT ANY WARRANTY; without even the implied warranty of
13 ;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
14 ;;; GNU General Public License for more details.
15 ;;;
16 ;;; You should have received a copy of the GNU General Public License
17 ;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
18
19 (define-module (gnu packages mp3)
20 #:use-module ((guix licenses)
21 #:renamer (symbol-prefix-proc 'license:))
22 #:use-module (gnu packages)
23 #:use-module (gnu packages autotools)
24 #:use-module (gnu packages cdrom)
25 #:use-module (gnu packages compression)
26 #:use-module (gnu packages ghostscript)
27 #:use-module (gnu packages glib)
28 #:use-module (gnu packages gtk)
29 #:use-module (gnu packages oggvorbis)
30 #:use-module (gnu packages pcre)
31 #:use-module (gnu packages pkg-config)
32 #:use-module (guix packages)
33 #:use-module (guix download)
34 #:use-module (guix build-system gnu))
35
36 (define-public libmad
37 (package
38 (name "libmad")
39 (version "0.15.1b")
40 (source (origin
41 (method url-fetch)
42 (uri (string-append "mirror://sourceforge/mad/libmad/"
43 version "/libmad-"
44 version ".tar.gz"))
45 (sha256
46 (base32
47 "14460zhacxhswnzb36qfpd1f2wbk10qvksvm6wyq5hpvdgnw7ymv"))))
48 (build-system gnu-build-system)
49 (arguments
50 `(#:phases
51 (alist-replace
52 'configure
53 (lambda* (#:key #:allow-other-keys #:rest args)
54 (let ((configure (assoc-ref %standard-phases 'configure)))
55 ;; remove option that is not supported by gcc any more
56 (substitute* "configure" ((" -fforce-mem") ""))
57 (apply configure args)))
58 %standard-phases)))
59 (synopsis "libmad, an MPEG audio decoder")
60 (description
61 "MAD (MPEG Audio Decoder) supports MPEG-1 and the MPEG-2 extension to
62 lower sampling frequencies, as well as the de facto MPEG 2.5 format.
63 All three audio layers — Layer I, Layer II, and Layer III (i.e. MP3) — are
64 fully implemented.
65
66 This package contains the library.")
67 (license license:gpl2+)
68 (home-page "http://www.underbit.com/products/mad/")))
69
70 (define-public libid3tag
71 (package
72 (name "libid3tag")
73 (version "0.15.1b")
74 (source (origin
75 (method url-fetch)
76 (uri (string-append "mirror://sourceforge/mad/libid3tag/"
77 version "/libid3tag-"
78 version ".tar.gz"))
79 (sha256
80 (base32
81 "0lb1w883dc46dajbdvnia5870brl5lvnlk7g7y58y9wpg5p4znk3"))))
82 (build-system gnu-build-system)
83 (inputs `(("zlib" ,zlib)))
84 (synopsis "libid3tag, a library for reading ID3 tags")
85 (description
86 "libid3tag is a library for reading ID3 tags, both ID3v1 and the various
87 versions of ID3v2")
88 (license license:gpl2+)
89 (home-page "http://www.underbit.com/products/mad/")))
90
91 (define-public id3lib
92 (package
93 (name "id3lib")
94 (version "3.8.3")
95 (source (origin
96 (method url-fetch)
97 (uri (string-append "mirror://sourceforge/id3lib/id3lib/"
98 version "/id3lib-"
99 version ".tar.gz"))
100 (sha256
101 (base32
102 "0yfhqwk0w8q2hyv1jib1008jvzmwlpsxvc8qjllhna6p1hycqj97"))))
103 (build-system gnu-build-system)
104 (arguments
105 `(#:phases
106 (alist-replace
107 'configure
108 (lambda* (#:key #:allow-other-keys #:rest args)
109 (let ((configure (assoc-ref %standard-phases 'configure)))
110 (substitute* "configure"
111 (("iomanip.h") "")) ; drop check for unused header
112 ;; see http://www.linuxfromscratch.org/patches/downloads/id3lib/
113 (substitute* "include/id3/id3lib_strings.h"
114 (("include <string>") "include <cstring>\n#include <string>"))
115 (substitute* "include/id3/writers.h"
116 (("//\\#include <string.h>") "#include <cstring>"))
117 (substitute* "examples/test_io.cpp"
118 (("dami;") "dami;\nusing namespace std;"))
119 (apply configure args)))
120 %standard-phases)))
121 (synopsis "a library for reading, writing, and manipulating ID3v1 and ID3v2 tags")
122 (description
123 "id3lib is a cross-platform software development library for reading,
124 writing, and manipulating ID3v1 and ID3v2 tags. It is an on-going project
125 whose primary goals are full compliance with the ID3v2 standard, portability
126 across several platforms, and providing a powerful and feature-rich API with
127 a highly stable and efficient implementation.")
128 (license license:lgpl2.0+)
129 (home-page "http://id3lib.sourceforge.net/")))
130
131 (define-public libmp3splt
132 (package
133 (name "libmp3splt")
134 (version "0.8.1a")
135 (source (origin
136 (method url-fetch)
137 (uri (string-append "mirror://sourceforge/mp3splt/libmp3splt/"
138 version "/libmp3splt-"
139 version ".tar.gz"))
140 (sha256
141 (base32
142 "0d20r1bd4fgp9kp7w3qixjgll34czck9dgw59mx2kbhb0mhh00d8"))))
143 (build-system gnu-build-system)
144 (inputs `(("libid3tag" ,libid3tag)
145 ("libmad" ,libmad)
146 ("libogg" ,libogg)
147 ("libtool" ,libtool)
148 ("libvorbid" ,libvorbis)
149 ("pkg-config" ,pkg-config)
150 ("pcre" ,pcre)))
151 (synopsis "libmp3splt, a library for splitting mp3 and ogg vorbis files")
152 (description
153 "Mp3splt is a utility to split mp3 and ogg vorbis files selecting a begin
154 and an end time position, without decoding. For splitting an album, one may
155 select split points and filenames manually or obtain them automatically from
156 CDDB (internet or a local file) or from .cue files. The tool also supports
157 automatic silence split, that can be used also to adjust cddb/cue splitpoints.
158
159 This package contains the library.")
160 (license license:gpl2+)
161 (home-page "http://mp3splt.sourceforge.net/mp3splt_page/home.php")))
162
163 (define-public mp3splt
164 (package
165 (name "mp3splt")
166 (version "2.5.1")
167 (source (origin
168 (method url-fetch)
169 (uri (string-append "mirror://sourceforge/mp3splt/mp3splt/"
170 version "/mp3splt-"
171 version ".tar.gz"))
172 (sha256
173 (base32
174 "106dnka56prlc9nsfh300f8841am2lmkwlzgl9lkr25mgnc35wwh"))))
175 (build-system gnu-build-system)
176 (inputs `(("libmp3splt" ,libmp3splt)))
177 (synopsis "mp3splt, a utiliy for splitting mp3 and ogg vorbis files")
178 (description
179 "Mp3splt is a utility to split mp3 and ogg vorbis files selecting a begin
180 and an end time position, without decoding. For splitting an album, one may
181 select split points and filenames manually or obtain them automatically from
182 CDDB (internet or a local file) or from .cue files. The tool also supports
183 automatic silence split, that can be used also to adjust cddb/cue splitpoints.
184
185 This package contains the binary.")
186 (license license:gpl2+)
187 (home-page "http://mp3splt.sourceforge.net/mp3splt_page/home.php")))
188
189 (define-public mpg321
190 (package
191 (name "mpg321")
192 (version "0.3.1")
193 (source (origin
194 (method url-fetch)
195 (uri (string-append "mirror://sourceforge/mpg321/"
196 version "/mpg321-" version ".tar.gz"))
197 (sha256
198 (base32
199 "0yamsqvj15nsxxnjs9mgyslzx7krgsfk3q1hk3g6l8w9bbbj770b"))))
200 (build-system gnu-build-system)
201 (arguments '(#:configure-flags '("--disable-alsa")))
202 (inputs
203 `(("zlib" ,zlib)
204 ("libmad" ,libmad)
205 ("libid3tag" ,libid3tag)
206 ("libao" ,ao)))
207 (home-page "http://mpg321.sourceforge.net/")
208 (synopsis "Command-line MP3 player")
209 (description "mpg321 is a command-line mp3 player. mpg321 is used for
210 frontends, as an mp3 player and as an mp3 to wave file decoder (primarily for
211 use with CD-recording software).")
212 (license license:gpl2)))
213
214 (define-public lame
215 (package
216 (name "lame")
217 (version "3.99.5")
218 (source (origin
219 (method url-fetch)
220 (uri (string-append "mirror://sourceforge/lame/lame/3.99/lame-"
221 version ".tar.gz"))
222 (sha256
223 (base32
224 "1zr3kadv35ii6liia0bpfgxpag27xcivp571ybckpbz4b10nnd14"))))
225 (build-system gnu-build-system)
226 (home-page "http://lame.sourceforge.net/")
227 (synopsis "MPEG Audio Layer III (MP3) encoder")
228 (description "LAME is a high quality MPEG Audio Layer III (MP3) encoder.")
229 (license license:lgpl2.0)))
230
231 (define-public ripperx
232 (package
233 (name "ripperx")
234 (version "2.7.3")
235 (source (origin
236 (method url-fetch)
237 (uri (string-append "mirror://sourceforge/ripperx/ripperx/"
238 version "/ripperX-"
239 version ".tar.gz"))
240 (sha256
241 (base32
242 "130rsb2ly0l6hz728m9qr605ir4073xfl2acvf83id63kxfzjn3x"))))
243 (build-system gnu-build-system)
244 (propagated-inputs
245 `(("gs-fonts" ,gs-fonts)
246 ("cdparanoia" ,cdparanoia)
247 ("flac" ,flac)
248 ("lame" ,lame)
249 ("vorbis-tools" ,vorbis-tools)))
250 (inputs
251 `(("patch/libm" ,(search-patch "ripperx-libm.patch"))
252 ("glib" ,glib)
253 ("gtk+" ,gtk+)
254 ("id3lib" ,id3lib)
255 ("pkg-config" ,pkg-config)))
256 (arguments
257 `(#:patches
258 ;; see http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=713684
259 (list (assoc-ref %build-inputs "patch/libm"))))
260 (synopsis "GTK program to rip and encode CD audio tracks")
261 (description
262 "RipperX is a GTK program to rip CD audio tracks and encode them to the
263 Ogg, MP3, or FLAC formats. It's goal is to be easy to use, requiring only
264 a few mouse clicks to convert an entire album. It supports CDDB lookups
265 for album and track information.")
266 (license license:gpl2)
267 (home-page "http://sourceforge.net/projects/ripperx/")))