gnu: Update harfbuzz to 0.9.20.
[jackhill/guix/guix.git] / gnu / packages / gperf.scm
1 ;;; GNU Guix --- Functional package management for GNU
2 ;;; Copyright © 2012, 2013 Ludovic Courtès <ludo@gnu.org>
3 ;;;
4 ;;; This file is part of GNU Guix.
5 ;;;
6 ;;; GNU Guix is free software; you can redistribute it and/or modify it
7 ;;; under the terms of the GNU General Public License as published by
8 ;;; the Free Software Foundation; either version 3 of the License, or (at
9 ;;; your option) any later version.
10 ;;;
11 ;;; GNU Guix is distributed in the hope that it will be useful, but
12 ;;; WITHOUT ANY WARRANTY; without even the implied warranty of
13 ;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
14 ;;; GNU General Public License for more details.
15 ;;;
16 ;;; You should have received a copy of the GNU General Public License
17 ;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
18
19 (define-module (gnu packages gperf)
20 #:use-module (guix licenses)
21 #:use-module (guix packages)
22 #:use-module (guix download)
23 #:use-module (guix build-system gnu))
24
25 (define-public gperf
26 (package
27 (name "gperf")
28 (version "3.0.4")
29 (source
30 (origin
31 (method url-fetch)
32 (uri (string-append "mirror://gnu/gperf/gperf-"
33 version ".tar.gz"))
34 (sha256
35 (base32
36 "0gnnm8iqcl52m8iha3sxrzrl9mcyhg7lfrhhqgdn4zj00ji14wbn"))))
37 (build-system gnu-build-system)
38 (arguments '(#:parallel-tests? #f))
39 (home-page "http://www.gnu.org/software/gperf/")
40 (synopsis "Perfect hash function generator")
41 (description
42 "GNU gperf is a perfect hash function generator. For a given
43 list of strings, it produces a hash function and hash table, in
44 form of C or C++ code, for looking up a value depending on the
45 input string. The hash function is perfect, which means that
46 the hash table has no collisions, and the hash table lookup
47 needs a single string comparison only.
48
49 GNU gperf is highly customizable. There are options for
50 generating C or C++ code, for emitting switch statements or
51 nested ifs instead of a hash table, and for tuning the algorithm
52 employed by gperf.")
53 (license gpl3+)))