gnu: Update harfbuzz to 0.9.20.
[jackhill/guix/guix.git] / gnu / packages / gnupg.scm
1 ;;; GNU Guix --- Functional package management for GNU
2 ;;; Copyright © 2012, 2013 Ludovic Courtès <ludo@gnu.org>
3 ;;; Copyright © 2013 Andreas Enge <andreas@enge.fr>
4 ;;;
5 ;;; This file is part of GNU Guix.
6 ;;;
7 ;;; GNU Guix is free software; you can redistribute it and/or modify it
8 ;;; under the terms of the GNU General Public License as published by
9 ;;; the Free Software Foundation; either version 3 of the License, or (at
10 ;;; your option) any later version.
11 ;;;
12 ;;; GNU Guix is distributed in the hope that it will be useful, but
13 ;;; WITHOUT ANY WARRANTY; without even the implied warranty of
14 ;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
15 ;;; GNU General Public License for more details.
16 ;;;
17 ;;; You should have received a copy of the GNU General Public License
18 ;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
19
20 (define-module (gnu packages gnupg)
21 #:use-module (guix licenses)
22 #:use-module (gnu packages curl)
23 #:use-module (gnu packages openldap)
24 #:use-module (gnu packages perl)
25 #:use-module (gnu packages pth)
26 #:use-module (gnu packages python)
27 #:use-module (gnu packages readline)
28 #:use-module ((gnu packages compression)
29 #:renamer (symbol-prefix-proc 'guix:))
30 #:use-module (guix packages)
31 #:use-module (guix download)
32 #:use-module (guix build-system gnu))
33
34 (define-public libgpg-error
35 (package
36 (name "libgpg-error")
37 (version "1.12")
38 (source
39 (origin
40 (method url-fetch)
41 (uri (string-append "mirror://gnupg/libgpg-error/libgpg-error-"
42 version ".tar.bz2"))
43 (sha256
44 (base32
45 "0pz58vr12qihq2f0bypjxsb6cf6ajq5258fmfm8s6lvwm3b9xz6a"))))
46 (build-system gnu-build-system)
47 (home-page "http://gnupg.org")
48 (synopsis
49 "Libgpg-error, a small library that defines common error values for all GnuPG components")
50 (description
51 "Libgpg-error is a small library that defines common error values
52 for all GnuPG components. Among these are GPG, GPGSM, GPGME,
53 GPG-Agent, libgcrypt, Libksba, DirMngr, Pinentry, SmartCard
54 Daemon and possibly more in the future.")
55 (license lgpl2.0+)))
56
57 (define-public libgcrypt
58 (package
59 (name "libgcrypt")
60 (version "1.5.2")
61 (source (origin
62 (method url-fetch)
63 (uri (string-append "mirror://gnupg/libgcrypt/libgcrypt-"
64 version ".tar.bz2"))
65 (sha256
66 (base32
67 "0gwnzqd64cpwdmk93nll54nidsr74jpimxzj4p4z7502ylwl66p4"))))
68 (build-system gnu-build-system)
69 (propagated-inputs
70 `(("libgpg-error" ,libgpg-error)))
71 (home-page "http://gnupg.org/")
72 (synopsis "Cryptographic function library")
73 (description
74 "GNU Libgcrypt is a general purpose cryptographic library based on
75 the code from GnuPG. It provides functions for all
76 cryptographic building blocks: symmetric ciphers, hash
77 algorithms, MACs, public key algorithms, large integer
78 functions, random numbers and a lot of supporting functions.")
79 (license lgpl2.0+)))
80
81 (define-public libassuan
82 (package
83 (name "libassuan")
84 (version "2.1.1")
85 (source
86 (origin
87 (method url-fetch)
88 (uri (string-append "mirror://gnupg/libassuan/libassuan-"
89 version ".tar.bz2"))
90 (sha256
91 (base32
92 "1783nb0b6nr9yjhb5wfh8ykc5w89f4anppz1kz9913mqg5vxdqi3"))))
93 (build-system gnu-build-system)
94 (propagated-inputs
95 `(("libgpg-error" ,libgpg-error) ("pth" ,pth)))
96 (home-page "http://gnupg.org")
97 (synopsis
98 "Libassuan, the IPC library used by GnuPG and related software")
99 (description
100 "Libassuan is a small library implementing the so-called Assuan
101 protocol. This protocol is used for IPC between most newer
102 GnuPG components. Both, server and client side functions are
103 provided.")
104 (license lgpl2.0+)))
105
106 (define-public libksba
107 (package
108 (name "libksba")
109 (version "1.2.0")
110 (source
111 (origin
112 (method url-fetch)
113 (uri (string-append
114 "mirror://gnupg/libksba/libksba-"
115 version ".tar.bz2"))
116 (sha256
117 (base32
118 "0jwk7hm3x3g4hd7l12z3d79dy7359x7lc88dq6z7q0ixn1jwxbq9"))))
119 (build-system gnu-build-system)
120 (propagated-inputs
121 `(("libgpg-error" ,libgpg-error)))
122 (home-page "http://www.gnupg.org")
123 (synopsis
124 "Libksba is a CMS and X.509 access library under development")
125 (description
126 "KSBA (pronounced Kasbah) is a library to make X.509 certificates
127 as well as the CMS easily accessible by other applications. Both
128 specifications are building blocks of S/MIME and TLS.")
129 (license gpl3+)))
130
131 (define-public gnupg
132 (package
133 (name "gnupg")
134 (version "2.0.20")
135 (source
136 (origin
137 (method url-fetch)
138 (uri (string-append "mirror://gnupg/gnupg/gnupg-" version
139 ".tar.bz2"))
140 (sha256
141 (base32
142 "16mp0j5inrcqcb3fxbn0b3aamascy3n923wiy0y8marc0rzrp53f"))))
143 (build-system gnu-build-system)
144 (inputs
145 `(;; TODO: Add missing optional dep libusb.
146 ;; ("libusb" ,libusb)
147 ("bzip2" ,guix:bzip2)
148 ("curl" ,curl)
149 ("libassuan" ,libassuan)
150 ("libgcrypt" ,libgcrypt)
151 ("libgpg-error" ,libgpg-error)
152 ("libksba" ,libksba)
153 ("pth" ,pth)
154 ("openldap" ,openldap)
155 ("zlib" ,guix:zlib)
156 ("readline" ,readline)))
157 (arguments
158 `(#:phases
159 (alist-replace
160 'configure
161 (lambda* (#:key #:allow-other-keys #:rest args)
162 (let ((configure (assoc-ref %standard-phases 'configure)))
163 (substitute* "tests/openpgp/Makefile.in"
164 (("/bin/sh") (which "bash")))
165 (apply configure args)))
166 %standard-phases)))
167 (home-page "http://gnupg.org/")
168 (synopsis "GNU Privacy Guard")
169 (description
170 "GnuPG is the GNU project's complete and free implementation of
171 the OpenPGP standard as defined by RFC4880. GnuPG allows to
172 encrypt and sign your data and communication, features a
173 versatile key managment system as well as access modules for all
174 kind of public key directories. GnuPG, also known as GPG, is a
175 command line tool with features for easy integration with other
176 applications. A wealth of frontend applications and libraries
177 are available. Version 2 of GnuPG also provides support for
178 S/MIME.")
179 (license gpl3+)))
180
181 (define-public pius
182 (package
183 (name "pius")
184 (version "2.0.9")
185 (source (origin
186 (method url-fetch)
187 (uri (string-append "mirror://sourceforge/pgpius/pius/"
188 version "/pius-"
189 version ".tar.bz2"))
190 (sha256 (base32
191 "1g1jly3wl4ks6h8ydkygyl2c4i7v3z91rg42005m6vm70y1d8b3d"))))
192 (build-system gnu-build-system)
193 (inputs `(("perl" ,perl)
194 ("python" ,python)
195 ("gpg" ,gnupg)))
196 (arguments
197 `(#:tests? #f
198 #:phases
199 (alist-replace
200 'configure
201 (lambda* (#:key #:allow-other-keys) #t)
202 (alist-replace
203 'build
204 (lambda* (#:key #:allow-other-keys) #t)
205 (alist-replace
206 'install
207 (lambda* (#:key inputs outputs #:allow-other-keys)
208 (let* ((out (assoc-ref outputs "out"))
209 (gpg (string-append (assoc-ref inputs "gpg")
210 "/bin/gpg2")))
211 (mkdir out)
212 (mkdir (string-append out "/bin"))
213 (for-each (lambda (file)
214 (substitute* file
215 (("/usr/bin/gpg") gpg))
216 (copy-file file (string-append out "/bin/" file)))
217 '("pius" "pius-keyring-mgr" "pius-party-worksheet"))))
218 %standard-phases)))))
219 (synopsis "Programs to simplify GnuPG key signing")
220 (description
221 "Pius (PGP Individual UID Signer) helps attendees of PGP keysigning
222 parties. It is the main utility and makes it possible to quickly and easily
223 sign each UID on a set of PGP keys. It is designed to take the pain out of
224 the sign-all-the-keys part of PGP Keysigning Party while adding security
225 to the process.
226
227 pius-keyring-mgr and pius-party-worksheet help organisers of
228 PGP keysigning parties.")
229 (license gpl2)
230 (home-page "http://www.phildev.net/pius/index.shtml")))
231
232 (define-public signing-party
233 (package
234 (name "signing-party")
235 (version "1.1.4")
236 (source (origin
237 (method url-fetch)
238 (uri (string-append "http://ftp.debian.org/debian/pool/main/s/signing-party/signing-party_"
239 version ".orig.tar.gz"))
240 (sha256 (base32
241 "188gp0prbh8qs29lq3pbf0qibfd6jq4fk7i0pfrybl8aahvm84rx"))))
242 (build-system gnu-build-system)
243 (inputs `(("perl" ,perl)))
244 (arguments
245 `(#:tests? #f
246 #:phases
247 (alist-replace
248 'unpack
249 (lambda* (#:key #:allow-other-keys #:rest args)
250 (let ((unpack (assoc-ref %standard-phases 'unpack)))
251 (apply unpack args)
252 ;; remove spurious symlink
253 (delete-file "keyanalyze/pgpring/depcomp")))
254 (alist-replace
255 'configure
256 (lambda* (#:key outputs #:allow-other-keys)
257 (let ((out (assoc-ref outputs "out")))
258 (substitute* "keyanalyze/Makefile"
259 (("LDLIBS") (string-append "CC=" (which "gcc") "\nLDLIBS")))
260 (substitute* "keyanalyze/Makefile"
261 (("./configure") (string-append "./configure --prefix=" out)))
262 (substitute* "keyanalyze/pgpring/configure"
263 (("/bin/sh") (which "bash")))
264 (substitute* "gpgwrap/Makefile"
265 (("\\} clean") (string-append "} clean\ninstall:\n\tinstall -D bin/gpgwrap "
266 out "/bin/gpgwrap\n")))
267 (substitute* '("gpgsigs/Makefile" "keyanalyze/Makefile"
268 "keylookup/Makefile" "sig2dot/Makefile"
269 "springgraph/Makefile")
270 (("/usr") out))))
271 (alist-replace
272 'install
273 (lambda* (#:key outputs #:allow-other-keys #:rest args)
274 (let ((out (assoc-ref outputs "out"))
275 (install (assoc-ref %standard-phases 'install)))
276 (apply install args)
277 (for-each
278 (lambda (dir file)
279 (copy-file (string-append dir "/" file)
280 (string-append out "/bin/" file)))
281 '("caff" "caff" "caff" "gpgdir" "gpg-key2ps"
282 "gpglist" "gpg-mailkeys" "gpgparticipants")
283 '("caff" "pgp-clean" "pgp-fixkey" "gpgdir" "gpg-key2ps"
284 "gpglist" "gpg-mailkeys" "gpgparticipants"))
285 (for-each
286 (lambda (dir file)
287 (copy-file (string-append dir "/" file)
288 (string-append out "/share/man/man1/" file)))
289 '("caff" "caff" "caff" "gpgdir"
290 "gpg-key2ps" "gpglist" "gpg-mailkeys"
291 "gpgparticipants" "gpgsigs" "gpgwrap/doc"
292 "keyanalyze" "keyanalyze/pgpring" "keyanalyze")
293 '("caff.1" "pgp-clean.1" "pgp-fixkey.1" "gpgdir.1"
294 "gpg-key2ps.1" "gpglist.1" "gpg-mailkeys.1"
295 "gpgparticipants.1" "gpgsigs.1" "gpgwrap.1"
296 "process_keys.1" "pgpring.1" "keyanalyze.1"))))
297 %standard-phases)))))
298 (synopsis "collection of scripts for simplifying gnupg key signing")
299 (description
300 "signing-party is a collection for all kinds of PGP/GnuPG related things,
301 including tools for signing keys, keyring analysis, and party preparation.
302
303 * caff: CA - Fire and Forget signs and mails a key
304
305 * pgp-clean: removes all non-self signatures from key
306
307 * pgp-fixkey: removes broken packets from keys
308
309 * gpg-mailkeys: simply mail out a signed key to its owner
310
311 * gpg-key2ps: generate PostScript file with fingerprint paper strips
312
313 * gpgdir: recursive directory encryption tool
314
315 * gpglist: show who signed which of your UIDs
316
317 * gpgsigs: annotates list of GnuPG keys with already done signatures
318
319 * gpgparticipants: create list of party participants for the organiser
320
321 * gpgwrap: a passphrase wrapper
322
323 * keyanalyze: minimum signing distance (MSD) analysis on keyrings
324
325 * keylookup: ncurses wrapper around gpg --search
326
327 * sig2dot: converts a list of GnuPG signatures to a .dot file
328
329 * springgraph: creates a graph from a .dot file")
330 ;; gpl2+ for almost all programs, except for keyanalyze: gpl2
331 ;; and caff and gpgsigs: bsd-3, see
332 ;; http://packages.debian.org/changelogs/pool/main/s/signing-party/current/copyright
333 (license gpl2)
334 (home-page "http://pgp-tools.alioth.debian.org/")))