gnu: Update harfbuzz to 0.9.20.
[jackhill/guix/guix.git] / gnu / packages / gettext.scm
1 ;;; GNU Guix --- Functional package management for GNU
2 ;;; Copyright © 2012 Nikita Karetnikov <nikita@karetnikov.org>
3 ;;;
4 ;;; This file is part of GNU Guix.
5 ;;;
6 ;;; GNU Guix is free software; you can redistribute it and/or modify it
7 ;;; under the terms of the GNU General Public License as published by
8 ;;; the Free Software Foundation; either version 3 of the License, or (at
9 ;;; your option) any later version.
10 ;;;
11 ;;; GNU Guix is distributed in the hope that it will be useful, but
12 ;;; WITHOUT ANY WARRANTY; without even the implied warranty of
13 ;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
14 ;;; GNU General Public License for more details.
15 ;;;
16 ;;; You should have received a copy of the GNU General Public License
17 ;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
18
19 (define-module (gnu packages gettext)
20 #:use-module (guix licenses)
21 #:use-module (gnu packages)
22 #:use-module (guix packages)
23 #:use-module (guix download)
24 #:use-module (guix build-system gnu))
25
26 (define-public gettext
27 (package
28 (name "gettext")
29 (version "0.18.3")
30 (source (origin
31 (method url-fetch)
32 (uri (string-append "mirror://gnu/gettext/gettext-"
33 version ".tar.gz"))
34 (sha256
35 (base32
36 "0j7rp56c61j4k1bz1xdc041hzv7186yyzhbp95fmc0zq7l2c3wrn"))))
37 (build-system gnu-build-system)
38 (arguments
39 `(#:phases (alist-cons-before
40 'check 'patch-tests
41 (lambda* (#:key inputs #:allow-other-keys)
42 (let ((bash (which "sh")))
43 (substitute* (find-files "gettext-tools/tests"
44 "^msgexec-[0-9]")
45 (("#![[:blank:]]/bin/sh")
46 (format #f "#!~a" bash)))
47 (substitute* (find-files "gettext-tools/gnulib-tests"
48 "posix_spawn")
49 (("/bin/sh")
50 bash))))
51 %standard-phases)))
52 (home-page "http://www.gnu.org/software/gettext/")
53 (synopsis "Tools and documentation for translation")
54 (description
55 "Usually, programs are written and documented in English, and use
56 English at execution time for interacting with users. Using a common
57 language is quite handy for communication between developers,
58 maintainers and users from all countries. On the other hand, most
59 people are less comfortable with English than with their own native
60 language, and would rather be using their mother tongue for day to
61 day's work, as far as possible. Many would simply love seeing their
62 computer screen showing a lot less of English, and far more of their
63 own language.
64
65 GNU `gettext' is an important step for the GNU Translation Project, as
66 bit is an asset on which we may build many other steps. This package
67 offers to programmers, translators, and even users, a well integrated
68 set of tools and documentation. Specifically, the GNU `gettext'
69 utilities are a set of tools that provides a framework to help other
70 GNU packages produce multi-lingual messages.")
71 (license gpl3))) ; some files are under GPLv2+