gnu: Update harfbuzz to 0.9.20.
[jackhill/guix/guix.git] / gnu / packages / dwm.scm
1 ;;; GNU Guix --- Functional package management for GNU
2 ;;; Copyright © 2013 Cyril Roelandt <tipecaml@gmail.com>
3 ;;;
4 ;;; This file is part of GNU Guix.
5 ;;;
6 ;;; GNU Guix is free software; you can redistribute it and/or modify it
7 ;;; under the terms of the GNU General Public License as published by
8 ;;; the Free Software Foundation; either version 3 of the License, or (at
9 ;;; your option) any later version.
10 ;;;
11 ;;; GNU Guix is distributed in the hope that it will be useful, but
12 ;;; WITHOUT ANY WARRANTY; without even the implied warranty of
13 ;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
14 ;;; GNU General Public License for more details.
15 ;;;
16 ;;; You should have received a copy of the GNU General Public License
17 ;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
18
19 (define-module (gnu packages dwm)
20 #:use-module (guix licenses)
21 #:use-module (guix packages)
22 #:use-module (guix download)
23 #:use-module (guix build-system gnu)
24 #:use-module (gnu packages)
25 #:use-module (gnu packages xorg))
26
27 (define-public dwm
28 (package
29 (name "dwm")
30 (version "6.0")
31 (source (origin
32 (method url-fetch)
33 (uri (string-append "http://dl.suckless.org/dwm/dwm-"
34 version ".tar.gz"))
35 (sha256
36 (base32 "0mpbivy9j80l1jqq4bd4g4z8s5c54fxrjj44avmfwncjwqylifdj"))))
37 (build-system gnu-build-system)
38 (arguments
39 `(#:tests? #f
40 #:phases
41 (alist-replace
42 'configure
43 (lambda _
44 (substitute* "Makefile" (("\\$\\{CC\\}") "gcc"))
45 #t)
46 (alist-replace
47 'install
48 (lambda* (#:key outputs #:allow-other-keys)
49 (let ((out (assoc-ref outputs "out")))
50 (zero?
51 (system* "make" "install"
52 (string-append "DESTDIR=" out) "PREFIX="))))
53 %standard-phases))))
54 (inputs
55 `(("libx11" ,libx11)
56 ("libxinerama" ,libxinerama)))
57 (home-page "http://dwm.suckless.org/")
58 (synopsis "Dynamic window manager")
59 (description
60 "dwm is a dynamic window manager for X. It manages windows in tiled,
61 monocle and floating layouts. All of the layouts can be applied dynamically,
62 optimising the environment for the application in use and the task performed.
63
64 In tiled layout windows are managed in a master and stacking area. The master
65 area contains the window which currently needs most attention, whereas the
66 stacking area contains all other windows. In monocle layout all windows are
67 maximised to the screen size. In floating layout windows can be resized and
68 moved freely. Dialog windows are always managed floating, regardless of the
69 layout applied.
70
71 Windows are grouped by tags. Each window can be tagged with one or multiple
72 tags. Selecting certain tags displays all windows with these tags.
73
74 Each screen contains a small status bar which displays all available tags, the
75 layout, the number of visible windows, the title of the focused window, and the
76 text read from the root window name property, if the screen is focused. A
77 floating window is indicated with an empty square and a maximised floating
78 window is indicated with a filled square before the windows title. The selected
79 tags are indicated with a different color. The tags of the focused window are
80 indicated with a filled square in the top left corner. The tags which are
81 applied to one or more windows are indicated with an empty square in the top
82 left corner.
83
84 dwm draws a small customizable border around windows to indicate the focus
85 state.")
86 (license x11)))