gnu: Update harfbuzz to 0.9.20.
[jackhill/guix/guix.git] / gnu / packages / cdrom.scm
1 ;;; GNU Guix --- Functional package management for GNU
2 ;;; Copyright © 2013 Ludovic Courtès <ludo@gnu.org>
3 ;;; Copyright © 2013 Andreas Enge <andreas@enge.fr>
4 ;;;
5 ;;; This file is part of GNU Guix.
6 ;;;
7 ;;; GNU Guix is free software; you can redistribute it and/or modify it
8 ;;; under the terms of the GNU General Public License as published by
9 ;;; the Free Software Foundation; either version 3 of the License, or (at
10 ;;; your option) any later version.
11 ;;;
12 ;;; GNU Guix is distributed in the hope that it will be useful, but
13 ;;; WITHOUT ANY WARRANTY; without even the implied warranty of
14 ;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
15 ;;; GNU General Public License for more details.
16 ;;;
17 ;;; You should have received a copy of the GNU General Public License
18 ;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
19
20 (define-module (gnu packages cdrom)
21 #:use-module (guix download)
22 #:use-module (guix packages)
23 #:use-module ((guix licenses) #:select (lgpl2.1+ gpl2 gpl3+))
24 #:use-module (guix build-system gnu)
25 #:use-module (gnu packages)
26 #:use-module (gnu packages acl)
27 #:use-module (gnu packages compression)
28 #:use-module (gnu packages readline)
29 #:use-module (gnu packages ncurses)
30 #:use-module (gnu packages help2man)
31 #:use-module (gnu packages pkg-config))
32
33 (define-public libcddb
34 (package
35 (name "libcddb")
36 (version "1.3.0")
37 (source (origin
38 (method url-fetch)
39 (uri (string-append "mirror://sourceforge/libcddb/libcddb-"
40 version ".tar.bz2"))
41 (sha256
42 (base32
43 "1y8bfy12dwm41m1jahayn3v47dm34fmz7m9cjxyh7xcw6fp3lzaf"))))
44 (build-system gnu-build-system)
45 (arguments '(#:tests? #f)) ; tests rely on access to external servers
46 (home-page "http://libcddb.sourceforge.net/")
47 (synopsis "C library to access data on a CDDB server")
48 (description
49 "Libcddb is a C library to access data on a CDDB server (freedb.org). It
50 allows you to:
51
52 1. search the database for possible CD matches;
53
54 2. retrieve detailed information about a specific CD;
55
56 3. submit new CD entries to the database.
57
58 Libcddb supports both the custom CDDB protocol and tunnelling the query and
59 read operations over plain HTTP. It is also possible to use an HTTP proxy
60 server. If you want to speed things up, you can make use of the built-in
61 caching facility provided by the library.")
62 (license lgpl2.1+)))
63
64 (define-public libcdio
65 (package
66 (name "libcdio")
67 (version "0.90")
68 (source (origin
69 (method url-fetch)
70 (uri (string-append "mirror://gnu/libcdio/libcdio-"
71 version ".tar.gz"))
72 (sha256
73 (base32
74 "0kpp6gr5sjr30pb9klncc37fhkw0wi6r41d2fmvmw17cbj176zmg"))))
75 (build-system gnu-build-system)
76 (inputs
77 `(("help2man" ,help2man)
78 ("ncurses" ,ncurses)
79 ("pkg-config" ,pkg-config)
80 ("libcddb" ,libcddb)))
81 (home-page "http://www.gnu.org/software/libcdio/")
82 (synopsis "CD Input and Control library")
83 (description
84 "GNU libcdio is a library for OS-idependent CD-ROM and CD image access.
85 It includes a library for working with ISO-9660 filesystems (libiso9660), as
86 well as utility programs such as an audio CD player and an extractor.")
87 (license gpl3+)))
88
89 (define-public xorriso
90 (package
91 (name "xorriso")
92 (version "1.3.0")
93 (source (origin
94 (method url-fetch)
95 (uri (string-append "mirror://gnu/xorriso/xorriso-"
96 version ".tar.gz"))
97 (sha256
98 (base32
99 "1gvyf1ppq764hsk8iyffip7h1dnz2b9k2cchf7himnns03aadavn"))))
100 (build-system gnu-build-system)
101 (inputs
102 `(("acl" ,acl)
103 ("readline" ,readline)
104 ("bzip2" ,bzip2)
105 ("zlib" ,zlib)
106 ("libcdio" ,libcdio)))
107 (home-page "http://www.gnu.org/software/xorriso/")
108 (synopsis "Create, manipulate, burn ISO-9660 filesystems")
109 (description
110 "GNU xorriso copies file objects from POSIX compliant filesystems into
111 Rock Ridge enhanced ISO 9660 filesystems and allows session-wise manipulation
112 of such filesystems. It can load the management information of existing ISO
113 images and it writes the session results to optical media or to filesystem
114 objects. Vice versa xorriso is able to copy file objects out of ISO 9660
115 filesystems.")
116 (license gpl3+)))
117
118 (define-public cdparanoia
119 (package
120 (name "cdparanoia")
121 (version "10.2")
122 (source (origin
123 (method url-fetch)
124 (uri (string-append "http://downloads.xiph.org/releases/cdparanoia/cdparanoia-III-"
125 version ".src.tgz"))
126 (sha256
127 (base32
128 "1pv4zrajm46za0f6lv162iqffih57a8ly4pc69f7y0gfyigb8p80"))))
129 (build-system gnu-build-system)
130 (inputs
131 `(("patch/fpic" ,(search-patch "cdparanoia-fpic.patch"))))
132 (arguments
133 `(#:tests? #f ; there is no check target
134 #:patches (list (assoc-ref %build-inputs "patch/fpic"))))
135 (home-page "http://www.xiph.org/paranoia/")
136 (synopsis "audio CD reading utility which includes extra data verification features")
137 (description "Cdparanoia retrieves audio tracks from CDDA capable CDROM
138 drives. The data can be saved to a file or directed to standard output
139 in WAV, AIFF, AIFF-C or raw format. Most ATAPI, SCSI and several
140 proprietary CDROM drive makes are supported; cdparanoia can determine if the
141 target drive is CDDA capable. In addition to simple reading, cdparanoia adds
142 extra-robust data verification, synchronization, error handling and scratch
143 reconstruction capability.")
144 (license gpl2))) ; libraries under lgpl2.1