gnu: fontconfig: Add replacement with font-dejavu instead of gs-fonts.
[jackhill/guix/guix.git] / gnu / packages / syndication.scm
1 ;;; GNU Guix --- Functional package management for GNU
2 ;;; Copyright © 2016, 2017, 2019, 2020 Efraim Flashner <efraim@flashner.co.il>
3 ;;; Copyright © 2018, 2019 Tobias Geerinckx-Rice <me@tobias.gr>
4 ;;;
5 ;;; This file is part of GNU Guix.
6 ;;;
7 ;;; GNU Guix is free software; you can redistribute it and/or modify it
8 ;;; under the terms of the GNU General Public License as published by
9 ;;; the Free Software Foundation; either version 3 of the License, or (at
10 ;;; your option) any later version.
11 ;;;
12 ;;; GNU Guix is distributed in the hope that it will be useful, but
13 ;;; WITHOUT ANY WARRANTY; without even the implied warranty of
14 ;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
15 ;;; GNU General Public License for more details.
16 ;;;
17 ;;; You should have received a copy of the GNU General Public License
18 ;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
19
20 (define-module (gnu packages syndication)
21 #:use-module ((guix licenses) #:prefix license:)
22 #:use-module (guix download)
23 #:use-module (guix packages)
24 #:use-module (guix build-system gnu)
25 #:use-module (guix build-system python)
26 #:use-module (gnu packages)
27 #:use-module (gnu packages check)
28 #:use-module (gnu packages curl)
29 #:use-module (gnu packages documentation)
30 #:use-module (gnu packages gettext)
31 #:use-module (gnu packages ncurses)
32 #:use-module (gnu packages pkg-config)
33 #:use-module (gnu packages python)
34 #:use-module (gnu packages python-check)
35 #:use-module (gnu packages python-xyz)
36 #:use-module (gnu packages python-web)
37 #:use-module (gnu packages sqlite)
38 #:use-module (gnu packages web)
39 #:use-module (gnu packages xml))
40
41 (define-public newsboat
42 (package
43 (name "newsboat")
44 (version "2.13")
45 (source
46 (origin
47 (method url-fetch)
48 (uri (string-append "https://newsboat.org/releases/" version
49 "/newsboat-" version ".tar.xz"))
50 (sha256
51 (base32
52 "0pik1d98ydzqi6055vdbkjg5krwifbk2hy2f5jp5p1wcy2s16dn7"))))
53 (build-system gnu-build-system)
54 (native-inputs
55 `(("gettext" ,gettext-minimal)
56 ("pkg-config" ,pkg-config)
57 ;; For building documentation.
58 ("asciidoc" ,asciidoc)))
59 (inputs
60 `(("curl" ,curl)
61 ("json-c" ,json-c)
62 ("libxml2" ,libxml2)
63 ("ncurses" ,ncurses)
64 ("stfl" ,stfl)
65 ("sqlite" ,sqlite)))
66 (arguments
67 '(#:phases
68 (modify-phases %standard-phases
69 (delete 'configure) ; no configure script
70 (add-after 'build 'build-documentation
71 (lambda _
72 (invoke "make" "doc"))))
73 #:make-flags
74 (list (string-append "prefix=" (assoc-ref %outputs "out")))
75 #:test-target "test"))
76 (native-search-paths
77 ;; Newsboat respects CURL_CA_BUNDLE.
78 (package-native-search-paths curl))
79 (home-page "https://newsboat.org/")
80 (synopsis "Text-mode RSS and Atom feed reader with podcast support")
81 (description "Newsboat is a feed reader for @dfn{RSS} and @dfn{Atom}, XML
82 formats widely used to transmit, publish, and syndicate news or blog articles.
83 It's designed for use on text terminals, and to have a coherent and easy-to-use
84 interface that might look familiar to @command{mutt} or @command{slrn} users.
85
86 Newsboat supports OPML import/exports, HTML rendering, podcasts (with
87 @command{podboat}), off-line reading, searching and storing articles to your
88 file system, and many more features.")
89 (license (list license:gpl2+ ; filter/*
90 license:expat)))) ; everything else
91
92 (define-public rtv
93 (package
94 (name "rtv")
95 (version "1.27.0")
96 (source
97 (origin
98 (method url-fetch)
99 (uri (pypi-uri "rtv" version))
100 (sha256
101 (base32 "0hvw426y09l3yzwv2zkb9hifpfbg9wd1gg0y3z3pxcli6n3ii2wl"))))
102 (build-system python-build-system)
103 (arguments
104 '(#:phases
105 (modify-phases %standard-phases
106 (add-before 'check 'set-environment-variables
107 (lambda* (#:key inputs #:allow-other-keys)
108 (setenv "HOME" (getcwd))
109 (setenv "TERM" "linux")
110 (setenv "TERMINFO" (string-append (assoc-ref inputs "ncurses")
111 "/share/terminfo"))
112 #t)))
113 #:tests? #f)) ; tests fail: _curses.error: nocbreak() returned ERR
114 (propagated-inputs
115 `(("python-beautifulsoup4" ,python-beautifulsoup4)
116 ("python-decorator" ,python-decorator)
117 ("python-kitchen" ,python-kitchen)
118 ("python-requests" ,python-requests)
119 ("python-six" ,python-six)))
120 (native-inputs
121 `(("ncurses" ,ncurses)
122 ("python-coveralls" ,python-coveralls)
123 ("python-coverage" ,python-coverage)
124 ("python-mock" ,python-mock)
125 ("python-pylint" ,python-pylint)
126 ("python-pytest" ,python-pytest)
127 ("python-vcrpy" ,python-vcrpy)))
128 (home-page "https://github.com/michael-lazar/rtv")
129 (synopsis "Terminal viewer for Reddit (Reddit Terminal Viewer)")
130 (description
131 "RTV provides a text-based interface to view and interact with Reddit.")
132 (license (list license:expat
133 license:gpl3+)))) ; rtv/packages/praw
134
135 (define-public tuir
136 (package
137 (name "tuir")
138 (version "1.28.3")
139 (source
140 (origin
141 (method url-fetch)
142 (uri (pypi-uri "tuir" version))
143 (sha256
144 (base32
145 "1gpyjrl7jdfjq30m32nzh59ajv91gq19l93jjri2wsv5yrf90hdr"))))
146 (build-system python-build-system)
147 (arguments
148 `(#:phases
149 (modify-phases %standard-phases
150 (replace 'check
151 (lambda* (#:key inputs outputs #:allow-other-keys)
152 (add-installed-pythonpath inputs outputs)
153 (invoke "pytest"))))))
154 (inputs
155 `(("python-beautifulsoup4" ,python-beautifulsoup4)
156 ("python-decorator" ,python-decorator)
157 ("python-kitchen" ,python-kitchen)
158 ("python-requests" ,python-requests)
159 ("python-six" ,python-six)))
160 (native-inputs
161 `(("python-coverage" ,python-coverage)
162 ("python-coveralls" ,python-coveralls)
163 ("python-mock" ,python-mock)
164 ("python-pylint" ,python-pylint)
165 ("python-pytest" ,python-pytest)
166 ("python-vcrpy" ,python-vcrpy)))
167 (home-page "https://gitlab.com/ajak/tuir")
168 (synopsis "Terminal viewer for Reddit (Terminal UI for Reddit)")
169 (description
170 "Tuir provides a simple terminal viewer for Reddit (Terminal UI for Reddit).")
171 (license (list license:expat
172 license:gpl3+)))) ; tuir/packages/praw
173
174 (define-public rawdog
175 (package
176 (name "rawdog")
177 (version "2.23")
178 (source
179 (origin
180 (method url-fetch)
181 (uri (string-append "https://offog.org/files/rawdog-"
182 version ".tar.gz"))
183 (sha256
184 (base32
185 "18nyg19mwxyqdnykplkqmzb4n27vvrhvp639zai8f81gg9vdbsjp"))))
186 (build-system python-build-system)
187 (arguments
188 `(#:python ,python-2.7))
189 (inputs
190 `(("python2-feedparser" ,python2-feedparser)
191 ("python2-pytidylib" ,python2-pytidylib)))
192 (home-page "https://offog.org/code/rawdog/")
193 (synopsis "RSS Aggregator Without Delusions Of Grandeur")
194 (description
195 "@command{rawdog} is a feed aggregator, capable of producing a personal
196 \"river of news\" or a public \"planet\" page. It supports all common feed
197 formats, including all versions of RSS and Atom.")
198 (license license:gpl2+)))