gnu: xorg-server: Fix CVE-2017-{10971,10972}.
[jackhill/guix/guix.git] / gnu / packages / patches / vorbis-tools-CVE-2014-9640.patch
1 Index: vorbis-tools/oggenc/oggenc.c
2 ===================================================================
3 --- vorbis-tools/oggenc/oggenc.c (revision 19116)
4 +++ vorbis-tools/oggenc/oggenc.c (revision 19117)
5 @@ -98,4 +98,6 @@
6 0,0,0.f,
7 0, 0, 0, 0, 0};
8 + input_format raw_format = {NULL, 0, raw_open, wav_close, "raw",
9 + N_("RAW file reader")};
10
11 int i;
12 @@ -240,6 +242,4 @@
13 if(opt.rawmode)
14 {
15 - input_format raw_format = {NULL, 0, raw_open, wav_close, "raw",
16 - N_("RAW file reader")};
17
18 enc_opts.rate=opt.raw_samplerate;
19 Index: vorbis-tools/oggenc/skeleton.h
20 ===================================================================
21 --- vorbis-tools/oggenc/skeleton.h (revision 19116)
22 +++ vorbis-tools/oggenc/skeleton.h (revision 19117)
23 @@ -42,5 +42,5 @@
24 ogg_int64_t start_granule; /* start granule value */
25 ogg_uint32_t preroll; /* preroll */
26 - unsigned char granule_shift; // a 8-bit field /* 1 byte value holding the granule shift */
27 + unsigned char granule_shift; /* 1 byte value holding the granule shift */
28 char *message_header_fields; /* holds all the message header fields */
29 /* current total size of the message header fields, for realloc purpose, initially zero */