gnu: xorg-server: Fix CVE-2017-{10971,10972}.
[jackhill/guix/guix.git] / gnu / packages / patches / cool-retro-term-remove-non-free-fonts.patch
1 From 96ceffdfdcedd3ae33c46b11357aa2518e0a6152 Mon Sep 17 00:00:00 2001
2 From: Petter <petter@mykolab.ch>
3 Date: Thu, 27 Apr 2017 18:55:10 +0200
4 Subject: [PATCH] Remove non-free fonts from settings menu
5
6 --- a/app/qml/ApplicationSettings.qml
7 +++ b/app/qml/ApplicationSettings.qml
8 @@ -409,7 +409,7 @@
9 obj_string: '{"ambientLight":0.16,"backgroundColor":"#000000","bloom":0.4,"brightness":0.5,"flickering":0.1,"contrast":0.85,"fontName":"TERMINUS_SCALED","fontColor":"#0ccc68","frameName":"SIMPLE_WHITE_FRAME","glowingLine":0.2,"horizontalSync":0.16,"jitter":0.18,"burnIn":0.45,"staticNoise":0.1,"rasterization":0,"screenCurvature":0.1,"windowOpacity":1,"chromaColor":0,"saturationColor":0,"rbgShift":0,"fontWidth":1.0,"useCustomCommand":false,"customCommand":""}'
10 builtin: true
11 }
12 - ListElement{
13 + /*ListElement{
14 text: "Default Scanlines"
15 obj_string: '{"ambientLight":0.16,"backgroundColor":"#000000","bloom":0.4,"brightness":0.5,"flickering":0.1,"contrast":0.85,"fontName":"COMMODORE_PET","fontColor":"#00ff5b","frameName":"SIMPLE_WHITE_FRAME","glowingLine":0.2,"horizontalSync":0.14,"jitter":0.11,"burnIn":0.4,"staticNoise":0.05,"rasterization":1,"screenCurvature":0.1,"windowOpacity":1,"chromaColor":0,"saturationColor":0,"rbgShift":0,"fontWidth":1.0,"useCustomCommand":false,"customCommand":""}'
16 builtin: true
17 @@ -433,7 +433,7 @@
18 text: "IBM Dos"
19 obj_string: '{"ambientLight":0.16,"backgroundColor":"#000000","bloom":0.4,"brightness":0.5,"flickering":0.07,"contrast":0.85,"fontName":"IBM_DOS","fontColor":"#ffffff","frameName":"SIMPLE_WHITE_FRAME","glowingLine":0.13,"horizontalSync":0,"jitter":0.16,"burnIn":0.3,"staticNoise":0.03,"rasterization":0,"screenCurvature":0.1,"windowOpacity":1,"chromaColor":1,"saturationColor":0,"rbgShift":0.35,"fontWidth":1.0,"useCustomCommand":false,"customCommand":""}'
20 builtin: true
21 - }
22 + }*/
23 ListElement{
24 text: "IBM 3278"
25 obj_string: '{"ambientLight":0.1,"backgroundColor":"#000000","bloom":0.15,"brightness":0.5,"flickering":0,"contrast":0.85,"fontName":"IBM_3278","fontColor":"#0ccc68","frameName":"SIMPLE_WHITE_FRAME","glowingLine":0,"horizontalSync":0,"jitter":0,"burnIn":0.6,"staticNoise":0,"rasterization":0,"screenCurvature":0.1,"windowOpacity":1,"chromaColor":0,"saturationColor":0,"rbgShift":0,"fontWidth":1.0,"useCustomCommand":false,"customCommand":""}'
26 diff --git a/app/qml/FontPixels.qml b/app/qml/FontPixels.qml
27 index 6ff85da..6f0d0ba 100644
28 --- a/app/qml/FontPixels.qml
29 +++ b/app/qml/FontPixels.qml
30 @@ -32,7 +32,7 @@ QtObject{
31 property bool lowResolutionFont: true
32
33 property ListModel fontlist: ListModel{
34 - ListElement{
35 + /*ListElement{
36 name: "COMMODORE_PET"
37 text: "Commodore PET (1977)"
38 source: "fonts/1977-commodore-pet/COMMODORE_PET.ttf"
39 @@ -40,7 +40,7 @@ QtObject{
40 pixelSize: 8
41 baseScaling: 4.0
42 fontWidth: 0.8
43 - }
44 + }*/
45 ListElement{
46 name: "PROGGY_TINY"
47 text: "Proggy Tiny (Modern)"
48 @@ -68,7 +68,7 @@ QtObject{
49 baseScaling: 3.0
50 fontWidth: 1.0
51 }
52 - ListElement{
53 + /*ListElement{
54 name: "APPLE_II"
55 text: "Apple ][ (1977)"
56 source: "fonts/1977-apple2/PrintChar21.ttf"
57 @@ -76,8 +76,8 @@ QtObject{
58 pixelSize: 8
59 baseScaling: 4.0
60 fontWidth: 0.9
61 - }
62 - ListElement{
63 + }*/
64 + /*ListElement{
65 name: "ATARI_400"
66 text: "Atari 400-800 (1979)"
67 source: "fonts/1979-atari-400-800/ATARI400800_original.TTF"
68 @@ -85,8 +85,8 @@ QtObject{
69 pixelSize: 8
70 baseScaling: 4.0
71 fontWidth: 0.8
72 - }
73 - ListElement{
74 + }*/
75 + /*ListElement{
76 name: "COMMODORE_64"
77 text: "Commodore 64 (1982)"
78 source: "fonts/1982-commodore64/C64_Pro_Mono_v1.0-STYLE.ttf"
79 @@ -94,6 +94,6 @@ QtObject{
80 pixelSize: 8
81 baseScaling: 4.0
82 fontWidth: 0.8
83 - }
84 + }*/
85 }
86 }
87 diff --git a/app/qml/FontScanlines.qml b/app/qml/FontScanlines.qml
88 index eebf00b..410d7b6 100644
89 --- a/app/qml/FontScanlines.qml
90 +++ b/app/qml/FontScanlines.qml
91 @@ -32,7 +32,7 @@ QtObject{
92 property bool lowResolutionFont: true
93
94 property ListModel fontlist: ListModel{
95 - ListElement{
96 + /*ListElement{
97 name: "COMMODORE_PET"
98 text: "Commodore PET (1977)"
99 source: "fonts/1977-commodore-pet/COMMODORE_PET.ttf"
100 @@ -40,7 +40,7 @@ QtObject{
101 pixelSize: 8
102 baseScaling: 4.0
103 fontWidth: 0.7
104 - }
105 + }*/
106 ListElement{
107 name: "PROGGY_TINY"
108 text: "Proggy Tiny (Modern)"
109 @@ -68,7 +68,7 @@ QtObject{
110 baseScaling: 3.0
111 fontWidth: 1.0
112 }
113 - ListElement{
114 + /*ListElement{
115 name: "APPLE_II"
116 text: "Apple ][ (1977)"
117 source: "fonts/1977-apple2/PrintChar21.ttf"
118 @@ -76,8 +76,8 @@ QtObject{
119 pixelSize: 8
120 baseScaling: 4.0
121 fontWidth: 0.8
122 - }
123 - ListElement{
124 + }*/
125 + /*ListElement{
126 name: "ATARI_400"
127 text: "Atari 400-800 (1979)"
128 source: "fonts/1979-atari-400-800/ATARI400800_original.TTF"
129 @@ -85,8 +85,8 @@ QtObject{
130 pixelSize: 8
131 baseScaling: 4.0
132 fontWidth: 0.7
133 - }
134 - ListElement{
135 + }*/
136 + /*ListElement{
137 name: "COMMODORE_64"
138 text: "Commodore 64 (1982)"
139 source: "fonts/1982-commodore64/C64_Pro_Mono_v1.0-STYLE.ttf"
140 @@ -94,6 +94,6 @@ QtObject{
141 pixelSize: 8
142 baseScaling: 4.0
143 fontWidth: 0.7
144 - }
145 + }*/
146 }
147 }
148 diff --git a/app/qml/Fonts.qml b/app/qml/Fonts.qml
149 index ad20844..882808a 100644
150 --- a/app/qml/Fonts.qml
151 +++ b/app/qml/Fonts.qml
152 @@ -80,7 +80,7 @@
153 fontWidth: 1.0
154 lowResolutionFont: true
155 }
156 - ListElement{
157 + /*ListElement{
158 name: "COMMODORE_PET_SCALED"
159 text: "Commodore PET (1977)"
160 source: "fonts/1977-commodore-pet/COMMODORE_PET.ttf"
161 @@ -89,7 +89,7 @@
162 baseScaling: 3.5
163 fontWidth: 0.7
164 lowResolutionFont: true
165 - }
166 + }*/
167 ListElement{
168 name: "PROGGY_TINY_SCALED"
169 text: "Proggy Tiny (Modern)"
170 @@ -100,7 +100,7 @@
171 fontWidth: 0.9
172 lowResolutionFont: true
173 }
174 - ListElement{
175 + /*ListElement{
176 name: "APPLE_II_SCALED"
177 text: "Apple ][ (1977)"
178 source: "fonts/1977-apple2/PrintChar21.ttf"
179 @@ -149,7 +149,7 @@
180 baseScaling: 2.0
181 fontWidth: 1.0
182 lowResolutionFont: true
183 - }
184 + }*/
185 ListElement{
186 name: "HERMIT"
187 text: "HD: Hermit (Modern)"
188 @@ -177,7 +177,7 @@
189 fontWidth: 1.0
190 lowResolutionFont: false
191 }
192 - ListElement{
193 + /*ListElement{
194 name: "MONACO"
195 text: "HD: Monaco (Modern)"
196 source: "fonts/modern-monaco/monaco.ttf"
197 @@ -185,7 +185,7 @@
198 pixelSize: 30
199 fontWidth: 1.0
200 lowResolutionFont: false
201 - }
202 + }*/
203 ListElement{
204 name: "INCONSOLATA"
205 text: "HD: Inconsolata (Modern)"