Merge branch 'python'
[jackhill/guix/guix.git] / gnu / packages / avahi.scm
1 ;;; GNU Guix --- Functional package management for GNU
2 ;;; Copyright © 2013 Ludovic Courtès <ludo@gnu.org>
3 ;;;
4 ;;; This file is part of GNU Guix.
5 ;;;
6 ;;; GNU Guix is free software; you can redistribute it and/or modify it
7 ;;; under the terms of the GNU General Public License as published by
8 ;;; the Free Software Foundation; either version 3 of the License, or (at
9 ;;; your option) any later version.
10 ;;;
11 ;;; GNU Guix is distributed in the hope that it will be useful, but
12 ;;; WITHOUT ANY WARRANTY; without even the implied warranty of
13 ;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
14 ;;; GNU General Public License for more details.
15 ;;;
16 ;;; You should have received a copy of the GNU General Public License
17 ;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
18
19 (define-module (gnu packages avahi)
20 #:use-module ((guix licenses) #:select (lgpl2.1+))
21 #:use-module (guix packages)
22 #:use-module (guix download)
23 #:use-module (guix build-system gnu)
24 #:use-module (gnu packages)
25 #:use-module (gnu packages gdbm)
26 #:use-module (gnu packages libdaemon)
27 #:use-module (gnu packages pkg-config)
28 #:use-module (gnu packages glib)
29 #:use-module (gnu packages xml))
30
31 (define-public avahi
32 (package
33 (name "avahi")
34 (version "0.6.31")
35 (home-page "http://avahi.org")
36 (source (origin
37 (method url-fetch)
38 (uri (string-append home-page "/download/avahi-"
39 version ".tar.gz"))
40 (sha256
41 (base32
42 "0j5b5ld6bjyh3qhd2nw0jb84znq0wqai7fsrdzg7bpg24jdp2wl3"))))
43 (build-system gnu-build-system)
44 (arguments
45 '(#:configure-flags '("--with-distro=none"
46 "--localstatedir=/var" ; for the DBus socket
47 "--disable-python"
48 "--disable-mono"
49 "--disable-doxygen-doc"
50 "--disable-xmltoman"
51 "--enable-tests"
52 "--disable-qt3" "--disable-qt4"
53 "--disable-gtk" "--disable-gtk3")
54 #:patches (list (assoc-ref %build-inputs "patch/localstatedir"))))
55 (inputs
56 `(("expat" ,expat)
57 ("glib" ,glib)
58 ("dbus" ,dbus)
59 ("libdaemon" ,libdaemon)
60 ("intltool" ,intltool)
61 ("pkg-config" ,pkg-config)
62 ("gdbm" ,gdbm)
63
64 ("patch/localstatedir"
65 ,(search-patch "avahi-localstatedir.patch"))))
66 (synopsis "Avahi, an mDNS/DNS-SD implementation")
67 (description
68 "Avahi is a system which facilitates service discovery on a local
69 network. It is an implementation of the mDNS (for \"Multicast DNS\") and
70 DNS-SD (for \"DNS-Based Service Discovery\") protocols.")
71 (license lgpl2.1+)))