gnu: avidemux: Build with Qt 5 instead of Qt 4.
[jackhill/guix/guix.git] / gnu / packages / xdisorg.scm
1 ;;; GNU Guix --- Functional package management for GNU
2 ;;; Copyright © 2013, 2014 Andreas Enge <andreas@enge.fr>
3 ;;; Copyright © 2014, 2015 Mark H Weaver <mhw@netris.org>
4 ;;; Copyright © 2014 Eric Bavier <bavier@member.fsf.org>
5 ;;; Copyright © 2014, 2015 Alex Kost <alezost@gmail.com>
6 ;;; Copyright © 2013, 2015 Ludovic Courtès <ludo@gnu.org>
7 ;;; Copyright © 2015 Mathieu Lirzin <mthl@openmailbox.org>
8 ;;; Copyright © 2015 Alexander I.Grafov <grafov@gmail.com>
9 ;;; Copyright © 2015 Andy Wingo <wingo@igalia.com>
10 ;;;
11 ;;; This file is part of GNU Guix.
12 ;;;
13 ;;; GNU Guix is free software; you can redistribute it and/or modify it
14 ;;; under the terms of the GNU General Public License as published by
15 ;;; the Free Software Foundation; either version 3 of the License, or (at
16 ;;; your option) any later version.
17 ;;;
18 ;;; GNU Guix is distributed in the hope that it will be useful, but
19 ;;; WITHOUT ANY WARRANTY; without even the implied warranty of
20 ;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
21 ;;; GNU General Public License for more details.
22 ;;;
23 ;;; You should have received a copy of the GNU General Public License
24 ;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
25
26 (define-module (gnu packages xdisorg)
27 #:use-module ((guix licenses) #:prefix license:)
28 #:use-module (guix packages)
29 #:use-module (guix download)
30 #:use-module (guix utils)
31 #:use-module (guix build-system gnu)
32 #:use-module (guix build-system glib-or-gtk)
33 #:use-module (gnu packages)
34 #:use-module (gnu packages compression)
35 #:use-module (gnu packages image)
36 #:use-module (gnu packages pkg-config)
37 #:use-module (gnu packages glib)
38 #:use-module (gnu packages perl)
39 #:use-module (gnu packages linux)
40 #:use-module (gnu packages guile)
41 #:use-module (gnu packages xml)
42 #:use-module (gnu packages gtk)
43 #:use-module (gnu packages xorg))
44
45 ;; packages outside the x.org system proper
46
47 (define-public xclip
48 (package
49 (name "xclip")
50 (version "0.12")
51 (source
52 (origin
53 (method url-fetch)
54 (uri (string-append
55 "mirror://sourceforge/" name "/" name "-" version ".tar.gz"))
56 (sha256
57 (base32
58 "0ibcf46rldnv0r424qcnai1fa5iq3lm5q5rdd7snsi5sb78gmixp"))))
59 (build-system gnu-build-system)
60 (arguments
61 '(#:tests? #f)) ; There is no test suite
62 (inputs `(("libxmu" ,libxmu)
63 ("libxt" ,libxt)))
64 (home-page "http://xclip.sourceforge.net/")
65 (synopsis "Command line interface to X11 clipboard")
66 (description "Xclip is a command line interface to the X11 clipboard. It
67 can also be used for copying files, as an alternative to sftp/scp, thus
68 avoiding password prompts when X11 forwarding has already been setup.")
69 (license license:gpl2+)))
70
71 (define-public xdotool
72 (package
73 (name "xdotool")
74 (version "2.20110530.1")
75 (source
76 (origin
77 (method url-fetch)
78 (uri (string-append
79 "http://semicomplete.googlecode.com/files/" name "-"
80 version ".tar.gz"))
81 (sha256
82 (base32
83 "0rxggg1cy7nnkwidx8x2w3c5f3pk6dh2b6q0q7hp069r3n5jrd77"))))
84 (build-system gnu-build-system)
85 (arguments
86 '(#:tests? #f ; Test suite requires a lot of black magic
87 #:phases
88 (alist-replace 'configure
89 (lambda* (#:key outputs #:allow-other-keys #:rest args)
90 (setenv "PREFIX" (assoc-ref outputs "out"))
91 (setenv "LDFLAGS" (string-append "-Wl,-rpath="
92 (assoc-ref
93 %outputs "out") "/lib"))
94 (setenv "CC" "gcc"))
95 %standard-phases)))
96 (native-inputs `(("perl" ,perl))) ; for pod2man
97 (inputs `(("libx11" ,libx11)
98 ("libxext" ,libxext)
99 ("libxi" ,libxi)
100 ("libxinerama" ,libxinerama)
101 ("libxtst" ,libxtst)))
102 (home-page "http://www.semicomplete.com/projects/xdotool")
103 (synopsis "Fake keyboard/mouse input, window management, and more")
104 (description "Xdotool lets you simulate keyboard input and mouse activity,
105 move and resize windows, etc. It does this using X11's XTEST extension and
106 other Xlib functions. Additionally, you can search for windows and move,
107 resize, hide, and modify window properties like the title. If your window
108 manager supports it, you can use xdotool to switch desktops, move windows
109 between desktops, and change the number of desktops.")
110 (license license:bsd-3)))
111
112 (define-public xeyes
113 (package
114 (name "xeyes")
115 (version "1.0.1")
116 (source
117 (origin
118 (method url-fetch)
119 (uri (string-append
120 "http://xeyes.sourcearchive.com/downloads/1.0.1/xeyes_"
121 version
122 ".orig.tar.gz"))
123 (sha256
124 (base32
125 "04c3md570j67g55h3bix1qbngcslnq91skli51k3g1avki88zkm9"))))
126 (build-system gnu-build-system)
127 (inputs
128 `(("libxext" ,libxext)
129 ("libxmu" ,libxmu)
130 ("libxt" ,libxt)))
131 (native-inputs
132 `(("pkg-config" ,pkg-config)))
133 (home-page "http://xeyes.sourcearchive.com/")
134 (synopsis "Follow-the-mouse X demo")
135 (description "Xeyes is a demo program for x.org. It shows eyes
136 following the mouse.")
137 (license license:x11)))
138
139
140 (define-public pixman
141 (package
142 (name "pixman")
143 (version "0.32.6")
144 (source
145 (origin
146 (method url-fetch)
147 (uri (string-append
148 "http://cairographics.org/releases/pixman-"
149 version
150 ".tar.gz"))
151 (sha256
152 (base32
153 "0129g4zdrw5hif5783li7rzcr4vpbc2cfia91azxmsk0h0xx3zix"))
154 (patches (list (search-patch "pixman-pointer-arithmetic.patch")))))
155 (build-system gnu-build-system)
156 (inputs
157 `(("libpng" ,libpng)
158 ("zlib" ,zlib)))
159 (native-inputs
160 `(("pkg-config" ,pkg-config)))
161 (home-page "http://www.pixman.org/")
162 (synopsis "Low-level pixel manipulation library")
163 (description "Pixman is a low-level software library for pixel
164 manipulation, providing features such as image compositing and trapezoid
165 rasterisation.")
166 (license license:x11)))
167
168
169 (define-public libdrm
170 (package
171 (name "libdrm")
172 (version "2.4.58")
173 (source
174 (origin
175 (method url-fetch)
176 (uri (string-append
177 "http://dri.freedesktop.org/libdrm/libdrm-"
178 version
179 ".tar.bz2"))
180 (sha256
181 (base32
182 "1pb5lfb3kh36p9axq620daclq68rqb3mhzxpz0pb18y9p7kglmdi"))))
183 (build-system gnu-build-system)
184 (inputs
185 `(("libpciaccess" ,libpciaccess)
186 ("libpthread-stubs" ,libpthread-stubs)))
187 (native-inputs
188 `(("pkg-config" ,pkg-config)))
189 (home-page "http://dri.freedesktop.org/wiki/")
190 (synopsis "Direct rendering userspace library")
191 (description "The Direct Rendering Infrastructure, also known as the DRI,
192 is a framework for allowing direct access to graphics hardware under the
193 X Window System in a safe and efficient manner. It includes changes to the
194 X server, to several client libraries, and to the kernel (DRM, Direct
195 Rendering Manager). The most important use for the DRI is to create fast
196 OpenGL implementations providing hardware acceleration for Mesa.
197 Several 3D accelerated drivers have been written to the DRI specification,
198 including drivers for chipsets produced by 3DFX, AMD (formerly ATI), Intel
199 and Matrox.")
200 (license license:x11)))
201
202
203 (define-public mtdev
204 (package
205 (name "mtdev")
206 (version "1.1.3")
207 (source
208 (origin
209 (method url-fetch)
210 (uri (string-append
211 "http://bitmath.org/code/mtdev/mtdev-"
212 version ".tar.bz2"))
213 (sha256
214 (base32
215 "159ndzwfpw0xr8mw4lhl47w9c2krshlfrscs7k6n186vknv2hk3d"))))
216 (build-system gnu-build-system)
217 (home-page "http://bitmath.org/code/mtdev/")
218 (synopsis "Multitouch protocol translation library")
219 (description "Mtdev is a stand-alone library which transforms all
220 variants of kernel MT events to the slotted type B protocol. The events
221 put into mtdev may be from any MT device, specifically type A without
222 contact tracking, type A with contact tracking, or type B with contact
223 tracking.")
224 (license license:x11)))
225
226 (define-public startup-notification
227 (package
228 (name "startup-notification")
229 (version "0.12")
230 (source
231 (origin
232 (method url-fetch)
233 (uri (string-append "http://www.freedesktop.org/software/" name
234 "/releases/" name "-" version ".tar.gz"))
235 (sha256
236 (base32
237 "0jmyryrpqb35y9hd5sgxqy2z0r1snw7d3ljw0jak0n0cjdz1yf9w"))))
238 (build-system gnu-build-system)
239 (native-inputs `(("pkg-config" ,pkg-config)))
240 (inputs
241 `(("libx11" ,libx11)
242 ("xcb-util" ,xcb-util)))
243 (home-page "http://www.freedesktop.org/wiki/Software/startup-notification/")
244 (synopsis "Application startup notification and feedback library")
245 (description
246 "Startup-notification contains a reference implementation of the startup
247 notification protocol. The reference implementation is mostly under an X Window
248 System style license, and has no special dependencies.")
249 ;; Most of the code is provided under x11 license.
250 (license license:lgpl2.0+)))
251
252 (define-public wmctrl
253 (package
254 (name "wmctrl")
255 (version "1.07")
256 (source (origin
257 (method url-fetch)
258 (uri (string-append
259 "http://tomas.styblo.name/wmctrl/dist/wmctrl-"
260 version ".tar.gz"))
261 (sha256
262 (base32
263 "1afclc57b9017a73mfs9w7lbdvdipmf9q0xdk116f61gnvyix2np"))
264 (patches (list (search-patch "wmctrl-64-fix.patch")))))
265 (build-system gnu-build-system)
266 (arguments
267 '(#:configure-flags
268 (list (string-append "--mandir="
269 (assoc-ref %outputs "out")
270 "/share/man"))))
271 (native-inputs
272 `(("pkg-config" ,pkg-config)))
273 (inputs
274 `(("libx11" ,libx11)
275 ("libxmu" ,libxmu)
276 ("glib" ,glib)))
277 (home-page "http://tomas.styblo.name/wmctrl/")
278 (synopsis "Command-line tool to control X window managers")
279 (description
280 "Wmctrl allows to interact with an X window manager that is compatible
281 with the EWMH/NetWM specification. It can query the window manager for
282 information, and request for certain window management actions (resize and
283 move windows, switch between desktops, etc.).")
284 (license license:gpl2+)))
285
286 (define-public scrot
287 (package
288 (name "scrot")
289 (version "0.8")
290 (source (origin
291 (method url-fetch)
292 (uri (string-append
293 "http://linuxbrit.co.uk/downloads/scrot-"
294 version ".tar.gz"))
295 (sha256
296 (base32
297 "1wll744rhb49lvr2zs6m93rdmiq59zm344jzqvijrdn24ksiqgb1"))))
298 (build-system gnu-build-system)
299 (arguments
300 ;; By default, man and doc are put in PREFIX/{man,doc} instead of
301 ;; PREFIX/share/{man,doc}.
302 '(#:configure-flags
303 (list (string-append "--mandir="
304 (assoc-ref %outputs "out")
305 "/share/man"))
306 #:phases (alist-replace
307 'install
308 (lambda* (#:key inputs outputs #:allow-other-keys)
309 (let* ((out (assoc-ref outputs "out"))
310 (doc (string-append out "/share/doc/scrot")))
311 (mkdir-p doc)
312 (zero?
313 (system* "make" "install"
314 (string-append "docsdir=" doc)))))
315 %standard-phases)))
316 (inputs
317 `(("libx11" ,libx11)
318 ("giblib" ,giblib)))
319 (home-page "http://linuxbrit.co.uk/software/")
320 (synopsis "Command-line screen capture utility for X Window System")
321 (description
322 "Scrot allows to save a screenshot of a full screen, a window or a part
323 of the screen selected by mouse.")
324 ;; This license removes a clause about X Consortium from the original
325 ;; X11 license.
326 (license (license:x11-style "file://COPYING"
327 "See 'COPYING' in the distribution."))))
328
329 (define-public unclutter
330 (package
331 (name "unclutter")
332 (version "8")
333 (source (origin
334 (method url-fetch)
335 (uri (string-append
336 "http://ftp.x.org/contrib/utilities/unclutter-"
337 version ".tar.Z"))
338 (sha256
339 (base32
340 "0ahrr5z6wxqqfyihm112hnq0859zlxisrb3y5232zav58j6sfmdq"))))
341 (build-system gnu-build-system)
342 (arguments
343 '(#:tests? #f ; no check target
344 #:phases (alist-delete
345 'configure
346 (alist-replace
347 'install
348 (lambda* (#:key inputs outputs #:allow-other-keys)
349 (let* ((out (assoc-ref outputs "out"))
350 (bin (string-append out "/bin"))
351 (man1 (string-append out "/share/man/man1")))
352 (mkdir-p bin)
353 (mkdir-p man1)
354 (zero?
355 (system* "make" "install" "install.man"
356 (string-append "BINDIR=" bin)
357 (string-append "MANDIR=" man1)))))
358 %standard-phases))))
359 (inputs `(("libx11" ,libx11)))
360 (home-page "http://ftp.x.org/contrib/utilities/")
361 (synopsis "Hide idle mouse cursor")
362 (description
363 "Unclutter is a program which runs permanently in the background of an
364 X11 session. It checks on the X11 pointer (cursor) position every few
365 seconds, and when it finds it has not moved (and no buttons are pressed
366 on the mouse, and the cursor is not in the root window) it creates a
367 small sub-window as a child of the window the cursor is in. The new
368 window installs a cursor of size 1x1 but a mask of all 0, i.e. an
369 invisible cursor. This allows you to see all the text in an xterm or
370 xedit, for example. The human factors crowd would agree it should make
371 things less distracting.")
372 (license license:public-domain)))
373
374 (define-public xlockmore
375 (package
376 (name "xlockmore")
377 (version "5.45")
378 (source (origin
379 (method url-fetch)
380 (uri (string-append "http://www.tux.org/~bagleyd/xlock/xlockmore-"
381 version "/xlockmore-" version ".tar.bz2"))
382 (sha256
383 (base32
384 "1xqm61bbfn5q056w57vp16gvai8nqpcw570ysxlm5h46nh6ai0bz"))))
385 (build-system gnu-build-system)
386 (arguments
387 '(#:configure-flags (list (string-append "--enable-appdefaultdir="
388 (assoc-ref %outputs "out")
389 "/lib/X11/app-defaults"))
390 #:tests? #f)) ;no such thing as a test suite
391 (inputs
392 `(("libX11" ,libx11)
393 ("libXext" ,libxext)
394 ("libXt" ,libxt)
395 ("linux-pam" ,linux-pam)))
396 (home-page "http://www.tux.org/~bagleyd/xlockmore.html")
397 (synopsis "Screen locker for the X Window System")
398 (description
399 "XLockMore is a classic screen locker and screen saver for the
400 X Window System.")
401 (license (license:non-copyleft #f "See xlock.c.")
402 ;; + GPLv2 in modes/glx/biof.c.
403 )))
404
405 (define-public xosd
406 (package
407 (name "xosd")
408 (version "2.2.14")
409 (source (origin
410 (method url-fetch)
411 (uri (string-append
412 "mirror://sourceforge/libxosd/xosd-"
413 version ".tar.gz"))
414 (sha256
415 (base32
416 "025m7ha89q29swkc7s38knnbn8ysl24g2h5s7imfxflm91psj7sg"))))
417 (build-system gnu-build-system)
418 (arguments
419 '(#:configure-flags
420 (list (string-append "--mandir=" %output "/share/man"))))
421 (inputs
422 `(("libx11" ,libx11)
423 ("libxt" ,libxt)
424 ("libxext" ,libxext)
425 ("libxinerama" ,libxinerama)))
426 (home-page "http://sourceforge.net/projects/libxosd/")
427 (synopsis "X On Screen Display")
428 (description
429 "XOSD provides a C library and a simple utility (osd_cat) for displaying
430 transparent text on your screen.")
431 (license license:gpl2+)))
432
433 (define-public xbindkeys
434 (package
435 (name "xbindkeys")
436 (version "1.8.6")
437 (source (origin
438 (method url-fetch)
439 ;; Download from the savannah mirror list fails
440 (uri (string-append
441 "http://www.nongnu.org/xbindkeys/xbindkeys-"
442 version
443 ".tar.gz"))
444 (sha256
445 (base32
446 "060df6d8y727jp1inp7blp44cs8a7jig7vcm8ndsn6gw36z1h3bc"))))
447 (build-system gnu-build-system)
448 (inputs
449 `(("libx11" ,libx11)
450 ("guile" ,guile-2.0)))
451 (home-page "http://www.nongnu.org/xbindkeys/")
452 (synopsis "Associate a combination of keys with a shell command")
453 (description
454 "XBindKeys is a program that allows you to launch shell commands with
455 your keyboard or your mouse under the X Window System. It links commands to
456 keys or mouse buttons, using a configuration file. It's independent of the
457 window manager and can capture all keyboard keys (ex: Power, Wake...). It
458 optionally supports a Guile-based configuration file layout, which enables you
459 to access all XBindKeys internals, so you can have key combinations, double
460 clicks or timed double clicks take actions. Also all functions that work in
461 Guile will work for XBindKeys.")
462 (license license:gpl2+)))
463
464 (define-public rxvt-unicode
465 (package
466 (name "rxvt-unicode")
467 (version "9.21")
468 (source
469 (origin
470 (method url-fetch)
471 (uri (string-append
472 "http://dist.schmorp.de/rxvt-unicode/"
473 name "-"
474 version
475 ".tar.bz2"))
476 (sha256
477 (base32
478 "0swmi308v5yxsddrdhvi4cch88k2bbs2nffpl5j5m2f55gbhw9vm"))))
479 (build-system gnu-build-system)
480 (inputs
481 `(("libXft" ,libxft)
482 ("libX11" ,libx11)))
483 (native-inputs
484 `(("perl" ,perl)
485 ("pkg-config" ,pkg-config)))
486 (home-page "http://software.schmorp.de/pkg/rxvt-unicode.html")
487 (synopsis "Rxvt clone with XFT and unicode support")
488 (description "Rxvt-unicode (urxvt) is a colour vt102 terminal emulator
489 intended as an xterm replacement for users who do not require features such as
490 Tektronix 4014 emulation and toolkit-style configurability. It supports
491 unicode, XFT and may be extended with Perl plugins. It also comes with a
492 client/daemon pair that lets you open any number of terminal windows from
493 within a single process.")
494 (license license:gpl3+)))
495
496 (define-public xcape
497 (package
498 (name "xcape")
499 (version "1.1")
500 (source
501 (origin
502 (method url-fetch)
503 (uri (string-append "https://github.com/alols/" name
504 "/archive/v" version ".tar.gz"))
505 (file-name (string-append name "-" version ".tar.gz"))
506 (sha256
507 (base32
508 "0jkdiaxc6sryrbibdgi2y1c48n4l9xyazhxr16l6h4ibddx95bk9"))))
509 (build-system gnu-build-system)
510 (arguments
511 `(#:tests? #f ; no check target
512 #:phases (alist-delete 'configure %standard-phases) ; no configure script
513 #:make-flags (list (string-append "PREFIX=" (assoc-ref %outputs "out"))
514 "MANDIR=/share/man/man1"
515 "CC=gcc")))
516 (inputs
517 `(("libxtst" ,libxtst)
518 ("libx11" ,libx11)))
519 (native-inputs
520 `(("pkg-config" ,pkg-config)))
521 (home-page "http://github.com/alols/xcape")
522 (synopsis "Use a modifier key in X.org as another key")
523 (description
524 "This utility for X.org allows to use modifier key as another key when
525 pressed and released on its own. The default behaviour is to generate the
526 Escape key when Left Control is pressed and released on its own.")
527 (license license:gpl3+)))
528
529 (define-public libwacom
530 (package
531 (name "libwacom")
532 (version "0.12")
533 (source (origin
534 (method url-fetch)
535 (uri (string-append "mirror://sourceforge/linuxwacom/libwacom/"
536 name "-" version ".tar.bz2"))
537 (sha256
538 (base32
539 "022d0097dk2glgb6772zpcsqm1w42sbsbr3i72pdhzq6naqawys8"))))
540 (build-system glib-or-gtk-build-system)
541 (native-inputs
542 `(("pkg-config" ,pkg-config)))
543 (inputs
544 `(("glib" ,glib)
545 ("gtk+" ,gtk+)
546 ("eudev" ,eudev)
547 ("libxml2" ,libxml2)))
548 (home-page "http://linuxwacom.sourceforge.net/")
549 (synopsis "Helper library for Wacom tablet settings")
550 (description
551 "Libwacom is a library to help implement Wacom tablet settings. It
552 is intended to be used by client-programs that need model identification. It
553 is already being used by the gnome-settings-daemon and the GNOME 3.4 Control
554 Center Wacom tablet applet. In the future, the xf86-input-wacom driver may
555 use it as well.")
556 (license license:x11)))
557
558 (define-public xf86-input-wacom
559 (package
560 (name "xf86-input-wacom")
561 (version "0.29.0")
562 (source (origin
563 (method url-fetch)
564 (uri (string-append
565 "mirror://sourceforge/linuxwacom/xf86-input-wacom/"
566 name "-" version ".tar.bz2"))
567 (sha256
568 (base32
569 "15lbzjkaf690i69qy0n0ibwczbclqq1nx0418c6a567by5v7wl48"))))
570 (arguments
571 `(#:configure-flags
572 (list (string-append "--with-sdkdir="
573 (assoc-ref %outputs "out")
574 "/include/xorg")
575 (string-append "--with-xorg-conf-dir="
576 (assoc-ref %outputs "out")
577 "/share/X11/xorg.conf.d"))))
578 (build-system gnu-build-system)
579 (native-inputs
580 `(("pkg-config" ,pkg-config)))
581 (inputs
582 `(("xorg-server" ,xorg-server)
583 ("libxrandr" ,libxrandr)
584 ("libxinerama" ,libxinerama)
585 ("libxi" ,libxi)
586 ("eudev" ,eudev)))
587 (home-page "http://linuxwacom.sourceforge.net/")
588 (synopsis "Wacom input driver for X")
589 (description
590 "The xf86-input-wacom driver is the wacom-specific X11 input driver for
591 the X.Org X Server version 1.7 and later (X11R7.5 or later).")
592 (license license:x11)))