Merge branch 'master' into staging
[jackhill/guix/guix.git] / gnu / packages / prolog.scm
1 ;;; GNU Guix --- Functional package management for GNU
2 ;;; Copyright © 2013 Nikita Karetnikov <nikita@karetnikov.org>
3 ;;; Copyright © 2013 Mark H Weaver <mhw@netris.org>
4 ;;; Copyright © 2020 Brett Gilio <brettg@gnu.org>
5 ;;;
6 ;;; This file is part of GNU Guix.
7 ;;;
8 ;;; GNU Guix is free software; you can redistribute it and/or modify it
9 ;;; under the terms of the GNU General Public License as published by
10 ;;; the Free Software Foundation; either version 3 of the License, or (at
11 ;;; your option) any later version.
12 ;;;
13 ;;; GNU Guix is distributed in the hope that it will be useful, but
14 ;;; WITHOUT ANY WARRANTY; without even the implied warranty of
15 ;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
16 ;;; GNU General Public License for more details.
17 ;;;
18 ;;; You should have received a copy of the GNU General Public License
19 ;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
20
21 (define-module (gnu packages prolog)
22 #:use-module (guix download)
23 #:use-module (guix git-download)
24 #:use-module ((guix licenses) #:prefix license:)
25 #:use-module (guix packages)
26 #:use-module (guix build-system cmake)
27 #:use-module (guix build-system gnu)
28 #:use-module (gnu packages backup)
29 #:use-module (gnu packages compression)
30 #:use-module (gnu packages fontutils)
31 #:use-module (gnu packages image)
32 #:use-module (gnu packages libunwind)
33 #:use-module (gnu packages multiprecision)
34 #:use-module (gnu packages perl)
35 #:use-module (gnu packages pkg-config)
36 #:use-module (gnu packages readline)
37 #:use-module (gnu packages texinfo)
38 #:use-module (gnu packages tls)
39 #:use-module (gnu packages xorg)
40 #:use-module (srfi srfi-1))
41
42 (define-public gprolog
43 (package
44 (name "gprolog")
45 (version "1.4.5")
46 (source
47 (origin
48 (method url-fetch)
49 ;; Recent versions are not hosted on the GNU mirrors.
50 (uri (list (string-append "http://gprolog.org/gprolog-" version
51 ".tar.gz")
52 (string-append "mirror://gnu/gprolog/gprolog-" version
53 ".tar.gz")))
54 (sha256
55 (base32
56 "0z4cc42n3k6i35b8mr816iwsvrpxshw6d7dgz6s2h1hy0l7g1p5z"))))
57 (build-system gnu-build-system)
58 (arguments
59 `(#:configure-flags
60 (list (string-append
61 "--with-install-dir=" %output "/share/gprolog"))
62 #:phases
63 (modify-phases %standard-phases
64 (add-before 'configure 'change-dir-n-fix-shells
65 (lambda _
66 (chdir "src")
67 (substitute* "configure"
68 (("-/bin/sh") (string-append "-" (which "sh")))
69 (("= /bin/sh") (string-append "= " (which "sh"))))
70 #t)))))
71 (home-page "https://www.gnu.org/software/gprolog/")
72 (synopsis "Prolog compiler")
73 (description
74 "GNU Prolog is a standards-compliant Prolog compiler with constraint
75 solving over finite domains. It accepts Prolog+ constraint programs and
76 produces a compiled, native binary which can function in a stand-alone
77 manner. It also features an interactive interpreter.")
78 (license (list license:gpl2+
79 license:lgpl3+))
80
81 ;; See 'configure' for the list of supported architectures.
82 (supported-systems (fold delete
83 %supported-systems
84 '("armhf-linux" "mips64el-linux")))))
85
86 (define-public swi-prolog
87 (package
88 (name "swi-prolog")
89 (version "8.1.21")
90 (source (origin
91 (method git-fetch)
92 (uri (git-reference
93 (url "https://github.com/SWI-Prolog/swipl-devel.git")
94 (recursive? #t) ; TODO: Determine if this can be split out.
95 (commit (string-append "V" version))))
96 (file-name (git-file-name name version))
97 (sha256
98 (base32
99 "1axdiz37dllw0ih58ffm0m95dfxqfzwahl48hpzq90rz4swcr1lq"))))
100 (build-system cmake-build-system)
101 (arguments
102 `(#:parallel-build? #t
103 #:tests? #t
104 #:configure-flags
105 (list "-DINSTALL_DOCUMENTATION=ON"
106 "-DSWIPL_INSTALL_IN_LIB=OFF") ; FIXME: Breaks RUNPATH validation.
107 #:phases
108 (modify-phases %standard-phases
109 ;; XXX: Delete a variety of tests which fail either attempting to
110 ;; establish a network connection, or attempts to write to the
111 ;; immutable store. Phases marked *-pre are disabled /before/ building.
112 ;; Phases marked *-post are disabled /after/ building.
113 (add-after 'unpack 'delete-failing-tests-pre
114 (lambda _
115 (substitute* "src/CMakeLists.txt"
116 ((" save") ""))
117 (substitute* "src/test.pl"
118 (("testdir\\('Tests/save'\\).") ""))
119 (with-directory-excursion "src/Tests"
120 (for-each delete-file-recursively
121 '("save")))
122 #t))
123 (add-before 'check 'delete-failing-tests-post
124 (lambda _
125 (with-directory-excursion "packages"
126 (for-each delete-file-recursively
127 '("http"
128 "pengines"
129 "RDF"
130 "semweb"
131 "ssl")))
132 #t)))))
133 (native-inputs
134 `(("zlib" ,zlib)
135 ("gmp" ,gmp)
136 ("readline" ,readline)
137 ("texinfo" ,texinfo)
138 ("libarchive" ,libarchive)
139 ("libunwind" ,libunwind)
140 ("libjpeg", libjpeg-turbo)
141 ("libxft" ,libxft)
142 ("fontconfig" ,fontconfig)
143 ("perl" ,perl)
144 ("pkg-config" ,pkg-config)
145 ("openssl" ,openssl)))
146 (home-page "https://www.swi-prolog.org/")
147 (synopsis "ISO/Edinburgh-style Prolog interpreter")
148 (description "SWI-Prolog is a fast and powerful ISO/Edinburgh-style Prolog
149 compiler with a rich set of built-in predicates. It offers a fast, robust and
150 small environment which enables substantial applications to be developed with
151 it.")
152 (license license:bsd-2)))