a9ac23e049bdfb17494d0ba9a8f6c68d82ac7fab
[jackhill/guix/guix.git] / gnu / packages / kde.scm
1 ;;; GNU Guix --- Functional package management for GNU
2 ;;; Copyright © 2016, 2017, 2019, 2020 Efraim Flashner <efraim@flashner.co.il>
3 ;;; Copyright © 2016 David Craven <david@craven.ch>
4 ;;; Copyright © 2016, 2017 Thomas Danckaert <post@thomasdanckaert.be>
5 ;;; Copyright © 2017, 2018 Mark Meyer <mark@ofosos.org>
6 ;;; Copyright © 2017, 2018, 2019, 2020 Tobias Geerinckx-Rice <me@tobias.gr>
7 ;;; Copyright © 2018 Gábor Boskovits <boskovits@gmail.com>
8 ;;; Copyright © 2019 Nicolas Goaziou <mail@nicolasgoaziou.fr>
9 ;;; Copyright © 2018, 2019 Hartmut Goebel <h.goebel@crazy-compilers.com>
10 ;;; Copyright © 2019, 2020 Ludovic Courtès <ludo@gnu.org>
11 ;;; Copyright © 2020 Marius Bakke <marius@gnu.org>
12 ;;; Copyright © 2020 Michael Rohleder <mike@rohleder.de>
13 ;;;
14 ;;; This file is part of GNU Guix.
15 ;;;
16 ;;; GNU Guix is free software; you can redistribute it and/or modify it
17 ;;; under the terms of the GNU General Public License as published by
18 ;;; the Free Software Foundation; either version 3 of the License, or (at
19 ;;; your option) any later version.
20 ;;;
21 ;;; GNU Guix is distributed in the hope that it will be useful, but
22 ;;; WITHOUT ANY WARRANTY; without even the implied warranty of
23 ;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
24 ;;; GNU General Public License for more details.
25 ;;;
26 ;;; You should have received a copy of the GNU General Public License
27 ;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
28
29 (define-module (gnu packages kde)
30 #:use-module (guix build-system cmake)
31 #:use-module (guix build-system qt)
32 #:use-module (guix deprecation)
33 #:use-module (guix download)
34 #:use-module (guix git-download)
35 #:use-module ((guix licenses) #:prefix license:)
36 #:use-module (guix packages)
37 #:use-module (guix utils)
38 #:use-module (gnu packages)
39 #:use-module (gnu packages algebra)
40 #:use-module (gnu packages apr)
41 #:use-module (gnu packages audio)
42 #:use-module (gnu packages boost)
43 #:use-module (gnu packages code)
44 #:use-module (gnu packages cpp)
45 #:use-module (gnu packages compression)
46 #:use-module (gnu packages curl)
47 #:use-module (gnu packages documentation)
48 #:use-module (gnu packages gettext)
49 #:use-module (gnu packages ghostscript)
50 #:use-module (gnu packages gl)
51 #:use-module (gnu packages gnome)
52 #:use-module (gnu packages graphics)
53 #:use-module (gnu packages image)
54 #:use-module (gnu packages kde-frameworks)
55 #:use-module (gnu packages kde-pim)
56 #:use-module (gnu packages kde-plasma)
57 #:use-module (gnu packages linux)
58 #:use-module (gnu packages llvm)
59 #:use-module (gnu packages maths)
60 #:use-module (gnu packages pdf)
61 #:use-module (gnu packages perl)
62 #:use-module (gnu packages photo)
63 #:use-module (gnu packages pkg-config)
64 #:use-module (gnu packages pulseaudio)
65 #:use-module (gnu packages python)
66 #:use-module (gnu packages tls)
67 #:use-module (gnu packages qt)
68 #:use-module (gnu packages version-control)
69 #:use-module (gnu packages video)
70 #:use-module (gnu packages xdisorg)
71 #:use-module (gnu packages xml)
72 #:use-module (gnu packages xorg))
73
74 (define-public baloo-widgets
75 (package
76 (name "baloo-widgets")
77 (version "20.04.1")
78 (source
79 (origin
80 (method url-fetch)
81 (uri (string-append "mirror://kde/stable/release-service/" version
82 "/src/baloo-widgets-" version ".tar.xz"))
83 (sha256
84 (base32 "1x4v79vhvc5ixkbsf3jyjz5ig1lf78rfw3r7g3llpb4j1kcp3wh0"))))
85 (build-system qt-build-system)
86 (native-inputs
87 `(("extra-cmake-modules" ,extra-cmake-modules)))
88 (inputs
89 `(("baloo" ,baloo)
90 ("kconfig" ,kconfig)
91 ("ki18n" ,ki18n)
92 ("kio" ,kio)
93 ("qtbase" ,qtbase)))
94 (arguments
95 `(#:phases
96 (modify-phases %standard-phases
97 (add-before 'check 'check-setup
98 (lambda _
99 (setenv "QT_QPA_PLATFORM" "offscreen")
100 #t)))))
101 (home-page "https://community.kde.org/Baloo")
102 (synopsis "Wigets for use with Baloo")
103 (description "Baloo is a framework for searching and managing metadata.
104 This package contains GUI widgets for baloo.")
105 (license license:lgpl2.0+)))
106
107 (define-public grantleetheme
108 (package
109 (name "grantleetheme")
110 (version "20.04.1")
111 (source
112 (origin
113 (method url-fetch)
114 (uri (string-append "mirror://kde/stable/release-service/" version
115 "/src/grantleetheme-" version ".tar.xz"))
116 (sha256
117 (base32 "0gabc5cb0sf00s7m5v2jnq55qsrdbrq6nqd15y1i15p788zifsjx"))
118 (patches (search-patches "grantlee-merge-theme-dirs.patch"))))
119 (build-system qt-build-system)
120 (native-inputs
121 `(("extra-cmake-modules" ,extra-cmake-modules)
122 ("libxml2" ,libxml2))) ;; xmllint required for tests
123 (inputs
124 `(("grantlee" ,grantlee)
125 ("kguiaddons" ,kguiaddons)
126 ("ki18n" ,ki18n)
127 ("kiconthemes" ,kiconthemes)
128 ("knewstuff" ,knewstuff)
129 ("qtbase" ,qtbase)))
130 (home-page "https://cgit.kde.org/grantleetheme.git")
131 (synopsis "Library providing Grantlee theme support")
132 (description "This library provides Grantlee theme support.")
133 (license ;; LGPL for libraries, FDL for documentation
134 (list license:lgpl2.1+ license:fdl1.2+))))
135
136 (define-public kdenlive
137 (let ((version "20.04.1"))
138 (package
139 (name "kdenlive")
140 (version version)
141 (source
142 (origin
143 (method git-fetch)
144 (uri (git-reference
145 (url "https://anongit.kde.org/kdenlive.git")
146 (commit (string-append "v" version))))
147 (file-name (string-append name "-" version "-checkout"))
148 (sha256
149 (base32
150 "0n0x34xmcn0k87rqnz0mk462b3al4gq56kn4m00rr428hafscdz7"))))
151 (build-system cmake-build-system)
152 (native-inputs
153 `(("extra-cmake-modules" ,extra-cmake-modules)
154 ("qttools" ,qttools)))
155 (inputs
156 `(("shared-mime-info" ,shared-mime-info)
157 ("frei0r-plugins" ,frei0r-plugins)
158 ("ffmpeg" ,ffmpeg)
159 ("rttr" ,rttr)
160 ("mlt" ,mlt)
161 ("qtbase" ,qtbase)
162 ("qtscript" ,qtscript)
163 ("qtsvg" ,qtsvg)
164 ("qtmultimedia" ,qtmultimedia)
165 ("kparts" ,kparts)
166 ("knotifications" ,knotifications)
167 ("karchive" ,karchive)
168 ("kdbusaddons" ,kdbusaddons)
169 ("kcrash" ,kcrash)
170 ("kguiaddons" ,kguiaddons)
171 ("knewstuff" ,knewstuff)
172 ("knotifyconfig" ,knotifyconfig)
173 ("kfilemetadata" ,kfilemetadata)
174 ("kdoctools" ,kdoctools)
175 ("kdeclarative" ,kdeclarative)
176 ("qtdeclarative" ,qtdeclarative)
177 ("qtquickcontrols" ,qtquickcontrols)
178 ("qtquickcontrols2" ,qtquickcontrols2)
179 ("kiconthemes" ,kiconthemes)
180 ("qtgraphicaleffects" ,qtgraphicaleffects)
181 ("kplotting" ,kplotting)))
182 (arguments
183 `(#:tests? #f ;TODO needs X
184 #:phases
185 (modify-phases %standard-phases
186 (add-after 'install 'wrap-executable
187 (lambda* (#:key inputs outputs #:allow-other-keys)
188 (let* ((out (assoc-ref outputs "out"))
189 (qtquickcontrols (assoc-ref inputs "qtquickcontrols"))
190 (qtquickcontrols2 (assoc-ref inputs "qtquickcontrols2"))
191 (qtbase (assoc-ref inputs "qtbase"))
192 (qtdeclarative (assoc-ref inputs "qtdeclarative"))
193 (frei0r (assoc-ref inputs "frei0r-plugins"))
194 (ffmpeg (assoc-ref inputs "ffmpeg"))
195 (qml "/lib/qt5/qml"))
196 (wrap-program (string-append out "/bin/kdenlive")
197 `("PATH" ":" prefix
198 ,(list (string-append ffmpeg "/bin")))
199 `("QT_PLUGIN_PATH" ":" prefix
200 ,(map (lambda (label)
201 (string-append (assoc-ref inputs label)
202 "/lib/qt5/plugins/"))
203 '("qtbase" "qtsvg")))
204 `("FREI0R_PATH" ":" =
205 (,(string-append frei0r "/lib/frei0r-1/")))
206 `("QT_QPA_PLATFORM_PLUGIN_PATH" ":" =
207 (,(string-append qtbase "/lib/qt5/plugins/platforms")))
208 `("QML2_IMPORT_PATH" ":" prefix
209 (,(string-append qtquickcontrols qml)
210 ,(string-append qtquickcontrols2 qml)
211 ,(string-append qtdeclarative qml)))
212 `("MLT_PREFIX" ":" =
213 (,(assoc-ref inputs "mlt")))))
214 #t)))))
215 (home-page "https://kdenlive.org")
216 (synopsis "Non-linear video editor")
217 (description "Kdenlive is an acronym for KDE Non-Linear Video Editor.
218
219 Non-linear video editing is much more powerful than beginner's (linear)
220 editors, hence it requires a bit more organization before starting. However,
221 it is not reserved to specialists and can be used for small personal
222 projects.")
223 (license license:gpl2+))))
224
225 (define-public kdevelop
226 (package
227 (name "kdevelop")
228 (version "5.5.2")
229 (source
230 (origin
231 (method url-fetch)
232 (uri (string-append "mirror://kde/stable/kdevelop"
233 "/" version "/src/kdevelop-"
234 version ".tar.xz"))
235 (sha256
236 (base32 "1nkl3z1n1l7ly2zvmbx2sdhx5q72wcvpwhzsz3qgw1474qd9i3i2"))))
237 (build-system qt-build-system)
238 (native-inputs
239 `(("extra-cmake-modules" ,extra-cmake-modules)
240 ("pkg-config" ,pkg-config)
241 ("shared-mime-info" ,shared-mime-info)
242 ("qttools" ,qttools)))
243 (inputs
244 `(("boost" ,boost)
245 ("clang" ,clang)
246 ("grantlee" ,grantlee)
247 ("karchive" ,karchive)
248 ("kcmutils" ,kcmutils)
249 ("kcrash" ,kcrash)
250 ("kdeclarative" ,kdeclarative)
251 ("kdoctools" ,kdoctools)
252 ("kguiaddons" ,kguiaddons)
253 ("ki18n" ,ki18n)
254 ("kiconthemes" ,kiconthemes)
255 ("kio" ,kio) ;; not checked as requirement
256 ("kitemmodels" ,kitemmodels)
257 ("kitemviews" ,kitemviews)
258 ("kjobwidgets" ,kjobwidgets)
259 ("knotifications" ,knotifications)
260 ("knotifyconfig" ,knotifyconfig)
261 ("kparts" ,kparts)
262 ("kservice" ,kservice)
263 ("ktexteditor" ,ktexteditor)
264 ("kwindowsystem" ,kwindowsystem)
265 ("kxmlgui" ,kxmlgui)
266 ("libkomparediff2" ,libkomparediff2)
267 ("oxygen-icons" ,oxygen-icons)
268 ("qtbase" ,qtbase)
269 ("qtdeclarative" ,qtdeclarative)
270 ("qtquickcontrols" ,qtquickcontrols) ;; not checked as requirement
271 ("qtquickcontrols2" ,qtquickcontrols2) ;; not checked as requirement
272 ("qtwebkit" ,qtwebkit)
273 ("threadweaver" ,threadweaver)
274
275 ;; recommendes
276 ("astyle" ,astyle)
277 ("kdevelop-pg-qt" ,kdevelop-pg-qt)
278 ("libksysguard" ,libksysguard)
279
280 ;; optional
281 ("apr" ,apr) ; required for subversion support
282 ("apr-util" ,apr-util) ; required for subversion support
283 ("attica" ,attica)
284 ("kconfigwidgets" ,kconfigwidgets)
285 ("knewstuff" ,knewstuff)
286 ("krunner" ,krunner)
287 ;; TODO: OktetaGui, OktetaKastenControllers
288 ("plasma" ,plasma-framework)
289 ;; TODO: purpose
290 ("sonnet" ,sonnet)
291 ("subversion" ,subversion)))
292
293 ;; run-time packages - TODO
294 ;; ClazyStandalone
295 ;; Cppcheck
296 ;; heaptrack
297 ;; heaptrack_gui
298 ;; meson
299 (arguments
300 `(#:tests? #f ;; there are some issues with the test suite
301 #:phases
302 (modify-phases %standard-phases
303 (add-before 'configure 'add-include-path
304 (lambda* (#:key inputs #:allow-other-keys)
305 (substitute* "cmake/modules/FindClang.cmake"
306 (("^\\s*PATHS \"\\$\\{CLANG_LIBRARY_DIRS\\}\"" line)
307 (string-append line " " (assoc-ref inputs "clang") "/lib")))
308 #t)))))
309 (home-page "https://kdevelop.org")
310 (synopsis "IDE for C, C++, Python, Javascript and PHP")
311 (description "The KDevelop IDE provides semantic syntax highlighting, as
312 well as code navigation and completion for C, C++ (using Clang/LLVM), QML,
313 JavaScript, Python and PHP. It also integrates with a debugger, different
314 build systems (CMake, QMake, custom Makefiles) and version control
315 software (Git, Subversion, Mercurial, CVS and Bazaar).")
316 (license license:lgpl2.1+)))
317
318 (define-public kdevelop-pg-qt
319 (package
320 (name "kdevelop-pg-qt")
321 (version "2.2.1")
322 (source
323 (origin
324 (method git-fetch)
325 (uri (git-reference
326 (url "https://github.com/KDE/kdevelop-pg-qt")
327 (commit (string-append "v" version))))
328 (file-name (git-file-name name version))
329 (sha256
330 (base32 "1kfab4p717acbdkcdi41d98vwch7v431gb2qi6s38hmclsf8bf8g"))))
331 (native-inputs
332 `(("extra-cmake-modules" ,extra-cmake-modules)))
333 (inputs
334 `(("qtbase" ,qtbase)))
335 (build-system cmake-build-system)
336 (home-page "https://kde.org")
337 (synopsis "Parser generator library for KDevplatform")
338 (description "KDevelop-PG-Qt is the parser generator used in KDevplatform
339 for some KDevelop language plugins (Ruby, PHP, CSS...).")
340 (license license:lgpl2.0+)))
341
342 ;; kdevplatform was merged into kdevelop as of 5.2.x
343 (define-deprecated kdevplatform kdevelop)
344
345 (define-public kdiagram
346 (package
347 (name "kdiagram")
348 (version "2.7.0")
349 (source
350 (origin
351 (method url-fetch)
352 (uri (string-append "mirror://kde/stable/kdiagram/" version
353 "/kdiagram-" version ".tar.xz"))
354 (sha256
355 (base32 "1pgvf2q8b59hw0jg5ajmj5nrn4q8cgnifpvdd0fynk2ml6zym8k3"))
356 (patches (search-patches
357 "kdiagram-Fix-missing-link-libraries.patch"))))
358 (build-system qt-build-system)
359 (native-inputs
360 `(("extra-cmake-modules" ,extra-cmake-modules)
361 ("qttools" ,qttools)))
362 (inputs
363 `(("qtbase" ,qtbase)
364 ("qtsvg" ,qtsvg)))
365 (home-page "https://cgit.kde.org/kdiagram.git/")
366 (synopsis "Libraries for creating business diagrams")
367 (description "This package provides libraries for integrating business
368 diagrams in Qt-based applications.
369
370 @code{KCharts} provides an implementation of the ODF Chart specification. It
371 supports stock charts, box charts, and whisker charts. @code{KGantt} provides
372 a module for implementing ODF Gantt charts, which are bar charts that
373 illustrate project schedules.")
374 (license license:gpl2+)))
375
376 (define-public krita
377 (package
378 (name "krita")
379 (version "4.3.0")
380 (source (origin
381 (method url-fetch)
382 (uri (string-append
383 "mirror://kde/stable/krita/" version
384 "/krita-" version ".tar.gz"))
385 (sha256
386 (base32
387 "1njbxv7b56if838gv7ydzm1sprgmaabnp0jlj0bxryxzfdy8hwfh"))))
388 (build-system cmake-build-system)
389 (arguments
390 `(#:tests? #f
391 #:configure-flags
392 (list "-DBUILD_TESTING=OFF"
393 (string-append "-DCMAKE_CXX_FLAGS=-I"
394 (assoc-ref %build-inputs "openexr")
395 "/include/OpenEXR"))
396 #:phases
397 (modify-phases %standard-phases
398 ;; Ensure that icons are found at runtime.
399 ;; This works around <https://bugs.gnu.org/22138>.
400 (add-after 'install 'wrap-executable
401 (lambda* (#:key inputs outputs #:allow-other-keys)
402 (let ((out (assoc-ref outputs "out"))
403 (qt '("qtbase" "qtsvg")))
404 (wrap-program (string-append out "/bin/krita")
405 `("QT_PLUGIN_PATH" ":" prefix
406 ,(map (lambda (label)
407 (string-append (assoc-ref inputs label)
408 "/lib/qt5/plugins/"))
409 qt)))
410 #t))))))
411 (native-inputs
412 `(("curl" ,curl)
413 ("eigen" ,eigen)
414 ("extra-cmake-modules" ,extra-cmake-modules)
415 ("gettext-minimal" ,gettext-minimal)
416 ("kitemmodels" ,kitemmodels)
417 ("pkg-config" ,pkg-config)
418 ("qwt" ,qwt)
419 ("vc" ,vc)))
420 (inputs
421 `(("boost" ,boost)
422 ("exiv2" ,exiv2)
423 ("fftw" ,fftw)
424 ("gsl" ,gsl)
425 ("ilmbase" ,ilmbase)
426 ("karchive" ,karchive)
427 ("kcompletion" ,kcompletion)
428 ("kconfig" ,kconfig)
429 ("kcoreaddons" ,kcoreaddons)
430 ("kcrash" ,kcrash)
431 ("kguiaddons" ,kguiaddons)
432 ("ki18n" ,ki18n)
433 ("kiconthemes" ,kiconthemes)
434 ("kio" ,kio)
435 ("kitemviews" ,kitemviews)
436 ("kwidgetsaddons" ,kwidgetsaddons)
437 ("kwindowsystem" ,kwindowsystem)
438 ("kxmlgui" ,kxmlgui)
439 ("lcms" ,lcms)
440 ("libjpeg-turbo" ,libjpeg-turbo)
441 ("libpng" ,libpng)
442 ("libraw" ,libraw-0.18)
443 ("libtiff" ,libtiff)
444 ("libx11" ,libx11)
445 ("libxcb" ,libxcb)
446 ("libxi" ,libxi)
447 ("openexr" ,openexr)
448 ("perl" ,perl)
449 ("poppler-qt5" ,poppler-qt5)
450 ("qtbase" ,qtbase-for-krita)
451 ("qtdeclarative" ,qtdeclarative)
452 ("qtmultimedia" ,qtmultimedia)
453 ("qtsvg" ,qtsvg)
454 ("qtx11extras" ,qtx11extras)
455 ("quazip" ,quazip)
456 ("zlib" ,zlib)))
457 (home-page "https://krita.org")
458 (synopsis "Digital painting application")
459 (description
460 "Krita is a professional painting tool designed for concept artists,
461 illustrators, matte and texture artists, and the VFX industry. Notable
462 features include brush stabilizers, brush engines and wrap-around mode.")
463 (license license:gpl2+)))
464
465 (define-public libkomparediff2
466 (package
467 (name "libkomparediff2")
468 (version "20.04.1")
469 (source
470 (origin
471 (method url-fetch)
472 (uri (string-append "mirror://kde/stable/release-service/" version
473 "/src/libkomparediff2-" version ".tar.xz"))
474 (sha256
475 (base32 "0m8m7sgpf2f4nxpaaymyvihlk0pcyblyd99mcbibrnyr5kzkzzdc"))))
476 (native-inputs
477 `(("extra-cmake-modules" ,extra-cmake-modules)
478 ("pkg-config" ,pkg-config)))
479 (inputs
480 `(("kcodecs" ,kcodecs)
481 ("kconfig" ,kconfig)
482 ("kcoreaddons" ,kcoreaddons)
483 ("ki18n" ,ki18n)
484 ("kio" ,kio)
485 ("kxmlgui" ,kxmlgui)
486 ("qtbase" ,qtbase)))
487 (build-system cmake-build-system)
488 (home-page "https://kde.org")
489 (synopsis "Library to compare files and strings, used in Kompare and KDevelop")
490 (description "Libkomparediff2 is a library to work with diffs and patches,
491 used in KDE development tools Kompare and KDevelop.")
492
493 ;; GPL, some files are also licensed under LGPL or BSD, see COPYING in the
494 ;; source archive
495 (license (list license:gpl2+ license:lgpl2.0+ license:bsd-3))))
496
497 (define-public qca
498 (package
499 (name "qca")
500 (version "2.3.0")
501 (source
502 (origin
503 (method url-fetch)
504 (uri (string-append "mirror://kde/stable/qca/" version
505 "/qca-" version ".tar.xz"))
506 (sha256
507 (base32
508 "1mrj748yz1grgzmfbmffgjkpcqiaj1l3m4pbddwcj7dnl50yys0x"))))
509 (build-system cmake-build-system)
510 (native-inputs
511 `(("pkg-config" ,pkg-config)))
512 (inputs
513 `(("openssl" ,openssl)
514 ("qtbase" ,qtbase)))
515 (home-page "https://userbase.kde.org/QCA")
516 (synopsis "Libraries for the Qt Cryptographic Architecture")
517 (description "The Qt Cryptographic Architecture (QCA) provides a
518 straightforward and cross-platform API for a range of cryptographic features,
519 including SSL/TLS, X.509 certificates, SASL, OpenPGP, S/MIME CMS, and smart
520 cards.")
521 (license license:lgpl2.1)))
522
523 (define-public kpmcore
524 (package
525 (name "kpmcore")
526 (version "4.1.0")
527 (source (origin
528 (method url-fetch)
529 (uri (string-append
530 "mirror://kde/stable/kpmcore"
531 "/" version "/src/"
532 name "-" version ".tar.xz"))
533 (sha256
534 (base32
535 "0jsig7algmab9h0fb09my0axjqzw83zgscamhzl8931lribs6idm"))))
536 (build-system cmake-build-system)
537 (native-inputs
538 `(("extra-cmake-modules" ,extra-cmake-modules)
539 ("pkg-config" ,pkg-config)))
540 (inputs
541 `(("kauth" ,kauth)
542 ("kcoreaddons" ,kcoreaddons)
543 ("ki18n" ,ki18n)
544 ("kwidgetsaddons" ,kwidgetsaddons)
545 ("qtbase" ,qtbase)
546 ("qca" ,qca)
547 ("util-linux" ,util-linux "lib")))
548 (home-page "https://community.kde.org/Frameworks")
549 (synopsis "Library for managing partitions")
550 (description "Library for managing partitions.")
551 (license license:gpl3+)))
552
553 (define-public snorenotify
554 (package
555 (name "snorenotify")
556 (version "0.7.0")
557 (source
558 (origin
559 (method url-fetch)
560 (uri (string-append "mirror://kde/stable/snorenotify/"
561 version "/src/snorenotify-" version ".tar.xz"))
562 (sha256
563 (base32
564 "0jz6ivk90h7iwgyxar7xzzj8yvzn6s1my6cqs9bdnwqswfk1nhbd"))))
565 (build-system cmake-build-system)
566 (arguments
567 `(#:tests? #f)) ; both tests fail, require display
568 (inputs
569 `(("qtbase" ,qtbase)))
570 (native-inputs
571 `(("extra-cmake-modules" ,extra-cmake-modules)
572 ("qttools" ,qttools)))
573 (home-page "https://techbase.kde.org/Projects/Snorenotify")
574 (synopsis "Qt notification framework")
575 (description "Snorenotify is a multi platform Qt notification framework.
576 Using a plugin system it is possible to create notifications with many
577 different notification systems.")
578 (license license:lgpl3)))
579
580 (define-public kdeconnect
581 (package
582 (name "kdeconnect")
583 (version "20.04.2")
584 (source
585 (origin
586 (method url-fetch)
587 (uri (string-append "mirror://kde/stable/release-service/"
588 version "/src/kdeconnect-kde-"
589 version ".tar.xz"))
590 (sha256
591 (base32
592 "0yq3afbbcc9gmlcachvh3xz3gdj57092fpagp36l5knw8gr0d9ip"))))
593 (build-system qt-build-system)
594 (arguments
595 `(#:configure-flags '("-DBUILD_TESTING=ON"
596 "-DKDE_INSTALL_LIBEXECDIR=libexec")
597 #:phases (modify-phases %standard-phases
598 (add-after 'set-paths 'extend-CPLUS_INCLUDE_PATH
599 (lambda* (#:key inputs #:allow-other-keys)
600 ;; FIXME: <kcmutils_version.h> is not found during one
601 ;; of the compilation steps without this hack.
602 (setenv "CPLUS_INCLUDE_PATH"
603 (string-append (assoc-ref inputs "kcmutils")
604 "/include/KF5:"
605 (or (getenv "CPLUS_INCLUDE_PATH")
606 "")))
607 #t)))
608 #:tests? #f)) ; tests fail hard in our build environment
609 (native-inputs
610 `(("extra-cmake-modules" ,extra-cmake-modules)
611 ("kdoctools" ,kdoctools)
612 ("libxtst" ,libxtst)
613 ("pkg-config" ,pkg-config)
614 ("python" ,python-wrapper)))
615 (inputs
616 `(("kcmutils" ,kcmutils)
617 ("kconfigwidgets" ,kconfigwidgets)
618 ("kdbusaddons" ,kdbusaddons)
619 ("ki18n" ,ki18n)
620 ("kiconthemes" ,kiconthemes)
621 ("kio" ,kio)
622 ("kirigami" ,kirigami)
623 ("knotifications" ,knotifications)
624 ("kpeople" ,kpeople)
625 ("kpeoplevcard" ,kpeoplevcard)
626 ("kwayland" ,kwayland)
627 ("libfakekey" ,libfakekey)
628 ("pulseaudio-qt" ,pulseaudio-qt)
629 ("qca" ,qca)
630 ("qtbase" ,qtbase)
631 ("qtdeclarative" ,qtdeclarative)
632 ("qtmultimedia" ,qtmultimedia)
633 ("qtx11extras" ,qtx11extras)))
634 (home-page "https://community.kde.org/KDEConnect")
635 (synopsis "Enable your devices to communicate with each other")
636 (description "KDE Connect is a project that enables all your devices to
637 communicate with each other. Here's a few things KDE Connect can do:
638 @enumerate
639 @item Receive your phone notifications on your desktop computer and reply to messages
640 @item Control music playing on your desktop from your phone
641 @item Use your phone as a remote control for your desktop
642 @item Run predefined commands on your PC from connected devices
643 @item Check your phones battery level from the desktop
644 @item Ring your phone to help finding it
645 @item Share files and links between devices
646 @item Browse your phone from the desktop
647 @item Control the desktop's volume from the phone
648 @end enumerate")
649 (properties `((upstream-name . "kdeconnect-kde")))
650 (license (list license:gpl2 license:gpl3)))) ; dual licensed
651
652 (define-public kqtquickcharts
653 (package
654 (name "kqtquickcharts")
655 (version "20.04.1")
656 (source
657 (origin
658 (method url-fetch)
659 (uri (string-append "mirror://kde/stable/release-service/"
660 version "/src/kqtquickcharts-" version ".tar.xz"))
661 (sha256
662 (base32
663 "1wxp35mf9zlpgzi4msdl86b2krdq2ipqw371gyx23r7j84vdyxi3"))))
664 (build-system cmake-build-system)
665 (native-inputs
666 `(("extra-cmake-modules" ,extra-cmake-modules)))
667 (inputs
668 `(("qtbase" ,qtbase)
669 ("qtdeclarative" ,qtdeclarative)))
670 (home-page "https://phabricator.kde.org/source/kqtquickcharts/")
671 (synopsis "Interactive charts for Qt Quick")
672 (description
673 "Kqtquickcharts is a QtQuick plugin to render beautiful and interactive
674 charts.")
675 (license license:lgpl2.1+)))
676
677 (define-public kcachegrind
678 (package
679 (name "kcachegrind")
680 (version "20.04.1")
681 (source (origin
682 (method url-fetch)
683 (uri (string-append "mirror://kde/stable/release-service/" version
684 "/src/kcachegrind-" version ".tar.xz"))
685 (sha256
686 (base32
687 "0fx17s6fj1pxl1mgfrqhchk8sihkbji1x8y3nhb1r0971wzd1nsc"))))
688 (build-system cmake-build-system)
689 (native-inputs
690 `(("extra-cmake-modules" ,extra-cmake-modules)
691 ("perl" ,perl)
692 ("python" ,python)
693 ("qttools" ,qttools)
694 ("kdoctools" ,kdoctools)))
695 (inputs
696 `(("qtbase" ,qtbase)
697 ("karchive" ,karchive)
698 ("ki18n" ,ki18n)
699 ("kio" ,kio)
700 ("kdbusaddons" ,kdbusaddons)))
701 ;; Note: The 'hotshot2calltree' and 'pprof2calltree' scripts depend on
702 ;; Python and PHP, respectively. These are optional and we ignore them
703 ;; for now.
704 (home-page "https://kcachegrind.github.io/html/Home.html")
705 (synopsis "Visualize profiles produces by Valgrind's Cachegrind tool")
706 (description
707 "The data files generated by the Callgrind of Valgrind, an application
708 profiler, can be loaded into KCachegrind for browsing the performance results.
709 There is also a command-line tool to get ASCII reports from data files without
710 the need to use KCachegrind.
711
712 The format of Callgrind output is documented. With conversion scripts,
713 KCachegrind is able to visualize output of other profilers like OProfile, a
714 system-wide profiler for Linux using statistical sampling with hardware
715 performance counters. There also exist converters for profiling output of
716 Python, PHP, and Perl.")
717 (license license:gpl2)))
718
719 (define-public libkdegames
720 (package
721 (name "libkdegames")
722 (version "20.04.1")
723 (source
724 (origin
725 (method url-fetch)
726 (uri (string-append "mirror://kde/stable/release-service/" version
727 "/src/libkdegames-" version ".tar.xz"))
728 (sha256
729 (base32 "1xsrrvhwjwi5aajcaxydmzc69i4yx6shs8ly8vr85njc188ycg13"))))
730 (build-system qt-build-system)
731 (native-inputs
732 `(("extra-cmake-modules" ,extra-cmake-modules)))
733 (inputs
734 `(("karchive" ,karchive)
735 ("kbookmarks" ,kbookmarks)
736 ("kcodecs" ,kcodecs)
737 ("kcompletion" ,kcompletion)
738 ("kconfigwidgets" ,kconfigwidgets)
739 ("kcrash" ,kcrash)
740 ("kdbusaddons" ,kdbusaddons)
741 ("kdeclarative" ,kdeclarative)
742 ("kdnssd" ,kdnssd)
743 ("kglobalaccel" ,kglobalaccel)
744 ("kguiaddons" ,kguiaddons)
745 ("ki18n" ,ki18n)
746 ("kiconthemes" ,kiconthemes)
747 ;("kio" ,kio)
748 ("kitemviews" ,kitemviews)
749 ("kjobwidgets" ,kjobwidgets)
750 ("knewstuff" ,knewstuff)
751 ("kservice" ,kservice)
752 ("ktextwidgets" ,ktextwidgets)
753 ("kwidgetsaddons" ,kwidgetsaddons)
754 ("kxmlgui" ,kxmlgui)
755 ("libsndfile" ,libsndfile)
756 ("openal" ,openal)
757 ("qtbase" ,qtbase)
758 ("qtdeclarative" ,qtdeclarative)
759 ("qtsvg" ,qtsvg)))
760 (home-page "https://games.kde.org/")
761 (synopsis "Runtime library for kdegames")
762 (description "Runtime library for kdegames")
763 (license (list license:gpl2+ license:fdl1.2+))))
764
765 (define-public zeroconf-ioslave
766 (package
767 (name "zeroconf-ioslave")
768 (version "20.04.1")
769 (source
770 (origin
771 (method url-fetch)
772 (uri (string-append "mirror://kde/stable/release-service/" version
773 "/src/zeroconf-ioslave-" version ".tar.xz"))
774 (sha256
775 (base32 "1qck5jyc4psslpibhki8sz8aj0hsnx8z791vzyn10lmdzn71vx8c"))))
776 (build-system qt-build-system)
777 (native-inputs
778 `(("extra-cmake-modules" ,extra-cmake-modules)))
779 (inputs
780 `(("kdbusaddons" ,kdbusaddons)
781 ("kdnssd" ,kdnssd)
782 ("ki18n" ,ki18n)
783 ("kio" ,kio)
784 ("qtbase" ,qtbase)))
785 (home-page "https://kde.org/applications/internet/org.kde.zeroconf_ioslave")
786 (synopsis "DNS-SD Service Discovery Monitor")
787 (description "Adds an entry to Dolphin's Network page to show local
788 services such as printers which advertise themselves with DNSSD (called Avahi
789 or Bonjour by other projects).")
790 (license ;; GPL for programs, LGPL for libraries, FDL for documentation
791 (list license:gpl2+ license:lgpl2.0+ license:fdl1.2+))))