gnu: orfm: Update to 0.4.1.
[jackhill/guix/guix.git] / gnu / packages / gimp.scm
1 ;;; GNU Guix --- Functional package management for GNU
2 ;;; Copyright © 2014, 2015 Ludovic Courtès <ludo@gnu.org>
3 ;;;
4 ;;; This file is part of GNU Guix.
5 ;;;
6 ;;; GNU Guix is free software; you can redistribute it and/or modify it
7 ;;; under the terms of the GNU General Public License as published by
8 ;;; the Free Software Foundation; either version 3 of the License, or (at
9 ;;; your option) any later version.
10 ;;;
11 ;;; GNU Guix is distributed in the hope that it will be useful, but
12 ;;; WITHOUT ANY WARRANTY; without even the implied warranty of
13 ;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
14 ;;; GNU General Public License for more details.
15 ;;;
16 ;;; You should have received a copy of the GNU General Public License
17 ;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
18
19 (define-module (gnu packages gimp)
20 #:use-module (guix packages)
21 #:use-module (guix download)
22 #:use-module ((guix licenses) #:prefix license:)
23 #:use-module (guix build-system gnu)
24 #:use-module (guix build-system glib-or-gtk)
25 #:use-module (gnu packages pkg-config)
26 #:use-module (gnu packages glib)
27 #:use-module (gnu packages gtk)
28 #:use-module (gnu packages gnome)
29 #:use-module (gnu packages image)
30 #:use-module ((gnu packages ghostscript)
31 #:select (lcms))
32 #:use-module (gnu packages compression)
33 #:use-module (gnu packages xml)
34 #:use-module (gnu packages photo)
35 #:use-module (gnu packages python)
36 #:use-module (gnu packages xorg)
37 #:use-module (gnu packages imagemagick))
38
39 (define-public babl
40 (package
41 (name "babl")
42 (version "0.1.10")
43 (source (origin
44 (method url-fetch)
45 (uri (list (string-append "http://ftp.gtk.org/pub/babl/0.1/babl-"
46 version ".tar.bz2")
47 (string-append "ftp://ftp.gtk.org/pub/babl/0.1/babl-"
48 version ".tar.bz2")))
49 (sha256
50 (base32
51 "1x2mb7zfbvk9d0a7h5cpdff9hhjsadxvqml2jay2bpf7x9nc6gwl"))))
52 (build-system gnu-build-system)
53 (home-page "http://gegl.org/babl/")
54 (synopsis "Image pixel format conversion library")
55 (description
56 "Babl is a dynamic, any to any, pixel format translation library.
57 It allows converting between different methods of storing pixels known as
58 pixel formats that have with different bitdepths and other data
59 representations, color models and component permutations.
60
61 A vocabulary to formulate new pixel formats from existing primitives is
62 provided as well as the framework to add new color models and data types.")
63 (license license:lgpl3+)))
64
65 (define-public gegl
66 (package
67 (name "gegl")
68 (version "0.2.0")
69 (source (origin
70 (method url-fetch)
71 (uri (list (string-append "http://download.gimp.org/pub/gegl/"
72 (string-take version 3)
73 "/" name "-" version ".tar.bz2")))
74 (sha256
75 (base32
76 "09nlv06li9nrn74ifpm7223mxpg0s7cii702z72cpbwrjh6nlbnz"))))
77 (build-system gnu-build-system)
78 (arguments
79 `(;; More than just the one test disabled below now fails; disable them
80 ;; all according to the rationale given below.
81 #:tests? #f
82 #:phases
83 (alist-cons-before
84 'build 'pre-build
85 (lambda _
86 ;; This test program seems to crash on exit. Specifically, whilst
87 ;; g_object_unreffing bufferA and bufferB - This seems to be a bug
88 ;; in the destructor. This is just a test program so will not have
89 ;; any wider effect, although might be hiding another problem.
90 ;; According to advice received on irc.gimp.org#gegl although 0.2.0
91 ;; is the latest released version, any bug reports against it will
92 ;; be ignored. So we are on our own.
93 (substitute* "tools/img_cmp.c"
94 (("g_object_unref \\(buffer.\\);") ""))
95
96 (substitute* "tests/compositions/Makefile"
97 (("/bin/sh") (which "bash"))))
98 %standard-phases)))
99 (inputs
100 `(("babl" ,babl)
101 ("glib" ,glib)
102 ("cairo" ,cairo)
103 ("pango" ,pango)
104 ("libpng" ,libpng)
105 ("libjpeg" ,libjpeg-8)))
106 (native-inputs
107 `(("pkg-config" ,pkg-config)
108 ("glib" ,glib "bin") ; for gtester
109 ("intltool" ,intltool)))
110 (home-page "http://gegl.org")
111 (synopsis "Graph based image processing framework")
112 (description "GEGL (Generic Graphics Library) provides infrastructure to
113 do demand based cached non destructive image editing on larger than RAM
114 buffers.")
115 ;; The library itself is licensed under LGPL while the sample commandline
116 ;; application and GUI binary gegl is licensed under GPL.
117 (license (list license:lgpl3+ license:gpl3+))))
118
119 (define-public gimp
120 (package
121 (name "gimp")
122 (version "2.8.14")
123 (source (origin
124 (method url-fetch)
125 (uri (string-append "http://download.gimp.org/pub/gimp/v2.8/gimp-"
126 version ".tar.bz2"))
127 (sha256
128 (base32
129 "0bdj0l7a94jqhjnj40m9rqaf622wj905iximivb55iy98639aanq"))))
130 (build-system gnu-build-system)
131 (inputs
132 `(("babl" ,babl)
133 ("glib" ,glib)
134 ("libtiff" ,libtiff)
135 ("libjpeg" ,libjpeg-8)
136 ("atk" ,atk)
137 ("gtk+" ,gtk+-2)
138 ("exif" ,libexif) ;optional, EXIF + XMP support
139 ("lcms" ,lcms) ;optional, color management
140 ("librsvg" ,librsvg) ;optional, SVG support
141 ("python" ,python-2) ;optional, Python support
142 ("python2-pygtk" ,python2-pygtk) ;optional, Python support
143 ("gegl" ,gegl)))
144 (native-inputs
145 `(("pkg-config" ,pkg-config)
146 ("intltool" ,intltool)))
147 (home-page "http://gimp.org")
148 (synopsis "GNU Image Manipulation Program")
149 (description
150 "GIMP is an application for image manipulation tasks such as photo
151 retouching, composition and authoring. It supports all common image formats
152 as well as specialized ones. It features a highly customizable interface
153 that is extensible via a plugin system.")
154 (license license:gpl3+))) ; some files are lgplv3