gnu: Rename module gnutls to tls.
[jackhill/guix/guix.git] / gnu / packages / wget.scm
1 ;;; GNU Guix --- Functional package management for GNU
2 ;;; Copyright © 2012 Nikita Karetnikov <nikita@karetnikov.org>
3 ;;; Copyright © 2014, 2015 Ludovic Courtès <ludo@gnu.org>
4 ;;;
5 ;;; This file is part of GNU Guix.
6 ;;;
7 ;;; GNU Guix is free software; you can redistribute it and/or modify it
8 ;;; under the terms of the GNU General Public License as published by
9 ;;; the Free Software Foundation; either version 3 of the License, or (at
10 ;;; your option) any later version.
11 ;;;
12 ;;; GNU Guix is distributed in the hope that it will be useful, but
13 ;;; WITHOUT ANY WARRANTY; without even the implied warranty of
14 ;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
15 ;;; GNU General Public License for more details.
16 ;;;
17 ;;; You should have received a copy of the GNU General Public License
18 ;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
19
20 (define-module (gnu packages wget)
21 #:use-module (guix licenses)
22 #:use-module (gnu packages libidn)
23 #:use-module (gnu packages python)
24 #:use-module (gnu packages perl)
25 #:use-module (gnu packages web)
26 #:use-module (gnu packages pkg-config)
27 #:use-module (gnu packages tls)
28 #:use-module (guix packages)
29 #:use-module (guix download)
30 #:use-module (guix build-system gnu))
31
32 (define-public wget
33 (package
34 (name "wget")
35 (version "1.16.3")
36 (source
37 (origin
38 (method url-fetch)
39 (uri (string-append "mirror://gnu/wget/wget-"
40 version ".tar.xz"))
41 (sha256
42 (base32
43 "0dzv5xf9qxc2bp4cyifmaghh3h464wbm73xiwcrvckf1ynqbgxv7"))))
44 (build-system gnu-build-system)
45 (inputs
46 `(("gnutls" ,gnutls)
47 ("libidn" ,libidn)
48 ("libpsl" ,libpsl)))
49 (native-inputs
50 `(("pkg-config" ,pkg-config)
51 ("perl" ,perl)
52 ("python" ,python) ;for testenv suite
53 ("perl-http-daemon" ,perl-http-daemon)
54 ("perl-io-socket-ssl" ,perl-io-socket-ssl)))
55 (home-page "http://www.gnu.org/software/wget/")
56 (synopsis "Non-interactive command-line utility for downloading files")
57 (description
58 "GNU Wget is a non-interactive tool for fetching files using the HTTP,
59 HTTPS and FTP protocols. It can resume interrupted downloads, use filename
60 wild cards, supports proxies and cookies, and it can convert absolute links
61 in downloaded documents to relative links.")
62 (license gpl3+))) ; some files are under GPLv2+