gnu: Rename module gnutls to tls.
[jackhill/guix/guix.git] / gnu / packages / weechat.scm
1 ;;; GNU Guix --- Functional package management for GNU
2 ;;; Copyright © 2014 Kevin Lemonnier <lemonnierk@ulrar.net>
3 ;;;
4 ;;; This file is part of GNU Guix.
5 ;;;
6 ;;; GNU Guix is free software; you can redistribute it and/or modify it
7 ;;; under the terms of the GNU General Public License as published by
8 ;;; the Free Software Foundation; either version 3 of the License, or (at
9 ;;; your option) any later version.
10 ;;;
11 ;;; GNU Guix is distributed in the hope that it will be useful, but
12 ;;; WITHOUT ANY WARRANTY; without even the implied warranty of
13 ;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
14 ;;; GNU General Public License for more details.
15 ;;;
16 ;;; You should have received a copy of the GNU General Public License
17 ;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
18
19 ;; TODO: Add ruby
20
21 (define-module (gnu packages weechat)
22 #:use-module (gnu packages ncurses)
23 #:use-module (gnu packages base)
24 #:use-module (gnu packages gettext)
25 #:use-module (gnu packages gnupg)
26 #:use-module (gnu packages file)
27 #:use-module (gnu packages compression)
28 #:use-module (gnu packages lua)
29 #:use-module (gnu packages python)
30 #:use-module (gnu packages perl)
31 #:use-module (gnu packages tcl)
32 #:use-module (gnu packages aspell)
33 #:use-module (gnu packages curl)
34 #:use-module (gnu packages guile)
35 #:use-module (gnu packages openssl)
36 #:use-module (gnu packages cyrus-sasl)
37 #:use-module (gnu packages autogen)
38 #:use-module (gnu packages autotools)
39 #:use-module (gnu packages pkg-config)
40 #:use-module (gnu packages tls)
41 #:use-module (guix packages)
42 #:use-module (guix download)
43 #:use-module (guix build-system gnu)
44 #:use-module ((guix licenses) #:select (gpl3)))
45
46 (define-public weechat
47 (package
48 (name "weechat")
49 (version "1.0")
50 (source (origin
51 (method url-fetch)
52 (uri (string-append "http://weechat.org/files/src/weechat-"
53 version ".tar.gz"))
54 (sha256
55 (base32 "1z17wyrl5fp697qp44srpmzk79w37f5hm1r0krffbmga6sbzdj3x"))))
56 (build-system gnu-build-system)
57 (native-inputs `(("autoconf" ,autoconf)
58 ("pkg-config" ,pkg-config)
59 ("file" ,file)
60 ("autogen" ,autogen)
61 ("automake" ,automake)
62 ("libtool" ,libtool)))
63 (inputs `(("ncurses" ,ncurses)
64 ("diffutils" ,diffutils)
65 ("gettext" ,gnu-gettext)
66 ("libltdl" ,libltdl)
67 ("libgcrypt" ,libgcrypt "out")
68 ("zlib" ,zlib)
69 ("aspell" ,aspell)
70 ("curl" ,curl)
71 ("gnutls" ,gnutls)
72 ("guile" ,guile-2.0)
73 ("openssl" ,openssl)
74 ("cyrus-sasl" ,cyrus-sasl)
75 ("lua" ,lua-5.1)
76 ("python" ,python-2)
77 ("perl" ,perl)
78 ("tcl" ,tcl)))
79 (arguments `(#:configure-flags (list
80 (string-append
81 "--with-tclconfig="
82 (assoc-ref %build-inputs "tcl") "/lib"))
83 #:phases (alist-cons-after
84 'autogen 'fix-file
85 (lambda _
86 (substitute* "configure"
87 (("/usr/bin/file") (which "file"))))
88 (alist-cons-before
89 'configure 'autogen
90 (lambda _
91 (zero? (system* "./autogen.sh")))
92 %standard-phases))))
93 (synopsis "Extensible chat client")
94 (description "WeeChat (Wee Enhanced Environment for Chat) is an
95 Internet Relay Chat client, which is designed to be light and fast.
96 The client uses a curses frontend, and there are remote interfaces
97 for Web, Qt, Android and Emacs. In WeeChat everything can be done
98 with a keyboard, though it also supports mouse. It is customizable
99 and extensible with plugins and scripts.")
100 (home-page "http://www.weechat.org/")
101 (license gpl3)))