gnu: Rename module gnutls to tls.
[jackhill/guix/guix.git] / gnu / packages / ftp.scm
1 ;;; GNU Guix --- Functional package management for GNU
2 ;;; Copyright © 2014, 2015 Ludovic Courtès <ludo@gnu.org>
3 ;;; Copyright © 2015 Andreas Enge <andreas@enge.fr>
4 ;;; Copyright © 2015 Mark H Weaver <mhw@netris.org>
5 ;;;
6 ;;; This file is part of GNU Guix.
7 ;;;
8 ;;; GNU Guix is free software; you can redistribute it and/or modify it
9 ;;; under the terms of the GNU General Public License as published by
10 ;;; the Free Software Foundation; either version 3 of the License, or (at
11 ;;; your option) any later version.
12 ;;;
13 ;;; GNU Guix is distributed in the hope that it will be useful, but
14 ;;; WITHOUT ANY WARRANTY; without even the implied warranty of
15 ;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
16 ;;; GNU General Public License for more details.
17 ;;;
18 ;;; You should have received a copy of the GNU General Public License
19 ;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
20
21 (define-module (gnu packages ftp)
22 #:use-module ((guix licenses) #:select (gpl2+ gpl3+ clarified-artistic))
23 #:use-module (guix build-system gnu)
24 #:use-module (guix download)
25 #:use-module (guix packages)
26 #:use-module (gnu packages)
27 #:use-module (gnu packages ncurses)
28 #:use-module (gnu packages readline)
29 #:use-module (gnu packages pkg-config)
30 #:use-module (gnu packages tls)
31 #:use-module (gnu packages compression))
32
33 (define-public lftp
34 (package
35 (name "lftp")
36 (version "4.6.1")
37 (source (origin
38 (method url-fetch)
39 (uri (list (string-append "http://lftp.yar.ru/ftp/lftp-"
40 version ".tar.xz")
41 (string-append "http://lftp.yar.ru/ftp/old/lftp-"
42 version ".tar.xz")))
43 (sha256
44 (base32
45 "1grmp8zg7cjgjinz66mrh53whigkqzl90nlxj05hapnhk3ns3vni"))
46 (patches
47 (list (search-patch
48 "lftp-dont-save-unknown-host-fingerprint.patch")))))
49 (build-system gnu-build-system)
50 (native-inputs
51 `(("pkg-config" ,pkg-config)))
52 (inputs
53 `(("zlib" ,zlib)
54 ("readline" ,readline)
55 ("gnutls" ,gnutls)))
56 (home-page "http://lftp.yar.ru/")
57 (synopsis "Command-line file transfer program")
58 (description
59 "LFTP is a sophisticated FTP/HTTP client, and a file transfer program
60 supporting a number of network protocols. Like Bash, it has job control and
61 uses the Readline library for input. It has bookmarks, a built-in mirror
62 command, and can transfer several files in parallel. It was designed with
63 reliability in mind.")
64 (license gpl3+)))
65
66 (define-public ncftp
67 (package
68 (name "ncftp")
69 (version "3.2.5")
70 (source (origin
71 (method url-fetch)
72 (uri (string-append "ftp://ftp.ncftp.com/ncftp/ncftp-"
73 version "-src.tar.bz2"))
74 (sha256
75 (base32
76 "0hlx12i0lwi99qsrx7nccf4nvwjj2gych4yks5y179b1ax0y5sxl"))
77 (modules '((guix build utils)))
78 (snippet
79 '(begin
80 ;; Use the right 'rm' and 'ls'.
81 (substitute* (cons "configure"
82 (find-files "."
83 "^(Makefile\\.in|.*\\.sh)$"))
84 (("/bin/(rm|ls)" _ command)
85 command))
86
87 ;; This is free software, avoid any confusion.
88 (substitute* (find-files "." "\\.c$")
89 (("a freeware program")
90 "free software"))))))
91 (build-system gnu-build-system)
92 (arguments
93 '(#:phases (alist-replace
94 'configure
95 (lambda* (#:key outputs #:allow-other-keys)
96 ;; This is an old 'configure' script that doesn't
97 ;; understand variables passed as arguments.
98 (let ((out (assoc-ref outputs "out")))
99 (setenv "CONFIG_SHELL" (which "sh"))
100 (setenv "SHELL" (which "sh"))
101 (zero? (system* "./configure"
102 (string-append "--prefix=" out)))))
103 %standard-phases)
104 #:tests? #f)) ;there are no tests
105 (inputs `(("ncurses" ,ncurses)))
106 (home-page "http://www.ncftp.com/ncftp/")
107 (synopsis "Command-line File Transfer Protocol (FTP) client")
108 (description
109 "NcFTP Client (or just NcFTP) is a set of command-line programs to access
110 File Transfer Protocol (FTP) servers. This includes 'ncftp', an interactive
111 FTP browser, as well as non-interactive commands such as 'ncftpput' and
112 'ncftpget'.")
113 (license clarified-artistic)))
114
115
116 (define-public weex
117 (package
118 (name "weex")
119 (version "2.6.1.5")
120 (source
121 (origin
122 (method url-fetch)
123 (uri
124 (string-append "mirror://sourceforge/weex/weex/" version
125 "/weex-" version ".tar.gz"))
126 (sha256
127 (base32
128 "0f5cj5p852wkm24mzy2sxgxyahv2p9rk4wlq21j310pi7wlhgwyl"))
129 (patches (list (search-patch "weex-vacopy.patch")))))
130 (build-system gnu-build-system)
131 (arguments
132 `(#:phases
133 (alist-replace 'configure
134 ;; configure does not work followed by both "SHELL=..." and
135 ;; "CONFIG_SHELL=..."; set environment variables instead
136 (lambda* (#:key outputs #:allow-other-keys)
137 (let* ((out (assoc-ref outputs "out"))
138 (bash (which "bash")))
139 (setenv "SHELL" bash)
140 (setenv "CONFIG_SHELL" bash)
141 (zero? (system* bash "./configure"
142 (string-append "--prefix=" out)))))
143 %standard-phases)))
144 (home-page "http://weex.sourceforge.net/")
145 (synopsis "Non-interactive client for FTP synchronization")
146 (description
147 "Weex is a utility designed to automate the task of remotely
148 maintaining a web page or other FTP archive. It synchronizes a set of
149 local files to a remote server by performing uploads and remote deletes
150 as required.")
151 (license gpl2+)))