Merge branch 'staging'
[jackhill/guix/guix.git] / gnu / packages / algebra.scm
1 ;;; GNU Guix --- Functional package management for GNU
2 ;;; Copyright © 2012, 2013, 2014, 2015, 2016, 2017 Andreas Enge <andreas@enge.fr>
3 ;;; Copyright © 2013, 2015, 2017, 2018 Ludovic Courtès <ludo@gnu.org>
4 ;;; Copyright © 2016, 2017, 2018 Nicolas Goaziou <mail@nicolasgoaziou.fr>
5 ;;; Copyright © 2014, 2018 Mark H Weaver <mhw@netris.org>
6 ;;; Copyright © 2016, 2018 Ricardo Wurmus <rekado@elephly.net>
7 ;;; Copyright © 2017 Efraim Flashner <efraim@flashner.co.il>
8 ;;; Copyright © 2017, 2018 Tobias Geerinckx-Rice <me@tobias.gr>
9 ;;; Copyright © 2017 Marius Bakke <mbakke@fastmail.com>
10 ;;; Copyright © 2017 Eric Bavier <bavier@member.fsf.org>
11 ;;;
12 ;;; This file is part of GNU Guix.
13 ;;;
14 ;;; GNU Guix is free software; you can redistribute it and/or modify it
15 ;;; under the terms of the GNU General Public License as published by
16 ;;; the Free Software Foundation; either version 3 of the License, or (at
17 ;;; your option) any later version.
18 ;;;
19 ;;; GNU Guix is distributed in the hope that it will be useful, but
20 ;;; WITHOUT ANY WARRANTY; without even the implied warranty of
21 ;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
22 ;;; GNU General Public License for more details.
23 ;;;
24 ;;; You should have received a copy of the GNU General Public License
25 ;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
26
27 (define-module (gnu packages algebra)
28 #:use-module (gnu packages)
29 #:use-module (gnu packages autotools)
30 #:use-module (gnu packages check)
31 #:use-module (gnu packages compression)
32 #:use-module (gnu packages cpp)
33 #:use-module (gnu packages documentation)
34 #:use-module (gnu packages ed)
35 #:use-module (gnu packages flex)
36 #:use-module (gnu packages fltk)
37 #:use-module (gnu packages gl)
38 #:use-module (gnu packages graphviz)
39 #:use-module (gnu packages image)
40 #:use-module (gnu packages java)
41 #:use-module (gnu packages maths)
42 #:use-module (gnu packages mpi)
43 #:use-module (gnu packages multiprecision)
44 #:use-module (gnu packages perl)
45 #:use-module (gnu packages python)
46 #:use-module (gnu packages readline)
47 #:use-module (gnu packages shells)
48 #:use-module (gnu packages tex)
49 #:use-module (gnu packages texinfo)
50 #:use-module (gnu packages xiph)
51 #:use-module (gnu packages xorg)
52 #:use-module (guix build-system ant)
53 #:use-module (guix build-system gnu)
54 #:use-module (guix build-system cmake)
55 #:use-module (guix download)
56 #:use-module (guix git-download)
57 #:use-module ((guix licenses) #:prefix license:)
58 #:use-module (guix packages)
59 #:use-module (guix utils))
60
61
62 (define-public mpfrcx
63 (package
64 (name "mpfrcx")
65 (version "0.5")
66 (source (origin
67 (method url-fetch)
68 (uri (string-append
69 "http://www.multiprecision.org/downloads/mpfrcx-"
70 version ".tar.gz"))
71 (sha256
72 (base32
73 "1s968480ymv6w0rnvfp9mxvx98hvi29fkvw8nk4ggzc6azxgwybs"))))
74 (build-system gnu-build-system)
75 (propagated-inputs
76 `(("gmp" ,gmp)
77 ("mpfr" ,mpfr)
78 ("mpc" ,mpc))) ; Header files are included by mpfrcx.h.
79 (synopsis "Arithmetic of polynomials over arbitrary precision numbers")
80 (description
81 "Mpfrcx is a library for the arithmetic of univariate polynomials over
82 arbitrary precision real (mpfr) or complex (mpc) numbers, without control
83 on the rounding. For the time being, only the few functions needed to
84 implement the floating point approach to complex multiplication are
85 implemented. On the other hand, these comprise asymptotically fast
86 multiplication routines such as Toom–Cook and the FFT.")
87 (license license:lgpl3+)
88 (home-page "http://mpfrcx.multiprecision.org/")))
89
90 (define-public cm
91 (package
92 (name "cm")
93 (version "0.3")
94 (source (origin
95 (method url-fetch)
96 (uri (string-append
97 "http://www.multiprecision.org/cm/download/cm-"
98 version ".tar.gz"))
99 (sha256
100 (base32
101 "1nf5kr0nqmhbzrsrinky18z0ighjpsmb5cr8zyg8jf04bfbyrfmc"))))
102 (build-system gnu-build-system)
103 (propagated-inputs
104 `(("mpfrcx" ,mpfrcx)
105 ("zlib" ,zlib))) ; Header files included from cm_common.h.
106 (inputs
107 `(("pari-gp" ,pari-gp)))
108 (synopsis "CM constructions for elliptic curves")
109 (description
110 "The CM software implements the construction of ring class fields of
111 imaginary quadratic number fields and of elliptic curves with complex
112 multiplication via floating point approximations. It consists of libraries
113 that can be called from within a C program and of executable command
114 line applications.")
115 (license license:gpl3+)
116 (home-page "http://cm.multiprecision.org/")))
117
118 (define-public fplll
119 (package
120 (name "fplll")
121 (version "4.0.4")
122 (source (origin
123 (method url-fetch)
124 (uri (string-append
125 "http://perso.ens-lyon.fr/damien.stehle/fplll/libfplll-"
126 version ".tar.gz"))
127 (sha256 (base32
128 "1cbiby7ykis4z84swclpysrljmqhfcllpkcbll1m08rzskgb1a6b"))))
129 (build-system gnu-build-system)
130 (inputs `(("gmp" ,gmp)
131 ("mpfr" ,mpfr)))
132 (synopsis "Library for LLL-reduction of euclidean lattices")
133 (description
134 "fplll LLL-reduces euclidean lattices. Since version 3, it can also
135 solve the shortest vector problem.")
136 (license license:lgpl2.1+)
137 (home-page "http://perso.ens-lyon.fr/damien.stehle/fplll/")))
138
139 (define-public pari-gp
140 (package
141 (name "pari-gp")
142 (version "2.11.0")
143 (source (origin
144 (method url-fetch)
145 (uri (string-append
146 "https://pari.math.u-bordeaux.fr/pub/pari/unix/pari-"
147 version ".tar.gz"))
148 (sha256
149 (base32
150 "18f9yj8ffn3dxignbxj1x36771zbxy4js0r18mv6831ymb6cld9q"))))
151 (build-system gnu-build-system)
152 (native-inputs `(("texlive" ,texlive-tiny)))
153 (inputs `(("gmp" ,gmp)
154 ("libx11" ,libx11)
155 ("perl" ,perl)
156 ("readline" ,readline)))
157 (arguments
158 '(#:make-flags '("all")
159 #:test-target "dobench"
160 #:phases (modify-phases %standard-phases
161 (replace 'configure
162 (lambda* (#:key outputs #:allow-other-keys)
163 (let ((out (assoc-ref outputs "out")))
164 (zero?
165 (system* "./Configure"
166 (string-append "--prefix=" out)))))))))
167 (synopsis "PARI/GP, a computer algebra system for number theory")
168 (description
169 "PARI/GP is a widely used computer algebra system designed for fast
170 computations in number theory (factorisations, algebraic number theory,
171 elliptic curves...), but it also contains a large number of other useful
172 functions to compute with mathematical entities such as matrices,
173 polynomials, power series, algebraic numbers, etc., and a lot of
174 transcendental functions.
175 PARI is also available as a C library to allow for faster computations.")
176 (license license:gpl2+)
177 (home-page "https://pari.math.u-bordeaux.fr/")))
178
179 (define-public gp2c
180 (package
181 (name "gp2c")
182 (version "0.0.11")
183 (source (origin
184 (method url-fetch)
185 (uri (string-append
186 "https://pari.math.u-bordeaux.fr/pub/pari/GP2C/gp2c-"
187 version ".tar.gz"))
188 (sha256
189 (base32
190 "1z69xj2dpd8yyi8108rz26c50xpv0k2j8qnk0bzy1c5lw3pd1adm"))))
191 (build-system gnu-build-system)
192 (native-inputs `(("perl" ,perl)))
193 (inputs `(("pari-gp" ,pari-gp)))
194 (arguments
195 '(#:configure-flags
196 (list (string-append "--with-paricfg="
197 (assoc-ref %build-inputs "pari-gp")
198 "/lib/pari/pari.cfg"))))
199 (synopsis "PARI/GP, a computer algebra system for number theory")
200 (description
201 "PARI/GP is a widely used computer algebra system designed for fast
202 computations in number theory (factorisations, algebraic number theory,
203 elliptic curves...), but it also contains a large number of other useful
204 functions to compute with mathematical entities such as matrices,
205 polynomials, power series, algebraic numbers, etc., and a lot of
206 transcendental functions.
207 PARI is also available as a C library to allow for faster computations.
208
209 GP2C, the GP to C compiler, translates GP scripts to PARI programs.")
210 (license license:gpl2)
211 (home-page "https://pari.math.u-bordeaux.fr/")))
212
213 (define-public giac-xcas
214 (package
215 (name "giac-xcas")
216 (version "1.4.9-59")
217 (source (origin
218 (method url-fetch)
219 ;; "~parisse/giac" is not used because the maintainer regularly
220 ;; overwrites the release tarball there, introducing a checksum
221 ;; mismatch every time. See
222 ;; <https://www-fourier.ujf-grenoble.fr/~parisse/debian/dists/stable/main/source/README>
223 (uri (string-append "https://www-fourier.ujf-grenoble.fr/"
224 "~parisse/debian/dists/stable/main/"
225 "source/giac_" version ".tar.gz"))
226 (sha256
227 (base32
228 "0dv5p5y6gkrsmz3xa7fw87rjyabwdwk09mqb09kb7gai9n9dgayk"))))
229 (build-system gnu-build-system)
230 (arguments
231 `(#:phases
232 (modify-phases %standard-phases
233 (add-after 'unpack 'patch-bin-cp
234 (lambda _
235 ;; Some Makefiles contain hard-coded "/bin/cp".
236 (substitute* (find-files "doc" "^Makefile")
237 (("/bin/cp") (which "cp")))
238 #t)))))
239 (inputs
240 `(("fltk" ,fltk)
241 ("gmp" ,gmp)
242 ("gsl" ,gsl)
243 ("lapack" ,lapack)
244 ("libao" ,ao)
245 ("libjpeg" ,libjpeg)
246 ("libpng" ,libpng)
247 ("libx11" ,libx11)
248 ("libxinerama" ,libxinerama)
249 ("libxft" ,libxft)
250 ("libxt" ,libxt)
251 ("mesa" ,mesa)
252 ("mpfi" ,mpfi)
253 ("mpfr" ,mpfr)
254 ("ntl" ,ntl)
255 ("perl" ,perl)
256 ("pari-gp" ,pari-gp)
257 ("tcsh" ,tcsh)
258 ("texlive" ,texlive-tiny)))
259 (native-inputs `(("readline" ,readline)))
260 (home-page "https://www-fourier.ujf-grenoble.fr/~parisse/giac.html")
261 (synopsis "Computer algebra system")
262 (description
263 "Giac/Xcas is a computer algebra system. It has a compatibility mode for
264 maple, mupad and the TI89. It is available as a standalone program (graphic
265 or text interfaces) or as a C++ library.")
266 (license license:gpl3+)))
267
268 (define-public flint
269 (package
270 (name "flint")
271 (version "2.5.2")
272 (source (origin
273 (method url-fetch)
274 (uri (string-append
275 "http://flintlib.org/flint-"
276 version ".tar.gz"))
277 (sha256 (base32
278 "11syazv1a8rrnac3wj3hnyhhflpqcmq02q8pqk2m6g2k6h0gxwfb"))
279 (patches (search-patches "flint-ldconfig.patch"))))
280 (build-system gnu-build-system)
281 (propagated-inputs
282 `(("gmp" ,gmp)
283 ("mpfr" ,mpfr))) ; header files from both are included by flint/arith.h
284 (arguments
285 `(#:parallel-tests? #f ; seems to be necessary on arm
286 #:phases
287 (modify-phases %standard-phases
288 (replace 'configure
289 (lambda* (#:key inputs outputs #:allow-other-keys)
290 (let ((out (assoc-ref outputs "out"))
291 (gmp (assoc-ref inputs "gmp"))
292 (mpfr (assoc-ref inputs "mpfr")))
293 ;; do not pass "--enable-fast-install", which makes the
294 ;; homebrew configure process fail
295 (zero? (system*
296 "./configure"
297 (string-append "--prefix=" out)
298 (string-append "--with-gmp=" gmp)
299 (string-append "--with-mpfr=" mpfr)))))))))
300 (synopsis "Fast library for number theory")
301 (description
302 "FLINT is a C library for number theory. It supports arithmetic
303 with numbers, polynomials, power series and matrices over many base
304 rings, including multiprecision integers and rationals, integers
305 modulo n, p-adic numbers, finite fields (prime and non-prime order)
306 and real and complex numbers (via the Arb extension library).
307
308 Operations that can be performed include conversions, arithmetic,
309 GCDs, factoring, solving linear systems, and evaluating special
310 functions. In addition, FLINT provides various low-level routines for
311 fast arithmetic.")
312 (license license:gpl2+)
313 (home-page "http://flintlib.org/")))
314
315 (define-public arb
316 (package
317 (name "arb")
318 (version "2.14.0")
319 (source (origin
320 (method url-fetch)
321 (uri (string-append
322 "https://github.com/fredrik-johansson/arb/archive/"
323 version ".tar.gz"))
324 (file-name (string-append name "-" version ".tar.gz"))
325 (sha256
326 (base32
327 "0ncr27nd20xxi18nj30cvpa6r52v59nq7gbi34x3l4xym3p8mlmx"))))
328 (build-system gnu-build-system)
329 (propagated-inputs
330 `(("flint" ,flint))) ; flint.h is included by arf.h
331 (inputs
332 `(("gmp" ,gmp)
333 ("mpfr" ,mpfr)))
334 (arguments
335 `(#:phases
336 (modify-phases %standard-phases
337 (replace 'configure
338 (lambda* (#:key inputs outputs #:allow-other-keys)
339 (let ((out (assoc-ref outputs "out"))
340 (flint (assoc-ref inputs "flint"))
341 (gmp (assoc-ref inputs "gmp"))
342 (mpfr (assoc-ref inputs "mpfr")))
343 ;; do not pass "--enable-fast-install", which makes the
344 ;; homebrew configure process fail
345 (invoke "./configure"
346 (string-append "--prefix=" out)
347 (string-append "--with-flint=" flint)
348 (string-append "--with-gmp=" gmp)
349 (string-append "--with-mpfr=" mpfr))))))))
350 (synopsis "Arbitrary precision floating-point ball arithmetic")
351 (description
352 "Arb is a C library for arbitrary-precision floating-point ball
353 arithmetic. It supports efficient high-precision computation with
354 polynomials, power series, matrices and special functions over the
355 real and complex numbers, with automatic, rigorous error control.")
356 (license license:lgpl2.1+)
357 (home-page "http://fredrikj.net/arb/")))
358
359 (define-public ntl
360 (package
361 (name "ntl")
362 (version "9.7.0")
363 (source (origin
364 (method url-fetch)
365 (uri (string-append "http://shoup.net/ntl/ntl-"
366 version ".tar.gz"))
367 (sha256 (base32
368 "115frp5flyvw9wghz4zph1b3llmr5nbxk1skgsggckr81fh3gmxq"))))
369 (build-system gnu-build-system)
370 (native-inputs
371 `(("libtool" ,libtool)
372 ("perl" ,perl))) ; for configuration
373 ;; FIXME: Add optional input gf2x once available; then also add
374 ;; configure flag "NTL_GF2X_LIB=on".
375 (inputs
376 `(("gmp" ,gmp)))
377 (arguments
378 `(#:phases
379 (modify-phases %standard-phases
380 (replace 'configure
381 (lambda* (#:key outputs #:allow-other-keys)
382 (chdir "src")
383 (system* "./configure"
384 (string-append "PREFIX=" (assoc-ref outputs "out"))
385 ;; Do not build especially for the build machine.
386 "NATIVE=off"
387 ;; Also do not tune to the build machine.
388 "WIZARD=off"
389 "SHARED=on")
390 #t)))))
391 (synopsis "C++ library for number theory")
392 (description
393 "NTL is a C++ library providing data structures and algorithms
394 for manipulating signed, arbitrary length integers, and for vectors,
395 matrices, and polynomials over the integers and over finite fields.")
396 (license license:gpl2+)
397 (home-page "http://shoup.net/ntl/")))
398
399 (define-public singular
400 (package
401 (name "singular")
402 (version "4.1.1p3")
403 (source
404 (origin
405 (method url-fetch)
406 (uri
407 (string-append "http://www.mathematik.uni-kl.de/ftp/pub/Math/"
408 "Singular/SOURCES/"
409 (string-join
410 (string-split
411 (string-trim-right version #\p
412 0 (1- (string-length version)))
413 #\.) "-")
414 "/singular-" version ".tar.gz"))
415 (sha256 (base32
416 "1qqj9bm9pkzm0iyycpvm8x6s79wws3nq60lz25h8x1q61h3426sm"))))
417 (build-system gnu-build-system)
418 (native-inputs
419 `(("doxygen" ,doxygen)
420 ("graphviz" ,graphviz)
421 ("perl" ,perl)))
422 (inputs
423 `(("cddlib" ,cddlib)
424 ("gmp" ,gmp)
425 ("flint" ,flint)
426 ("mpfr" ,mpfr)
427 ("ntl" ,ntl)
428 ("python" ,python-2)
429 ("readline" ,readline)))
430 (arguments
431 `(#:configure-flags
432 (list (string-append "--with-ntl="
433 (assoc-ref %build-inputs "ntl")))))
434 (synopsis "Computer algebra system for polynomial computations")
435 (description
436 "Singular is a computer algebra system for polynomial computations,
437 with special emphasis on commutative and non-commutative algebra, algebraic
438 geometry and singularity theory.")
439 ;; Singular itself is dual licensed gpl2 or gpl3, but some of the
440 ;; libraries with which it links are licensed under lgpl3+, so the
441 ;; combined work becomes gpl3. See COPYING in the source code.
442 (license license:gpl3)
443 (home-page "http://www.singular.uni-kl.de/index.php")))
444
445 (define-public gmp-ecm
446 (package
447 (name "gmp-ecm")
448 (version "7.0.4")
449 (source (origin
450 (method url-fetch)
451 ;; Use the ‘Latest version’ link for a stable URI across releases.
452 (uri (string-append "https://gforge.inria.fr/frs/download.php/"
453 "latestfile/160/ecm-" version ".tar.gz"))
454 (sha256 (base32
455 "0hxs24c2m3mh0nq1zz63z3sb7dhy1rilg2s1igwwcb26x3pb7xqc"))))
456 (build-system gnu-build-system)
457 (inputs
458 `(("gmp" ,gmp)))
459 (arguments
460 `(#:configure-flags '("--enable-shared"
461 ;; Disable specific assembly routines, which depend
462 ;; on the subarchitecture of the build machine,
463 ;; and use gmp instead.
464 "--disable-asm-redc")))
465 (synopsis "Integer factorization library using the elliptic curve method")
466 (description
467 "GMP-ECM factors integers using the elliptic curve method (ECM) as well
468 as the P-1 and P+1 algorithms. It provides a library and a stand-alone
469 binary.")
470 ;; Most files are under lgpl3+, but some are under gpl3+ or gpl2+,
471 ;; so the combined work is under gpl3+.
472 (license license:gpl3+)
473 (home-page "http://ecm.gforge.inria.fr/")))
474
475 (define-public bc
476 (package
477 (name "bc")
478 (version "1.07.1")
479 (source (origin
480 (method url-fetch)
481 (uri (string-append "mirror://gnu/bc/bc-" version ".tar.gz"))
482 (sha256
483 (base32
484 "0amh9ik44jfg66csyvf4zz1l878c4755kjndq9j0270akflgrbb2"))))
485 (build-system gnu-build-system)
486 (native-inputs
487 `(("ed" ,ed)
488 ("flex" ,flex)
489 ("texinfo" ,texinfo)))
490 (arguments
491 '(#:configure-flags
492 (list "--with-readline")))
493 (home-page "https://www.gnu.org/software/bc/")
494 (synopsis "Arbitrary precision numeric processing language")
495 (description
496 "bc is an arbitrary precision numeric processing language. It includes
497 an interactive environment for evaluating mathematical statements. Its
498 syntax is similar to that of C, so basic usage is familiar. It also includes
499 \"dc\", a reverse-polish calculator.")
500 (license license:gpl2+)))
501
502 ;; The original kiss-fft does not have a complete build system and does not
503 ;; build any shared libraries. This is a fork used by Extempore.
504 (define-public kiss-fft-for-extempore
505 (package
506 (name "kiss-fft-for-extempore")
507 (version "1.3.0")
508 (source (origin
509 (method url-fetch)
510 (uri (string-append "https://github.com/extemporelang/kiss_fft/archive/"
511 version ".tar.gz"))
512 (file-name (string-append name "-" version ".tar.gz"))
513 (sha256
514 (base32
515 "0hkp9l6l4c92fb1l2sh6a6zv1hynpvb2s4d03vd8vxyvybc0l4pv"))))
516 (build-system cmake-build-system)
517 (arguments `(#:tests? #f)) ; no tests included
518 ;; Extempore refuses to build on architectures other than x86_64
519 (supported-systems '("x86_64-linux"))
520 (home-page "https://github.com/extemporelang/kiss_fft")
521 (synopsis "Mixed-radix Fast Fourier Transform")
522 (description
523 "Kiss FFT attempts to be a reasonably efficient, moderately useful FFT
524 that can use fixed or floating data types and can easily be incorporated into
525 a C program.")
526 (license license:bsd-3)))
527
528 (define-public fftw
529 (package
530 (name "fftw")
531 (version "3.3.7")
532 (source (origin
533 (method url-fetch)
534 (uri (string-append "ftp://ftp.fftw.org/pub/fftw/fftw-"
535 version".tar.gz"))
536 (sha256
537 (base32
538 "0wsms8narnbhfsa8chdflv2j9hzspvflblnqdn7hw8x5xdzrnq1v"))))
539 (build-system gnu-build-system)
540 (arguments
541 `(#:configure-flags
542 '("--enable-shared" "--enable-openmp" "--enable-threads"
543 ,@(let ((system (or (%current-target-system) (%current-system))))
544 ;; Enable SIMD extensions for codelets. See details at:
545 ;; <http://fftw.org/fftw3_doc/Installation-on-Unix.html>.
546 (cond
547 ((string-prefix? "x86_64" system)
548 '("--enable-sse2" "--enable-avx" "--enable-avx2"
549 "--enable-avx512" "--enable-avx-128-fma"))
550 ((string-prefix? "i686" system)
551 '("--enable-sse2"))
552 ((string-prefix? "aarch64" system)
553 ;; Note that fftw supports NEON on 32-bit ARM only when
554 ;; compiled for single-precision.
555 '("--enable-neon"))
556 (else
557 '())))
558 ;; By default '-mtune=native' is used. However, that may cause the
559 ;; use of ISA extensions (e.g. AVX) that are not necessarily
560 ;; available on the user's machine when that package is built on a
561 ;; different machine.
562 "ax_cv_c_flags__mtune_native=no")))
563 (native-inputs `(("perl" ,perl)))
564 (home-page "http://fftw.org")
565 (synopsis "Computing the discrete Fourier transform")
566 (description
567 "FFTW is a C subroutine library for computing the discrete Fourier
568 transform (DFT) in one or more dimensions, of arbitrary input size, and of
569 both real and complex data (as well as of even/odd data---i.e. the discrete
570 cosine/ sine transforms or DCT/DST).")
571 (license license:gpl2+)))
572
573 (define-public fftwf
574 (package (inherit fftw)
575 (name "fftwf")
576 (arguments
577 (substitute-keyword-arguments (package-arguments fftw)
578 ((#:configure-flags fftw-configure-flags)
579 `(cons* "--enable-single"
580 ,@(if (string-prefix? "arm" (or (%current-target-system)
581 (%current-system)))
582 ;; fftw supports NEON on 32-bit ARM only when compiled
583 ;; for single-precision, so add it here.
584 '("--enable-neon")
585 '())
586 ,fftw-configure-flags))))
587 (description
588 (string-append (package-description fftw)
589 " Single-precision version."))))
590
591 (define-public fftw-openmpi
592 (package (inherit fftw)
593 (name "fftw-openmpi")
594 (inputs
595 `(("openmpi" ,openmpi)
596 ,@(package-inputs fftw)))
597 (arguments
598 (substitute-keyword-arguments (package-arguments fftw)
599 ((#:configure-flags cf)
600 `(cons "--enable-mpi" ,cf))))
601 (description
602 (string-append (package-description fftw)
603 " With OpenMPI parallelism support."))))
604
605 (define-public java-la4j
606 (package
607 (name "java-la4j")
608 (version "0.6.0")
609 (source (origin
610 (method git-fetch)
611 (uri (git-reference
612 (url "https://github.com/vkostyukov/la4j.git")
613 (commit version)))
614 (file-name (string-append name "-" version "-checkout"))
615 (sha256
616 (base32
617 "1qir8dr978cfvz9k12m2kbdwpyf6cqdf1d0ilb7lnkhbgq5i53w3"))))
618 (build-system ant-build-system)
619 (arguments
620 `(#:jar-name "la4j.jar"
621 #:jdk ,icedtea-8
622 #:test-exclude (list "**/Abstract*.java"
623 "**/MatrixTest.java"
624 "**/DenseMatrixTest.java"
625 "**/SparseMatrixTest.java"
626 "**/VectorTest.java"
627 "**/SparseVectorTest.java"
628 "**/DenseVectorTest.java")))
629 (native-inputs
630 `(("java-junit" ,java-junit)
631 ("java-hamcrest-core" ,java-hamcrest-core)))
632 (home-page "http://la4j.org/")
633 (synopsis "Java library that provides Linear Algebra primitives and algorithms")
634 (description "The la4j library is a Java library that provides Linear
635 Algebra primitives (matrices and vectors) and algorithms. The key features of
636 the la4j library are:
637
638 @itemize
639 @item No dependencies and tiny size
640 @item Fluent object-oriented/functional API
641 @item Sparse (CRS, CCS) and dense (1D/2D arrays) matrices
642 @item Linear systems solving (Gaussian, Jacobi, Zeidel, Square Root, Sweep and other)
643 @item Matrices decomposition (Eigenvalues/Eigenvectors, SVD, QR, LU, Cholesky and other)
644 @item MatrixMarket/CSV IO formats support for matrices and vectors
645 @end itemize\n")
646 (license license:asl2.0)))
647
648 (define-public java-jlargearrays
649 (package
650 (name "java-jlargearrays")
651 (version "1.6")
652 (source (origin
653 (method url-fetch)
654 (uri (string-append "http://search.maven.org/remotecontent?"
655 "filepath=pl/edu/icm/JLargeArrays/"
656 version "/JLargeArrays-" version
657 "-sources.jar"))
658 (file-name (string-append name "-" version ".jar"))
659 (sha256
660 (base32
661 "0v05iphpxbjnd7f4jf1rlqq3m8hslhcm0imdbsgxr20pi3xkaf2a"))))
662 (build-system ant-build-system)
663 (arguments
664 `(#:jar-name "jlargearrays.jar"
665 #:tests? #f ; tests are not included in the release archive
666 #:jdk ,icedtea-8))
667 (propagated-inputs
668 `(("java-commons-math3" ,java-commons-math3)))
669 (home-page "https://gitlab.com/ICM-VisLab/JLargeArrays")
670 (synopsis "Library of one-dimensional arrays that can store up to 263 elements")
671 (description "JLargeArrays is a Java library of one-dimensional arrays
672 that can store up to 263 elements.")
673 (license license:bsd-2)))
674
675 (define-public java-jtransforms
676 (package
677 (name "java-jtransforms")
678 (version "3.1")
679 (source (origin
680 (method url-fetch)
681 (uri (string-append "http://search.maven.org/remotecontent?"
682 "filepath=com/github/wendykierp/JTransforms/"
683 version "/JTransforms-" version "-sources.jar"))
684 (sha256
685 (base32
686 "1haw5m8shv5srgcpwkl853dz8bv6h90bzlhcps6mdpb4cixjirsg"))))
687 (build-system ant-build-system)
688 (arguments
689 `(#:jar-name "jtransforms.jar"
690 #:tests? #f ; tests are not included in the release archive
691 #:jdk ,icedtea-8))
692 (propagated-inputs
693 `(("java-commons-math3" ,java-commons-math3)
694 ("java-jlargearrays" ,java-jlargearrays)))
695 (home-page "https://github.com/wendykierp/JTransforms")
696 (synopsis "Multithreaded FFT library written in pure Java")
697 (description "JTransforms is a multithreaded FFT library written in pure
698 Java. Currently, four types of transforms are available: @dfn{Discrete
699 Fourier Transform} (DFT), @dfn{Discrete Cosine Transform} (DCT), @dfn{Discrete
700 Sine Transform} (DST) and @dfn{Discrete Hartley Transform} (DHT).")
701 (license license:bsd-2)))
702
703 (define-public eigen
704 (package
705 (name "eigen")
706 (version "3.3.5")
707 (source (origin
708 (method url-fetch)
709 (uri (string-append "https://bitbucket.org/eigen/eigen/get/"
710 version ".tar.bz2"))
711 (sha256
712 (base32
713 "1qh3yrwn78ms5yhwbpl5wvblk4gbz02cacdygxylr7i9xbrvylkk"))
714 (file-name (string-append name "-" version ".tar.bz2"))
715 (modules '((guix build utils)))
716 (snippet
717 ;; There are 3 test failures in the "unsupported" directory,
718 ;; but maintainers say it's a known issue and it's unsupported
719 ;; anyway, so just skip them.
720 '(begin
721 (substitute* "unsupported/CMakeLists.txt"
722 (("add_subdirectory\\(test.*")
723 "# Do not build the tests for unsupported features.\n"))
724 #t))))
725 (build-system cmake-build-system)
726 (arguments
727 '(;; Turn off debugging symbols to save space.
728 #:build-type "Release"
729
730 #:phases (modify-phases %standard-phases
731 (replace 'check
732 (lambda _
733 (let* ((cores (parallel-job-count))
734 (dash-j (format #f "-j~a" cores)))
735 (setenv "EIGEN_SEED" "1") ;for reproducibility
736 ;; First build the tests, in parallel. See
737 ;; <http://eigen.tuxfamily.org/index.php?title=Tests>.
738 (invoke "make" "buildtests" dash-j)
739
740 ;; Then run 'CTest' with -V so we get more
741 ;; details upon failure.
742 (invoke "ctest" "-V" dash-j)))))))
743 (home-page "https://eigen.tuxfamily.org")
744 (synopsis "C++ template library for linear algebra")
745 (description
746 "Eigen is a C++ template library for linear algebra: matrices, vectors,
747 numerical solvers, and related algorithms. It provides an elegant API based
748 on \"expression templates\". It is versatile: it supports all matrix sizes,
749 all standard numeric types, various matrix decompositions and geometry
750 features, and more.")
751
752 ;; Most of the code is MPLv2, with a few files under LGPLv2.1+ or BSD-3.
753 ;; See 'COPYING.README' for details.
754 (license license:mpl2.0)))
755
756 (define-public xtensor
757 (package
758 (name "xtensor")
759 (version "0.17.1")
760 (source (origin
761 (method git-fetch)
762 (uri (git-reference
763 (url "https://github.com/QuantStack/xtensor.git")
764 (commit version)))
765 (sha256
766 (base32
767 "0w40v5lp0hp8ihf8nnvak373sb5xx0768pxgiqh3nzn57wf8px4r"))
768 (file-name (git-file-name name version))))
769 (build-system cmake-build-system)
770 (native-inputs
771 `(("googletest" ,googletest)
772 ("xtl" ,xtl)))
773 (arguments
774 `(#:configure-flags
775 '("-DBUILD_TESTS=ON")
776 #:test-target "xtest"))
777 (home-page "http://quantstack.net/xtensor")
778 (synopsis "C++ tensors with broadcasting and lazy computing")
779 (description "xtensor is a C++ library meant for numerical analysis with
780 multi-dimensional array expressions.
781
782 xtensor provides:
783 @itemize
784 @item an extensible expression system enabling lazy broadcasting.
785 @item an API following the idioms of the C++ standard library.
786 @item tools to manipulate array expressions and build upon xtensor.
787 @end itemize")
788 (license license:bsd-3)))