gnu: ratpoison: Install xsession file (ratpoison.desktop).
[jackhill/guix/guix.git] / gnu / packages / ratpoison.scm
1 ;;; GNU Guix --- Functional package management for GNU
2 ;;; Copyright © 2013, 2014 Ludovic Courtès <ludo@gnu.org>
3 ;;;
4 ;;; This file is part of GNU Guix.
5 ;;;
6 ;;; GNU Guix is free software; you can redistribute it and/or modify it
7 ;;; under the terms of the GNU General Public License as published by
8 ;;; the Free Software Foundation; either version 3 of the License, or (at
9 ;;; your option) any later version.
10 ;;;
11 ;;; GNU Guix is distributed in the hope that it will be useful, but
12 ;;; WITHOUT ANY WARRANTY; without even the implied warranty of
13 ;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
14 ;;; GNU General Public License for more details.
15 ;;;
16 ;;; You should have received a copy of the GNU General Public License
17 ;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
18
19 (define-module (gnu packages ratpoison)
20 #:use-module (guix packages)
21 #:use-module (guix download)
22 #:use-module (guix build-system gnu)
23 #:use-module ((guix licenses) #:select (gpl2+))
24 #:use-module (gnu packages)
25 #:use-module (gnu packages xorg)
26 #:use-module (gnu packages perl)
27 #:use-module (gnu packages readline)
28 #:use-module (gnu packages pkg-config)
29 #:use-module (gnu packages fontutils))
30
31 (define ratpoison.desktop
32 (origin
33 (method url-fetch)
34 (uri (string-append "http://sources.gentoo.org/cgi-bin/viewvc.cgi/"
35 "gentoo-x86/x11-wm/ratpoison/files/ratpoison.desktop"
36 "?revision=1.1"))
37 (file-name "ratpoison.desktop")
38 (sha256
39 (base32
40 "1rh3f4c3rhn6q2hmkraam0831xqcqyj3qkqf019ahaxsxaan3553"))))
41
42 (define-public ratpoison
43 (package
44 (name "ratpoison")
45 (version "1.4.6")
46 (source (origin
47 (method url-fetch)
48 (uri (string-append "mirror://savannah/ratpoison/ratpoison-"
49 version ".tar.xz"))
50 (sha256
51 (base32
52 "0v4mh8d3vsh5xbbycfdl3g8zfygi1rkslh1x7k5hi1d05bfq3cdr"))
53 (patches (list (search-patch "ratpoison-shell.patch")))))
54 (build-system gnu-build-system)
55 (arguments
56 '(#:phases
57 (alist-cons-after
58 'install 'install-xsession
59 (lambda _
60 (let* ((file (assoc-ref %build-inputs "ratpoison.desktop"))
61 (xsessions (string-append %output "/share/xsessions"))
62 (target (string-append xsessions "/ratpoison.desktop")))
63 (mkdir-p xsessions)
64 (copy-file file target)))
65 %standard-phases)))
66 (inputs
67 `(("libXi" ,libxi)
68 ("readline" ,readline)
69 ("xextproto" ,xextproto)
70 ("libXtst" ,libxtst)
71 ("freetype" ,freetype)
72 ("fontconfig" ,fontconfig)
73 ("libXft" ,libxft)
74 ("libXpm" ,libxpm)
75 ("libXt" ,libxt)
76 ("inputproto" ,inputproto)
77 ("libX11" ,libx11)
78 ("ratpoison.desktop" ,ratpoison.desktop)))
79 (native-inputs
80 `(("perl" ,perl)
81 ("pkg-config" ,pkg-config)))
82 (home-page "http://www.nongnu.org/ratpoison/")
83 (synopsis "Simple mouse-free tiling window manager")
84 (description
85 "Ratpoison is a simple window manager with no fat library
86 dependencies, no fancy graphics, no window decorations, and no
87 rodent dependence. It is largely modelled after GNU Screen which
88 has done wonders in the virtual terminal market.
89
90 The screen can be split into non-overlapping frames. All windows
91 are kept maximized inside their frames to take full advantage of
92 your precious screen real estate.
93
94 All interaction with the window manager is done through keystrokes.
95 Ratpoison has a prefix map to minimize the key clobbering that
96 cripples Emacs and other quality pieces of software.")
97 (license gpl2+)))