gnu: password-store: Don't run tests in parallel.
[jackhill/guix/guix.git] / gnu / packages / password-utils.scm
1 ;;; GNU Guix --- Functional package management for GNU
2 ;;; Copyright © 2015 Steve Sprang <scs@stevesprang.com>
3 ;;; Copyright © 2015, 2016 Efraim Flashner <efraim@flashner.co.il>
4 ;;; Copyright © 2015 Aljosha Papsch <misc@rpapsch.de>
5 ;;; Copyright © 2016 Christopher Allan Webber <cwebber@dustycloud.org>
6 ;;; Copyright © 2016 Jessica Tallon <tsyesika@tsyesika.se>
7 ;;; Copyright © 2016 Andreas Enge <andreas@enge.fr>
8 ;;; Copyright © 2016 Lukas Gradl <lgradl@openmailbox.org>
9 ;;; Copyright © 2016 Alex Griffin <a@ajgrf.com>
10 ;;;
11 ;;; This file is part of GNU Guix.
12 ;;;
13 ;;; GNU Guix is free software; you can redistribute it and/or modify it
14 ;;; under the terms of the GNU General Public License as published by
15 ;;; the Free Software Foundation; either version 3 of the License, or (at
16 ;;; your option) any later version.
17 ;;;
18 ;;; GNU Guix is distributed in the hope that it will be useful, but
19 ;;; WITHOUT ANY WARRANTY; without even the implied warranty of
20 ;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
21 ;;; GNU General Public License for more details.
22 ;;;
23 ;;; You should have received a copy of the GNU General Public License
24 ;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
25
26 (define-module (gnu packages password-utils)
27 #:use-module ((guix licenses) #:prefix license:)
28 #:use-module (guix build-system cmake)
29 #:use-module (guix build-system gnu)
30 #:use-module (guix download)
31 #:use-module (guix packages)
32 #:use-module (gnu packages)
33 #:use-module (gnu packages admin)
34 #:use-module (gnu packages base)
35 #:use-module (gnu packages compression)
36 #:use-module (gnu packages gnupg)
37 #:use-module (gnu packages gtk)
38 #:use-module (gnu packages guile)
39 #:use-module (gnu packages linux)
40 #:use-module (gnu packages man)
41 #:use-module (gnu packages ncurses)
42 #:use-module (gnu packages pkg-config)
43 #:use-module (gnu packages python)
44 #:use-module (gnu packages tls)
45 #:use-module (gnu packages qt)
46 #:use-module (gnu packages version-control)
47 #:use-module (gnu packages xdisorg)
48 #:use-module (gnu packages xorg)
49 #:use-module (guix build-system python))
50
51 (define-public pwgen
52 (package
53 (name "pwgen")
54 (version "2.07")
55 (source
56 (origin
57 (method url-fetch)
58 (uri (string-append "mirror://sourceforge/pwgen/pwgen/" version
59 "/pwgen-" version ".tar.gz"))
60 (sha256
61 (base32 "0mhmw700kkh238fzivcwnwi94bj9f3h36yfh3k3j2v19b0zmjx7b"))))
62 (build-system gnu-build-system)
63 (arguments
64 `(#:tests? #f)) ; no test suite
65 (home-page "http://pwgen.sourceforge.net/")
66 (synopsis "Password generator")
67 (description "Pwgen generates passwords which can be easily memorized by a
68 human.")
69 (license license:gpl2)))
70
71 (define-public keepassx
72 (package
73 (name "keepassx")
74 (version "2.0.3")
75 (source
76 (origin
77 (method url-fetch)
78 (uri (string-append "https://www.keepassx.org/releases/" version
79 "/keepassx-" version ".tar.gz"))
80 (sha256
81 (base32
82 "1ia7cqx9ias38mnffsl7da7g1f66bcbjsi23k49sln0c6spb9zr3"))))
83 (build-system cmake-build-system)
84 (inputs
85 `(("libgcrypt" ,libgcrypt)
86 ("libxi" ,libxi)
87 ("libxtst" ,libxtst)
88 ("qt" ,qt-4)))
89 (native-inputs
90 `(("zlib" ,zlib)))
91 (home-page "https://www.keepassx.org")
92 (synopsis "Password manager")
93 (description "KeePassX is a password manager or safe which helps you to
94 manage your passwords in a secure way. You can put all your passwords in one
95 database, which is locked with one master key or a key-file which can be stored
96 on an external storage device. The databases are encrypted using the
97 algorithms AES or Twofish.")
98 ;; Non functional parts use various licences.
99 (license license:gpl3)))
100
101 (define-public shroud
102 (package
103 (name "shroud")
104 (version "0.1.1")
105 (source (origin
106 (method url-fetch)
107 (uri (string-append "http://files.dthompson.us/shroud/shroud-"
108 version ".tar.gz"))
109 (sha256
110 (base32
111 "1y43yhgy2zbrk5bqj3qyx9rkcz2bma9sinlrg7dip3jqms9gq4lr"))))
112 (build-system gnu-build-system)
113 (arguments
114 '(#:phases
115 (modify-phases %standard-phases
116 (add-after 'install 'wrap-shroud
117 (lambda* (#:key outputs #:allow-other-keys)
118 (let* ((out (assoc-ref outputs "out"))
119 (ccachedir (string-append out "/lib/guile/2.0/ccache"))
120 (prog (string-append out "/bin/shroud")))
121 (wrap-program prog
122 `("GUILE_LOAD_COMPILED_PATH" ":" prefix (,ccachedir)))
123 #t))))))
124 (inputs
125 `(("guile" ,guile-2.0)
126 ("gnupg" ,gnupg)
127 ("xclip" ,xclip)))
128 (synopsis "GnuPG-based secret manager")
129 (description "Shroud is a simple secret manager with a command line
130 interface. The password database is stored as a Scheme s-expression and
131 encrypted with a GnuPG key. Secrets consist of an arbitrary number of
132 key/value pairs, making Shroud suitable for more than just password storage.
133 For copying and pasting secrets into web browsers and other graphical
134 applications, there is xclip integration." )
135 (home-page "http://dthompson.us/pages/software/shroud.html")
136 (license license:gpl3+)))
137
138 (define-public yapet
139 (package
140 (name "yapet")
141 (version "1.0")
142 (source (origin
143 (method url-fetch)
144 (uri (string-append "http://www.guengel.ch/myapps/yapet/downloads/yapet-"
145 version
146 ".tar.bz2"))
147 (sha256
148 (base32
149 "0ydbnqw6icdh07pnv2w6dhvq501bdfvrklv4xmyr8znca9d753if"))))
150 (build-system gnu-build-system)
151 (inputs
152 `(("ncurses" ,ncurses)
153 ("openssl" ,openssl)))
154 (native-inputs
155 `(("pkg-config" ,pkg-config)))
156 (synopsis "Yet Another Password Encryption Tool")
157 (description "YAPET is a text based password manager using the Blowfish
158 encryption algorithm. Because of its small footprint and very few library
159 dependencies, it is suited for installing on desktop and server systems alike.
160 The text based user interface allows you to run YAPET easily in a Secure Shell
161 session. Two companion utilities enable users to convert CSV files to YAPET
162 and vice versa.")
163 (home-page "http://www.guengel.ch/myapps/yapet/")
164 (license license:gpl3+)))
165
166 (define-public cracklib
167 (package
168 (name "cracklib")
169 (version "2.9.6")
170 (source (origin
171 (method url-fetch)
172 (uri (string-append "https://github.com/cracklib/cracklib/"
173 "releases/download/" name "-" version "/"
174 name "-" version ".tar.gz"))
175 (patches (search-patches "cracklib-CVE-2016-6318.patch"))
176 (sha256
177 (base32
178 "0hrkb0prf7n92w6rxgq0ilzkk6rkhpys2cfqkrbzswp27na7dkqp"))))
179 (build-system gnu-build-system)
180 (synopsis "Password checking library")
181 (home-page "https://github.com/cracklib/cracklib")
182 (description
183 "CrackLib is a library containing a C function which may be used in a
184 passwd like program. The idea is simple: try to prevent users from choosing
185 passwords that could be guessed by crack by filtering them out, at source.")
186 (license license:lgpl2.1)))
187
188 (define-public libpwquality
189 (package
190 (name "libpwquality")
191 (version "1.3.0")
192 (source (origin
193 (method url-fetch)
194 (uri (list
195 (string-append "https://fedorahosted.org/releases/l/i/"
196 name "/" name "-" version ".tar.bz2")
197 (string-append "https://launchpad.net/libpwquality/trunk/"
198 version "/+download/"
199 name "-" version ".tar.bz2")))
200 (sha256
201 (base32
202 "0aidriag6h0syfm33nzdfdsqgrnsgihwjv3a5lgkqch3w68fmlkl"))))
203 (build-system gnu-build-system)
204 (arguments
205 ;; XXX: have RUNPATH issue.
206 '(#:configure-flags '("--disable-python-bindings")))
207 (inputs
208 `(("cracklib" ,cracklib)))
209 (synopsis "Password quality checker")
210 (home-page "https://fedorahosted.org/libpwquality/")
211 (description
212 "Libpwquality is a library for password quality checking and generation of
213 random passwords that pass the checks.")
214 (license license:gpl2+)))
215
216 (define-public assword
217 (package
218 (name "assword")
219 (version "0.8")
220 (source (origin
221 (method url-fetch)
222 (uri (list
223 (string-append
224 "http://http.debian.net/debian/pool/main/a/assword/"
225 "assword_" version ".orig.tar.gz")))
226 (sha256
227 (base32
228 "0dl4wizbi0r21wxzykm8s445xbvqim5nabi799dmpkdnnh8i546i"))))
229 (arguments
230 `(#:python ,python-2
231 ;; irritatingly, tests do run but not there are two problems:
232 ;; - "import gtk" fails for unknown reasons here despite it the
233 ;; program working (indeed, I've found I have to do a logout and log
234 ;; back in in after an install order for some mumbo jumbo environment
235 ;; variable mess to work with pygtk and assword... what's up with
236 ;; that?)
237 ;; - even when the tests fail, they don't return a nonzero status,
238 ;; so I'm not sure how to programmatically get that information
239 #:tests? #f
240 #:phases
241 (modify-phases %standard-phases
242 (add-after 'install 'manpage
243 (lambda* (#:key outputs #:allow-other-keys)
244 (and
245 (zero? (system* "make" "assword.1"))
246 (install-file
247 "assword.1"
248 (string-append (assoc-ref outputs "out") "/share/man/man1"))))))))
249 (build-system python-build-system)
250 (native-inputs
251 `(("help2man" ,help2man)))
252 (inputs
253 `(("python2-xdo" ,python2-xdo)
254 ("python2-pygpgme" ,python2-pygpgme)
255 ("python2-pygtk" ,python2-pygtk)))
256 (propagated-inputs
257 `(("xclip" ,xclip)))
258 (home-page "https://finestructure.net/assword/")
259 (synopsis "Password manager")
260 (description "assword is a simple password manager using GPG-wrapped
261 JSON files. It has a command line interface as well as a very simple
262 graphical interface, which can even \"type\" your passwords into
263 any X11 window.")
264 (license license:gpl3+)))
265
266 (define-public password-store
267 (package
268 (name "password-store")
269 (version "1.6.5")
270 (source (origin
271 (method url-fetch)
272 (uri
273 (string-append "https://git.zx2c4.com/password-store/snapshot/"
274 name "-" version ".tar.xz"))
275 (sha256
276 (base32
277 "05bk3lrp5jwg0v338lvylp7glpliydzz4jf5pjr6k3kagrv3jyik"))))
278 (build-system gnu-build-system)
279 (arguments
280 '(#:phases
281 (modify-phases %standard-phases
282 (delete 'configure)
283 (delete 'build)
284 (add-after 'install 'wrap-path
285 (lambda* (#:key inputs outputs #:allow-other-keys)
286 (let ((out (assoc-ref outputs "out"))
287 (path (map (lambda (pkg)
288 (string-append (assoc-ref inputs pkg) "/bin"))
289 '("coreutils" "getopt" "git" "gnupg" "pwgen"
290 "sed" "tree" "which" "xclip"))))
291 (wrap-program (string-append out "/bin/pass")
292 `("PATH" ":" prefix (,(string-join path ":"))))))))
293 #:make-flags (list "CC=gcc" (string-append "PREFIX=" %output))
294 ;; Parallel tests may cause a race condition leading to a
295 ;; timeout in some circumstances.
296 #:parallel-tests? #f
297 #:test-target "test"))
298 (inputs
299 `(("getopt" ,util-linux)
300 ("git" ,git)
301 ("gnupg" ,gnupg)
302 ("pwgen" ,pwgen)
303 ("sed" ,sed)
304 ("tree" ,tree)
305 ("which" ,which)
306 ("xclip" ,xclip)))
307 (home-page "http://www.passwordstore.org/")
308 (synopsis "Encrypted password manager")
309 (description "Password-store is a password manager which uses GnuPG to
310 store and retrieve passwords. The tool stores each password in its own
311 GnuPG-encrypted file, allowing the program to be simple yet secure.
312 Synchronization is possible using the integrated git support, which commits
313 changes to your password database to a git repository that can be managed
314 through the pass command.")
315 (license license:gpl2+)))
316
317 (define-public argon2
318 (package
319 (name "argon2")
320 (version "20160406")
321 (source
322 (origin
323 (method url-fetch)
324 (uri
325 (string-append
326 "https://codeload.github.com/P-H-C/phc-winner-"
327 name "/tar.gz/" version))
328 (file-name (string-append name "-" version ".tar.gz"))
329 (sha256
330 (base32
331 "0g6wa94sh639xl1qc8z21q43r1mp8y77r1zf8nwx5pfsxd8fmyzv"))))
332 (build-system gnu-build-system)
333 (arguments
334 `(#:test-target "test"
335 #:make-flags '("CC=gcc")
336 #:phases
337 (modify-phases %standard-phases
338 (delete 'configure)
339 (replace 'install
340 (lambda _
341 (let ((out (assoc-ref %outputs "out")))
342 (install-file "argon2" (string-append out "/bin"))
343 (install-file "libargon2.a" (string-append out "/lib"))
344 (install-file "libargon2.so" (string-append out "/lib"))
345 (copy-recursively "include"
346 (string-append out "/include"))))))))
347 (home-page "https://www.argon2.com/")
348 (synopsis "Password hashing library")
349 (description "Argon2 provides a key derivation function that was declared
350 winner of the 2015 Password Hashing Competition.")
351 (license license:cc0)))
352
353 (define-public python-bcrypt
354 (package
355 (name "python-bcrypt")
356 (version "3.1.0")
357 (source
358 (origin
359 (method url-fetch)
360 (uri (pypi-uri "bcrypt" version))
361 (sha256
362 (base32
363 "1giy0dvd8gvq6flxh44np1v2nqwsji5qsnrz038mgwzgp7c20j75"))))
364 (build-system python-build-system)
365 (native-inputs
366 `(("python-pycparser" ,python-pycparser)
367 ("python-pytest" ,python-pytest)))
368 (propagated-inputs
369 `(("python-cffi" ,python-cffi)
370 ("python-six" ,python-six)))
371 (home-page "https://github.com/pyca/bcrypt/")
372 (synopsis
373 "Modern password hashing library")
374 (description
375 "Bcrypt is a Python module which provides a password hashing method based
376 on the Blowfish password hashing algorithm, as described in
377 @url{http://static.usenix.org/events/usenix99/provos.html,\"A Future-Adaptable
378 Password Scheme\"} by Niels Provos and David Mazieres.")
379 (license license:asl2.0)))
380
381 (define-public python2-bcrypt
382 (package-with-python2 python-bcrypt))