gnu: kio: Search 'smbd' on $PATH.
[jackhill/guix/guix.git] / gnu / packages / patches / tinyxml-use-stl.patch
1 From a53b6ee4519a7657164610ac14a82c57b1273bf6 Mon Sep 17 00:00:00 2001
2 From: David Thompson <dthompson2@worcester.edu>
3 Date: Mon, 23 Nov 2015 06:54:36 -0500
4 Subject: [PATCH] Use STL.
5
6 Software that uses the shared library, such as Kodi, assume that TinyXML was
7 compiled with STL activated.
8
9 ---
10 tinyxml.h | 2 ++
11 xmltest.cpp | 1 +
12 2 files changed, 3 insertions(+)
13
14 diff --git a/tinyxml.h b/tinyxml.h
15 index a3589e5..6cbfc7d 100644
16 --- a/tinyxml.h
17 +++ b/tinyxml.h
18 @@ -43,6 +43,8 @@ distribution.
19 #define DEBUG
20 #endif
21
22 +#define TIXML_USE_STL 1
23 +
24 #ifdef TIXML_USE_STL
25 #include <string>
26 #include <iostream>
27 diff --git a/xmltest.cpp b/xmltest.cpp
28 index 663c157..057dbfe 100644
29 --- a/xmltest.cpp
30 +++ b/xmltest.cpp
31 @@ -2,6 +2,7 @@
32 Test program for TinyXML.
33 */
34
35 +#define TIXML_USE_STL 1
36
37 #ifdef TIXML_USE_STL
38 #include <iostream>
39 --
40 2.5.0
41