gnu: kio: Search 'smbd' on $PATH.
[jackhill/guix/guix.git] / gnu / packages / patches / casync-renameat2-declaration.patch
1 Fix build failure on glibc 2.28 where 'renameat2' would end up being
2 declared twice: <https://github.com/systemd/casync/issues/166>.
3
4 From 625244ca47e8ee1375d2d0092271bfd13b0913ea Mon Sep 17 00:00:00 2001
5 From: Daniel Mack <daniel@zonque.org>
6 Date: Tue, 13 Nov 2018 17:52:48 +0100
7 Subject: [PATCH] meson.build: pass -D_GNU_SOURCE when checking for functions
8
9 As described in #166, -D_GNU_SOURCE needs to be passed to the meson function
10 availability checker. h/t to @tomeon for providing a link to the solution as
11 well.
12 ---
13 meson.build | 2 +-
14 1 file changed, 1 insertion(+), 1 deletion(-)
15
16 diff --git a/meson.build b/meson.build
17 index f42ed16..c0f741e 100644
18 --- a/meson.build
19 +++ b/meson.build
20 @@ -78,6 +78,6 @@ foreach ident : [
21 ['copy_file_range', '''#include <sys/syscall.h>
22 #include <unistd.h>'''],
23 ]
24 - have = cc.has_function(ident[0], prefix : ident[1])
25 + have = cc.has_function(ident[0], args : '-D_GNU_SOURCE', prefix : ident[1])
26 conf.set10('HAVE_' + ident[0].to_upper(), have)
27 endforeach