gnu: kio: Search 'smbd' on $PATH.
[jackhill/guix/guix.git] / gnu / packages / patches / byobu-writable-status.patch
1 Skeleton status files are installed read-only. When copying to the config dir
2 upon initialization, make sure they end up writable.
3
4 --- byobu-5.127/usr/bin/byobu-janitor.in
5 +++ byobu-5.127/usr/bin/byobu-janitor.in
6 @@ -82,6 +82,7 @@
7 if [ ! -r "$BYOBU_CONFIG_DIR/$f" ]; then
8 # Copy from skeleton, if possible
9 cp -f "$BYOBU_PREFIX/share/$PKG/status/$f" "$BYOBU_CONFIG_DIR/$f"
10 + chmod +w "$BYOBU_CONFIG_DIR/$f"
11 fi
12 done
13