gnu: Add Combinatorial BLAS.
[jackhill/guix/guix.git] / gnu / packages / patches / enlightenment-fix-setuid-path.patch
1 diff --git a/src/bin/e_auth.c b/src/bin/e_auth.c
2 index 00b0e5d84..98ab4518f 100644
3 --- a/src/bin/e_auth.c
4 +++ b/src/bin/e_auth.c
5 @@ -9,8 +9,7 @@ e_auth_begin(char *passwd)
6
7 if (strlen(passwd) == 0) goto out;
8
9 - snprintf(buf, sizeof(buf), "%s/enlightenment/utils/enlightenment_ckpasswd",
10 - e_prefix_lib_get());
11 + snprintf(buf, sizeof(buf), "/run/setuid-programs/enlightenment_ckpasswd");
12
13 exe = ecore_exe_pipe_run(buf, ECORE_EXE_PIPE_WRITE, NULL);
14 if (ecore_exe_send(exe, passwd, strlen(passwd)) != EINA_TRUE) goto out;
15 diff --git a/src/bin/e_backlight.c b/src/bin/e_backlight.c
16 index 2bced6766..208e583ba 100644
17 --- a/src/bin/e_backlight.c
18 +++ b/src/bin/e_backlight.c
19 @@ -521,8 +521,8 @@ _bl_sys_level_set(double val)
20 }
21 // fprintf(stderr, "SET: %1.3f\n", val);
22 snprintf(buf, sizeof(buf),
23 - "%s/enlightenment/utils/enlightenment_backlight %i %s",
24 - e_prefix_lib_get(), (int)(val * 1000.0), bl_sysval);
25 + "/run/setuid-programs/enlightenment_backlight %i %s",
26 + (int)(val * 1000.0), bl_sysval);
27 bl_sys_set_exe = ecore_exe_run(buf, NULL);
28 }
29 #endif // HAVE_EEZE || __FreeBSD_kernel__
30 diff --git a/src/bin/e_fm/e_fm_main_eeze.c b/src/bin/e_fm/e_fm_main_eeze.c
31 index b7d9e3eba..d8a9eb82c 100644
32 --- a/src/bin/e_fm/e_fm_main_eeze.c
33 +++ b/src/bin/e_fm/e_fm_main_eeze.c
34 @@ -318,7 +318,7 @@ _e_fm_main_eeze_volume_eject(E_Volume *v)
35 {
36 char buf[PATH_MAX];
37
38 - snprintf(buf, sizeof(buf), "%s/enlightenment/utils/enlightenment_sys", eina_prefix_lib_get(pfx));
39 + snprintf(buf, sizeof(buf), "/run/setuid-programs/enlightenment_sys");
40 eeze_disk_mount_wrapper_set(v->disk, buf);
41 }
42 v->guard = ecore_timer_loop_add(E_FM_EJECT_TIMEOUT, (Ecore_Task_Cb)_e_fm_main_eeze_vol_eject_timeout, v);
43 @@ -512,7 +512,7 @@ _e_fm_main_eeze_volume_unmount(E_Volume *v)
44 {
45 char buf[PATH_MAX];
46
47 - snprintf(buf, sizeof(buf), "%s/enlightenment/utils/enlightenment_sys", eina_prefix_lib_get(pfx));
48 + snprintf(buf, sizeof(buf), "/run/setuid-programs/enlightenment_sys");
49 eeze_disk_mount_wrapper_set(v->disk, buf);
50 }
51 v->guard = ecore_timer_loop_add(E_FM_UNMOUNT_TIMEOUT, (Ecore_Task_Cb)_e_fm_main_eeze_vol_unmount_timeout, v);
52 @@ -548,7 +548,7 @@ _e_fm_main_eeze_volume_mount(E_Volume *v)
53 {
54 char buf2[PATH_MAX];
55
56 - snprintf(buf2, sizeof(buf2), "%s/enlightenment/utils/enlightenment_sys", eina_prefix_lib_get(pfx));
57 + snprintf(buf2, sizeof(buf2), "/run/setuid-programs/enlightenment_sys");
58 eeze_disk_mount_wrapper_set(v->disk, buf2);
59 }
60 v->guard = ecore_timer_loop_add(E_FM_MOUNT_TIMEOUT, (Ecore_Task_Cb)_e_fm_main_eeze_vol_mount_timeout, v);
61 diff --git a/src/bin/e_sys.c b/src/bin/e_sys.c
62 index 6781a9b5a..8cd140f1b 100644
63 --- a/src/bin/e_sys.c
64 +++ b/src/bin/e_sys.c
65 @@ -653,20 +653,16 @@ _e_sys_cb_timer(void *data EINA_UNUSED)
66
67 e_init_status_set(_("Checking System Permissions"));
68 snprintf(buf, sizeof(buf),
69 - "%s/enlightenment/utils/enlightenment_sys -t halt",
70 - e_prefix_lib_get());
71 + "/run/setuid-programs/enlightenment_sys -t halt");
72 _e_sys_halt_check_exe = ecore_exe_run(buf, NULL);
73 snprintf(buf, sizeof(buf),
74 - "%s/enlightenment/utils/enlightenment_sys -t reboot",
75 - e_prefix_lib_get());
76 + "/run/setuid-programs/enlightenment_sys -t reboot");
77 _e_sys_reboot_check_exe = ecore_exe_run(buf, NULL);
78 snprintf(buf, sizeof(buf),
79 - "%s/enlightenment/utils/enlightenment_sys -t suspend",
80 - e_prefix_lib_get());
81 + "/run/setuid-programs/enlightenment_sys -t suspend");
82 _e_sys_suspend_check_exe = ecore_exe_run(buf, NULL);
83 snprintf(buf, sizeof(buf),
84 - "%s/enlightenment/utils/enlightenment_sys -t hibernate",
85 - e_prefix_lib_get());
86 + "/run/setuid-programs/enlightenment_sys -t hibernate");
87 _e_sys_hibernate_check_exe = ecore_exe_run(buf, NULL);
88 return ECORE_CALLBACK_CANCEL;
89 }
90 @@ -1079,8 +1075,7 @@ _e_sys_action_do(E_Sys_Action a, char *param EINA_UNUSED, Eina_Bool raw)
91 /* shutdown -h now */
92 if (e_util_immortal_check()) return 0;
93 snprintf(buf, sizeof(buf),
94 - "%s/enlightenment/utils/enlightenment_sys halt",
95 - e_prefix_lib_get());
96 + "/run/setuid-programs/enlightenment_sys halt");
97 if (_e_sys_exe)
98 {
99 if ((ecore_time_get() - _e_sys_begin_time) > 2.0)
100 @@ -1114,8 +1109,7 @@ _e_sys_action_do(E_Sys_Action a, char *param EINA_UNUSED, Eina_Bool raw)
101 /* shutdown -r now */
102 if (e_util_immortal_check()) return 0;
103 snprintf(buf, sizeof(buf),
104 - "%s/enlightenment/utils/enlightenment_sys reboot",
105 - e_prefix_lib_get());
106 + "/run/setuid-programs/enlightenment_sys reboot");
107 if (_e_sys_exe)
108 {
109 if ((ecore_time_get() - _e_sys_begin_time) > 2.0)
110 @@ -1148,8 +1142,7 @@ _e_sys_action_do(E_Sys_Action a, char *param EINA_UNUSED, Eina_Bool raw)
111 case E_SYS_SUSPEND:
112 /* /etc/acpi/sleep.sh force */
113 snprintf(buf, sizeof(buf),
114 - "%s/enlightenment/utils/enlightenment_sys suspend",
115 - e_prefix_lib_get());
116 + "/run/setuid-programs/enlightenment_sys suspend");
117 if (_e_sys_exe)
118 {
119 if ((ecore_time_get() - _e_sys_begin_time) > 2.0)
120 @@ -1208,8 +1201,7 @@ _e_sys_action_do(E_Sys_Action a, char *param EINA_UNUSED, Eina_Bool raw)
121 case E_SYS_HIBERNATE:
122 /* /etc/acpi/hibernate.sh force */
123 snprintf(buf, sizeof(buf),
124 - "%s/enlightenment/utils/enlightenment_sys hibernate",
125 - e_prefix_lib_get());
126 + "/run/setuid-programs/enlightenment_sys hibernate");
127 if (_e_sys_exe)
128 {
129 if ((ecore_time_get() - _e_sys_begin_time) > 2.0)
130 diff --git a/src/modules/bluez4/e_mod_main.c b/src/modules/bluez4/e_mod_main.c
131 index 4b5148634..47d34b07f 100644
132 --- a/src/modules/bluez4/e_mod_main.c
133 +++ b/src/modules/bluez4/e_mod_main.c
134 @@ -49,8 +49,8 @@ _ebluez_l2ping_poller(void *data EINA_UNUSED)
135
136 if (tmp)
137 {
138 - eina_strbuf_append_printf(buf, "%s/enlightenment/utils/enlightenment_sys l2ping %s",
139 - e_prefix_lib_get(), tmp);
140 + eina_strbuf_append_printf(buf, "/run/setuid-programs/enlightenment_sys l2ping %s",
141 + tmp);
142 autolock_exe = ecore_exe_run(eina_strbuf_string_get(buf), NULL);
143 }
144
145 @@ -692,8 +692,7 @@ e_modapi_init(E_Module *m)
146 autolock_desklock = ecore_event_handler_add(E_EVENT_DESKLOCK, _ebluez_desklock, NULL);
147
148 buf = eina_strbuf_new();
149 - eina_strbuf_append_printf(buf, "%s/enlightenment/utils/enlightenment_sys -t l2ping",
150 - e_prefix_lib_get());
151 + eina_strbuf_append_printf(buf, "/run/setuid-programs/enlightenment_sys -t l2ping");
152 autolock_exe = ecore_exe_run(eina_strbuf_string_get(buf), NULL);
153 eina_strbuf_free(buf);
154
155 diff --git a/src/modules/cpufreq/e_mod_main.c b/src/modules/cpufreq/e_mod_main.c
156 index f4ba259b6..ae228bae3 100644
157 --- a/src/modules/cpufreq/e_mod_main.c
158 +++ b/src/modules/cpufreq/e_mod_main.c
159 @@ -1450,8 +1450,7 @@ e_modapi_init(E_Module *m)
160 }
161 E_CONFIG_LIMIT(cpufreq_config->poll_interval, 1, 1024);
162
163 - snprintf(buf, sizeof(buf), "%s/%s/freqset",
164 - e_module_dir_get(m), MODULE_ARCH);
165 + snprintf(buf, sizeof(buf), "/run/setuid-programs/freqset");
166 cpufreq_config->set_exe_path = strdup(buf);
167
168 if (stat(buf, &st) < 0)