gnu: Add Hugs.
[jackhill/guix/guix.git] / gnu / packages / hugs.scm
1 ;;; GNU Guix --- Functional package management for GNU
2 ;;; Copyright © 2013 Nikita Karetnikov <nikita@karetnikov.org>
3 ;;;
4 ;;; This file is part of GNU Guix.
5 ;;;
6 ;;; GNU Guix is free software; you can redistribute it and/or modify it
7 ;;; under the terms of the GNU General Public License as published by
8 ;;; the Free Software Foundation; either version 3 of the License, or (at
9 ;;; your option) any later version.
10 ;;;
11 ;;; GNU Guix is distributed in the hope that it will be useful, but
12 ;;; WITHOUT ANY WARRANTY; without even the implied warranty of
13 ;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
14 ;;; GNU General Public License for more details.
15 ;;;
16 ;;; You should have received a copy of the GNU General Public License
17 ;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
18
19 (define-module (gnu packages hugs)
20 #:use-module (guix licenses)
21 #:use-module (guix packages)
22 #:use-module (guix download)
23 #:use-module (guix build-system gnu))
24
25 (define-public hugs
26 (package
27 (name "hugs")
28 (version "Sep2006")
29 (source
30 (origin
31 (method url-fetch)
32 (uri (string-append "http://cvs.haskell.org/Hugs/downloads/2006-09/"
33 name "98-plus-" version ".tar.gz"))
34 (sha256
35 (base32
36 "1mdy4aq4campgmnpc2qwq7bsbfhaxfsqdghbyyz2wms4lnfcmyma"))))
37 (build-system gnu-build-system)
38 (arguments
39 `(#:phases (alist-cons-before
40 'configure 'fix-sh-n-cp
41 (lambda _
42 (substitute*
43 '("configure"
44 "libraries/configure"
45 "packages/time/configure"
46 "packages/base/configure"
47 "packages/X11/configure"
48 "packages/HGL/configure"
49 "packages/OpenAL/configure"
50 "packages/OpenGL/configure"
51 "packages/network/configure"
52 "packages/unix/configure"
53 "packages/Cabal/tests/HSQL/configure"
54 "packages/ALUT/configure"
55 "packages/GLUT/configure"
56 "packages/base/cbits/execvpe.c"
57 "packages/base/System/Process/Internals.hs"
58 "packages/Cabal/Distribution/attic"
59 "packages/Cabal/Distribution/Simple/Register.hs"
60 "packages/Cabal/Distribution/Simple/Hugs.hs"
61 "tools/hugs-hc"
62 "src/machdep.c"
63 "libraries/Makefile.in")
64 (("/bin/sh") (which "sh")))
65 (substitute* '("demos/Makefile.in"
66 "libraries/Makefile.in")
67 (("/bin/cp") (which "cp"))))
68 %standard-phases)
69 #:tests? #f)) ; no test target
70 (home-page "http://haskell.org/hugs")
71 (synopsis "Functional programming system based on Haskell 98")
72 (description
73 "Hugs 98 is an interpreter and programming environment for developing
74 Haskell programs. It provides an almost complete implementation of Haskell
75 98, which includes expression and pattern syntax, primitives for monadic I/O,
76 with support for simple interactive programs, handle-based I/O, and exception
77 handling. Hugs has a nearly complete implementation of the Haskell module
78 system and supports a number of advanced extensions.")
79 (license (bsd-style "file://License"
80 "See License in the distribution."))))